summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-11-04 12:26:08 +0000
committerJustin Lecher <jlec@gentoo.org>2014-11-04 12:26:08 +0000
commit1a9630a2877f665c6ee4c08bc471d55458f7c767 (patch)
tree1387b6e2f3a8f665ec92a3b96443406b537e740b /net-analyzer/openvas-libraries
parentCleanup due #65870 (diff)
downloadgentoo-2-1a9630a2877f665c6ee4c08bc471d55458f7c767.tar.gz
gentoo-2-1a9630a2877f665c6ee4c08bc471d55458f7c767.tar.bz2
gentoo-2-1a9630a2877f665c6ee4c08bc471d55458f7c767.zip
net-analyzer/openvas-libraries: Version Bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'net-analyzer/openvas-libraries')
-rw-r--r--net-analyzer/openvas-libraries/ChangeLog7
-rw-r--r--net-analyzer/openvas-libraries/openvas-libraries-7.0.5.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/net-analyzer/openvas-libraries/ChangeLog b/net-analyzer/openvas-libraries/ChangeLog
index 745d0f745f96..8158823e690c 100644
--- a/net-analyzer/openvas-libraries/ChangeLog
+++ b/net-analyzer/openvas-libraries/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/openvas-libraries
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-libraries/ChangeLog,v 1.27 2014/10/22 23:12:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-libraries/ChangeLog,v 1.28 2014/11/04 12:26:08 jlec Exp $
+
+*openvas-libraries-7.0.5 (04 Nov 2014)
+
+ 04 Nov 2014; Justin Lecher <jlec@gentoo.org> +openvas-libraries-7.0.5.ebuild:
+ Version Bump
22 Oct 2014; Jeroen Roovers <jer@gentoo.org>
openvas-libraries-8.0_beta3.ebuild:
diff --git a/net-analyzer/openvas-libraries/openvas-libraries-7.0.5.ebuild b/net-analyzer/openvas-libraries/openvas-libraries-7.0.5.ebuild
new file mode 100644
index 000000000000..e795c5e53887
--- /dev/null
+++ b/net-analyzer/openvas-libraries/openvas-libraries-7.0.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-libraries/openvas-libraries-7.0.5.ebuild,v 1.1 2014/11/04 12:26:08 jlec Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DL_ID=1787
+
+DESCRIPTION="A remote security scanner for Linux (openvas-libraries)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/${DL_ID}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="ldap"
+
+RDEPEND="
+ >=dev-libs/glib-2.12
+ =net-libs/gnutls-2*
+ net-libs/libpcap
+ app-crypt/gpgme
+ !net-analyzer/openvas-libnasl
+ net-libs/libssh
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ dev-util/cmake"
+
+DOCS="ChangeLog CHANGES README"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.0.4-libssh.patch
+ "${FILESDIR}"/${PN}-7.0.4-bsdsource.patch
+ "${FILESDIR}"/${PN}-7.0.4-run.patch
+ )
+
+src_prepare() {
+ sed \
+ -e '/^install.*OPENVAS_CACHE_DIR.*/d' \
+ -i CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DLOCALSTATEDIR=${EPREFIX}/var"
+ "-DSYSCONFDIR=${EPREFIX}/etc"
+ $(cmake-utils_use_build ldap WITH_LDAP)
+ )
+ cmake-utils_src_configure
+}