summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2008-04-25 10:45:14 +0000
committerWolfram Schlich <wschlich@gentoo.org>2008-04-25 10:45:14 +0000
commitfa930d8068f961749d24542164835070308f3ce3 (patch)
tree1db83882a3911ed18fe85eedb147da63a08a0087 /net-analyzer/portbunny/portbunny-1.0.ebuild
parentversion bump (diff)
downloadgentoo-2-fa930d8068f961749d24542164835070308f3ce3.tar.gz
gentoo-2-fa930d8068f961749d24542164835070308f3ce3.tar.bz2
gentoo-2-fa930d8068f961749d24542164835070308f3ce3.zip
initial import
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'net-analyzer/portbunny/portbunny-1.0.ebuild')
-rw-r--r--net-analyzer/portbunny/portbunny-1.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-analyzer/portbunny/portbunny-1.0.ebuild b/net-analyzer/portbunny/portbunny-1.0.ebuild
new file mode 100644
index 000000000000..860490db6e73
--- /dev/null
+++ b/net-analyzer/portbunny/portbunny-1.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portbunny/portbunny-1.0.ebuild,v 1.1 2008/04/25 10:45:14 wschlich Exp $
+
+inherit eutils linux-mod
+
+MY_PV_SNAP=${PV##*_p}
+if [[ ${MY_PV_SNAP} != ${PV} ]]; then
+ MY_PV=${MY_PV_SNAP:6:2}${MY_PV_SNAP:4:2}${MY_PV_SNAP:2:2}
+ MY_P=PortBunny${MY_PV}
+ S="${WORKDIR}"/${MY_P}-dev
+else
+ MY_P=PortBunny-${PV}
+ S="${WORKDIR}"/${MY_P}
+fi
+
+MODULE_NAMES="portbunny(kernel:)"
+BUILD_TARGETS="all"
+
+DESCRIPTION="A kernel based highspeed TCP SYN port scanner"
+HOMEPAGE="http://recurity-labs.com/portbunny/"
+SRC_URI="http://recurity-labs.com/portbunny/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/python"
+
+src_install() {
+ insinto /usr/share/portbunny
+ doins UI/share/portbunny/*
+ dosed "s:^\(ETC_SERVICES\)[[:space:]]\+=.*:\1 = '/usr/share/portbunny/services':g" \
+ /usr/share/portbunny/PBunnyServices.py
+ dobin UI/bin/portbunny.py
+ dosym portbunny.py /usr/bin/portbunny
+ dosed "s:^\(PBUNNY_SHARE\)[[:space:]]\+=.*:\1 = '/usr/share/portbunny/':g" \
+ /usr/bin/portbunny.py
+ dosed "s:^\(PBUNNY_SHARE2\)[[:space:]]\+=.*:\1 = '/usr/share/portbunny/':g" \
+ /usr/bin/portbunny.py
+
+ linux-mod_src_install
+}
+
+pkg_postinst() {
+ einfo
+ einfo "See http://recurity-labs.com/portbunny/README.pdf"
+ einfo
+ ewarn
+ ewarn "WARNING"
+ ewarn "WARNING: this software may HARM the stability of your system!"
+ ewarn "WARNING: do NOT use this on production machines!"
+ ewarn "WARNING"
+ ewarn
+ ebeep 10
+}