summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-04-23 00:05:22 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-04-23 00:05:22 +0000
commit1be62fdfaad9aa41cb5d295e67817cf9de5756a3 (patch)
treeb13a7eb9b776a6513180862b5f20239bda324b52 /net-analyzer/portsentry/portsentry-1.1-r7.ebuild
parentChange supersed dependencies (diff)
downloadgentoo-2-1be62fdfaad9aa41cb5d295e67817cf9de5756a3.tar.gz
gentoo-2-1be62fdfaad9aa41cb5d295e67817cf9de5756a3.tar.bz2
gentoo-2-1be62fdfaad9aa41cb5d295e67817cf9de5756a3.zip
Change supersed dependencies
Diffstat (limited to 'net-analyzer/portsentry/portsentry-1.1-r7.ebuild')
-rw-r--r--net-analyzer/portsentry/portsentry-1.1-r7.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/net-analyzer/portsentry/portsentry-1.1-r7.ebuild b/net-analyzer/portsentry/portsentry-1.1-r7.ebuild
index 9085147e6d14..25ba7da70f29 100644
--- a/net-analyzer/portsentry/portsentry-1.1-r7.ebuild
+++ b/net-analyzer/portsentry/portsentry-1.1-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portsentry/portsentry-1.1-r7.ebuild,v 1.4 2003/02/13 13:49:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portsentry/portsentry-1.1-r7.ebuild,v 1.5 2003/04/23 00:02:57 lostlogic Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Automated port scan detector and response tool"
@@ -11,23 +11,23 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc "
-DEPEND="sys-apps/supersed"
+DEPEND="=sys-apps/sed-4*"
src_unpack() {
unpack ${A} ; cd ${S}
# Setting the portsentry.conf file location
- ssed -i -e 's:/usr/local/psionic/portsentry/portsentry.conf:/etc/portsentry/portsentry.conf:' \
+ sed -i -e 's:/usr/local/psionic/portsentry/portsentry.conf:/etc/portsentry/portsentry.conf:' \
portsentry_config.h
# presetting the other file locations in portsentry.conf
- ssed -i -e 's:\(^IGNORE_FILE\).*:\1="/etc/portsentry/portsentry.ignore":g' \
+ sed -i -e 's:\(^IGNORE_FILE\).*:\1="/etc/portsentry/portsentry.ignore":g' \
-e 's:^\(HISTORY_FILE\).*:\1="/etc/portsentry/portsentry.history":g' \
-e 's:^\(BLOCKED_FILE\).*:\1="/etc/portsentry/portsentry.blocked":g' \
portsentry.conf
- ssed -i "s:^set SENTRYDIR.*:set SENTRYDIR=/etc/portsentry:g" \
+ sed -i "s:^set SENTRYDIR.*:set SENTRYDIR=/etc/portsentry:g" \
ignore.csh
}