summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-27 15:51:42 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-27 15:51:42 +0000
commite1ee97efd673ad7a86b3f4f7fc275b861bcbc4e2 (patch)
tree8fb23616545ce18efdfff8674d263d6a8bc4bcd0 /net-analyzer/sinfo
parentStarting with 2.0.4-r1 swig works again... (diff)
downloadgentoo-2-e1ee97efd673ad7a86b3f4f7fc275b861bcbc4e2.tar.gz
gentoo-2-e1ee97efd673ad7a86b3f4f7fc275b861bcbc4e2.tar.bz2
gentoo-2-e1ee97efd673ad7a86b3f4f7fc275b861bcbc4e2.zip
Fix usage of autotool-utils (bug #392157).
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/sinfo')
-rw-r--r--net-analyzer/sinfo/ChangeLog5
-rw-r--r--net-analyzer/sinfo/sinfo-0.0.43.ebuild24
2 files changed, 19 insertions, 10 deletions
diff --git a/net-analyzer/sinfo/ChangeLog b/net-analyzer/sinfo/ChangeLog
index 0389ae117cc8..3383537e324b 100644
--- a/net-analyzer/sinfo/ChangeLog
+++ b/net-analyzer/sinfo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/sinfo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sinfo/ChangeLog,v 1.1 2011/11/26 11:18:39 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sinfo/ChangeLog,v 1.2 2011/11/27 15:51:42 radhermit Exp $
+
+ 27 Nov 2011; Tim Harder <radhermit@gentoo.org> sinfo-0.0.43.ebuild:
+ Fix usage of autotool-utils (bug #392157).
*sinfo-0.0.43 (26 Nov 2011)
diff --git a/net-analyzer/sinfo/sinfo-0.0.43.ebuild b/net-analyzer/sinfo/sinfo-0.0.43.ebuild
index a73dd6a784dd..9fbdf5e5b027 100644
--- a/net-analyzer/sinfo/sinfo-0.0.43.ebuild
+++ b/net-analyzer/sinfo/sinfo-0.0.43.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sinfo/sinfo-0.0.43.ebuild,v 1.1 2011/11/26 11:18:39 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sinfo/sinfo-0.0.43.ebuild,v 1.2 2011/11/27 15:51:42 radhermit Exp $
EAPI=4
-inherit eutils autotools-utils
+inherit autotools-utils
DESCRIPTION="A monitoring tool for networked computers"
HOMEPAGE="http://www.ant.uni-bremen.de/whomes/rinas/sinfo/"
@@ -20,23 +20,29 @@ RDEPEND="dev-libs/boost
DEPEND="${RDEPEND}
dev-cpp/asio"
-AUTOTOOLS_IN_SOURCE_BUILD=1
+#AUTOTOOLS_IN_SOURCE_BUILD=1
+DOCS=( AUTHORS ChangeLog README )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-librpc-linking.patch
+ "${FILESDIR}"/${P}-ncurses-m4.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-librpc-linking.patch
- epatch "${FILESDIR}"/${P}-ncurses-m4.patch
+ autotools-utils_src_prepare
eautoreconf
}
src_configure() {
- econf \
- --with-ncurses \
+ local myeconfargs=(
+ --with-ncurses
$(use_enable static-libs static)
+ )
+ autotools-utils_src_configure
}
src_install() {
- default
- remove_libtool_files
+ autotools-utils_src_install
newconfd "${FILESDIR}"/${PN}.confd ${PN}
newinitd "${FILESDIR}"/${PN}.initd ${PN}