summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-01-25 12:11:24 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-01-25 12:11:24 +0000
commit95fbd60787c81f032ae74d6a5c375d65d0a300ab (patch)
treebe69d154b1c00b9ecdd240fb2d3b24275b345b1a /net-analyzer/snort
parentgcc-2.95 patch as per bug #79032 (diff)
downloadgentoo-2-95fbd60787c81f032ae74d6a5c375d65d0a300ab.tar.gz
gentoo-2-95fbd60787c81f032ae74d6a5c375d65d0a300ab.tar.bz2
gentoo-2-95fbd60787c81f032ae74d6a5c375d65d0a300ab.zip
change shell of snort user to /bin/false as per bug #79216
(Portage version: 2.0.51-r14)
Diffstat (limited to 'net-analyzer/snort')
-rw-r--r--net-analyzer/snort/ChangeLog7
-rw-r--r--net-analyzer/snort/snort-2.0.6.ebuild6
-rw-r--r--net-analyzer/snort/snort-2.1.3.ebuild6
-rw-r--r--net-analyzer/snort/snort-2.2.0.ebuild6
-rw-r--r--net-analyzer/snort/snort-2.3.0_rc2.ebuild6
5 files changed, 18 insertions, 13 deletions
diff --git a/net-analyzer/snort/ChangeLog b/net-analyzer/snort/ChangeLog
index ad97f670763a..67082c7fa82f 100644
--- a/net-analyzer/snort/ChangeLog
+++ b/net-analyzer/snort/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/snort
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.56 2005/01/25 10:33:46 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.57 2005/01/25 12:11:24 dragonheart Exp $
+
+ 25 Jan 2005; Daniel Black <dragonheart@gentoo.org> snort-2.0.6.ebuild,
+ snort-2.1.3.ebuild, snort-2.2.0.ebuild, snort-2.3.0_rc2.ebuild:
+ change shell of snort user to /bin/false as per bug #79216. Thanks to Sascha
+ Nitsch <gentoobugs@linuxhowtos.org>
25 Jan 2005; Aaron Walker <ka0ttic@gentoo.org> snort-2.3.0_rc2.ebuild:
Run autoreconf since it looks like autogen.sh is no longer provided; fixes
diff --git a/net-analyzer/snort/snort-2.0.6.ebuild b/net-analyzer/snort/snort-2.0.6.ebuild
index 489400ab2c0a..3b4de7784072 100644
--- a/net-analyzer/snort/snort-2.0.6.ebuild
+++ b/net-analyzer/snort/snort-2.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.0.6.ebuild,v 1.8 2005/01/12 02:08:13 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.0.6.ebuild,v 1.9 2005/01/25 12:11:24 dragonheart Exp $
inherit eutils
@@ -97,10 +97,10 @@ src_install() {
pkg_postinst() {
enewgroup snort
- enewuser snort -1 /dev/null /var/log/snort snort
+ enewuser snort -1 /bin/false /var/log/snort snort
usermod -d "/var/log/snort" snort || die "usermod problem"
usermod -g "snort" snort || die "usermod problem"
- usermod -s "/dev/null" snort || die "usermod problem"
+ usermod -s "/bin/false" snort || die "usermod problem"
echo "ignore any message about CREATE_HOME above..."
chown snort:snort /var/log/snort
diff --git a/net-analyzer/snort/snort-2.1.3.ebuild b/net-analyzer/snort/snort-2.1.3.ebuild
index 57e37a9bd30f..046ddb08c975 100644
--- a/net-analyzer/snort/snort-2.1.3.ebuild
+++ b/net-analyzer/snort/snort-2.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.1.3.ebuild,v 1.9 2005/01/12 02:08:13 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.1.3.ebuild,v 1.10 2005/01/25 12:11:24 dragonheart Exp $
inherit eutils gnuconfig
@@ -98,10 +98,10 @@ src_compile() {
pkg_preinst() {
enewgroup snort
- enewuser snort -1 /dev/null /var/log/snort snort
+ enewuser snort -1 /bin/false /var/log/snort snort
usermod -d "/var/log/snort" snort || die "usermod problem"
usermod -g "snort" snort || die "usermod problem"
- usermod -s "/dev/null" snort || die "usermod problem"
+ usermod -s "/bin/false" snort || die "usermod problem"
echo "ignore any message about CREATE_HOME above..."
}
diff --git a/net-analyzer/snort/snort-2.2.0.ebuild b/net-analyzer/snort/snort-2.2.0.ebuild
index 8681f76a2e15..29e44adb7107 100644
--- a/net-analyzer/snort/snort-2.2.0.ebuild
+++ b/net-analyzer/snort/snort-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.2.0.ebuild,v 1.7 2005/01/12 02:08:13 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.2.0.ebuild,v 1.8 2005/01/25 12:11:24 dragonheart Exp $
inherit eutils gnuconfig
@@ -98,10 +98,10 @@ src_compile() {
pkg_preinst() {
enewgroup snort
- enewuser snort -1 /dev/null /var/log/snort snort
+ enewuser snort -1 /bin/false /var/log/snort snort
usermod -d "/var/log/snort" snort || die "usermod problem"
usermod -g "snort" snort || die "usermod problem"
- usermod -s "/dev/null" snort || die "usermod problem"
+ usermod -s "/bin/false" snort || die "usermod problem"
echo "ignore any message about CREATE_HOME above..."
}
diff --git a/net-analyzer/snort/snort-2.3.0_rc2.ebuild b/net-analyzer/snort/snort-2.3.0_rc2.ebuild
index 741a553b9379..fb059df381df 100644
--- a/net-analyzer/snort/snort-2.3.0_rc2.ebuild
+++ b/net-analyzer/snort/snort-2.3.0_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.3.0_rc2.ebuild,v 1.5 2005/01/25 10:33:46 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.3.0_rc2.ebuild,v 1.6 2005/01/25 12:11:24 dragonheart Exp $
inherit eutils gnuconfig
@@ -91,10 +91,10 @@ src_compile() {
pkg_preinst() {
enewgroup snort
- enewuser snort -1 /dev/null /var/log/snort snort
+ enewuser snort -1 /bin/false /var/log/snort snort
usermod -d "/var/log/snort" snort || die "usermod problem"
usermod -g "snort" snort || die "usermod problem"
- usermod -s "/dev/null" snort || die "usermod problem"
+ usermod -s "/bin/false" snort || die "usermod problem"
echo "ignore any message about CREATE_HOME above..."
}