summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-12-15 19:15:05 +0000
committerFabian Groffen <grobian@gentoo.org>2011-12-15 19:15:05 +0000
commit6689259d9af0a0fff2e7374e385c2110c7f0f345 (patch)
tree65f22659fed429148654a7f6f5d5ac8ce2224187 /net-analyzer/wireshark
parentAdd an ebuild for /bin/sh eselect module per bug #214817. (diff)
downloadgentoo-2-6689259d9af0a0fff2e7374e385c2110c7f0f345.tar.gz
gentoo-2-6689259d9af0a0fff2e7374e385c2110c7f0f345.tar.bz2
gentoo-2-6689259d9af0a0fff2e7374e385c2110c7f0f345.zip
Use EPREFIX/EROOT, bug #321309
(Portage version: 2.2.01.19941-prefix/cvs/Darwin i386)
Diffstat (limited to 'net-analyzer/wireshark')
-rw-r--r--net-analyzer/wireshark/ChangeLog5
-rw-r--r--net-analyzer/wireshark/wireshark-1.6.4.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index da952b814482..df9448008b10 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.323 2011/12/14 17:21:14 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.324 2011/12/15 19:15:05 grobian Exp $
+
+ 15 Dec 2011; Fabian Groffen <grobian@gentoo.org> wireshark-1.6.4.ebuild:
+ Use EPREFIX/EROOT, bug #321309
14 Dec 2011; Agostino Sarubbo <ago@gentoo.org> wireshark-1.6.4.ebuild:
Stable for AMD64, wrt security bug #389255
diff --git a/net-analyzer/wireshark/wireshark-1.6.4.ebuild b/net-analyzer/wireshark/wireshark-1.6.4.ebuild
index 2b7f6007e399..0e776aa27e50 100644
--- a/net-analyzer/wireshark/wireshark-1.6.4.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.6.4.ebuild,v 1.4 2011/12/14 17:21:14 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.6.4.ebuild,v 1.5 2011/12/15 19:15:05 grobian Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
@@ -167,7 +167,7 @@ src_configure() {
$(use_with pcap dumpcap-group wireshark) \
$(use pcap && use_enable caps setcap-install) \
$(use pcap && use_enable !caps setuid-install) \
- --sysconfdir=/etc/wireshark \
+ --sysconfdir="${EPREFIX}"/etc/wireshark \
--disable-extra-gcc-checks \
${myconf}
}
@@ -208,7 +208,7 @@ src_install() {
pkg_postinst() {
if use caps && use pcap; then
- fcaps 0:wireshark 550 cap_net_raw,cap_net_admin "${ROOT}"/usr/bin/dumpcap
+ fcaps 0:wireshark 550 cap_net_raw,cap_net_admin "${EROOT}"/usr/bin/dumpcap
fi
echo
ewarn "NOTE: To run wireshark as normal user you have to add yourself to"