summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-02-12 00:14:43 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-02-12 00:14:43 +0000
commit5483d26acb508119fc89f364fb9e9b12c635c4bb (patch)
tree36c81be1532dc56790885908ae7e7e342bb6e0cd /net-analyzer/zabbix-agent
parentMore fixes for 165482 (diff)
downloadgentoo-2-5483d26acb508119fc89f364fb9e9b12c635c4bb.tar.gz
gentoo-2-5483d26acb508119fc89f364fb9e9b12c635c4bb.tar.bz2
gentoo-2-5483d26acb508119fc89f364fb9e9b12c635c4bb.zip
version bump
(Portage version: 2.1.2)
Diffstat (limited to 'net-analyzer/zabbix-agent')
-rw-r--r--net-analyzer/zabbix-agent/ChangeLog11
-rw-r--r--net-analyzer/zabbix-agent/files/1.1.6/init.d/zabbix-agentd22
-rw-r--r--net-analyzer/zabbix-agent/files/1.1.6/zabbix_agent.conf25
-rw-r--r--net-analyzer/zabbix-agent/files/1.1.6/zabbix_agentd.conf70
-rw-r--r--net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.02
-rw-r--r--net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1.63
-rw-r--r--net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1_alpha72
-rw-r--r--net-analyzer/zabbix-agent/zabbix-agent-1.1.6.ebuild81
8 files changed, 214 insertions, 2 deletions
diff --git a/net-analyzer/zabbix-agent/ChangeLog b/net-analyzer/zabbix-agent/ChangeLog
index 58c13fa8830d..8e5391c6e6cb 100644
--- a/net-analyzer/zabbix-agent/ChangeLog
+++ b/net-analyzer/zabbix-agent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/zabbix-agent
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-agent/ChangeLog,v 1.8 2006/10/14 09:46:09 corsair Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-agent/ChangeLog,v 1.9 2007/02/12 00:14:43 wschlich Exp $
+
+*zabbix-agent-1.1.6 (12 Feb 2007)
+
+ 12 Feb 2007; Wolfram Schlich <wschlich@gentoo.org>
+ +files/1.1.6/init.d/zabbix-agentd, +files/1.1.6/zabbix_agent.conf,
+ +files/1.1.6/zabbix_agentd.conf, +zabbix-agent-1.1.6.ebuild:
+ version bump
14 Oct 2006; Markus Rothe <corsair@gentoo.org> zabbix-agent-1.1-r1.ebuild:
Added ~ppc64; bug #151046
diff --git a/net-analyzer/zabbix-agent/files/1.1.6/init.d/zabbix-agentd b/net-analyzer/zabbix-agent/files/1.1.6/init.d/zabbix-agentd
new file mode 100644
index 000000000000..9017faf8deb5
--- /dev/null
+++ b/net-analyzer/zabbix-agent/files/1.1.6/init.d/zabbix-agentd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-agent/files/1.1.6/init.d/zabbix-agentd,v 1.1 2007/02/12 00:14:43 wschlich Exp $
+
+depend() {
+ need net
+ provide zabbix-agent
+ use zabbix-server
+}
+
+start() {
+ ebegin "Starting Zabbix agent"
+ start-stop-daemon --start -c zabbix:zabbix --exec /usr/sbin/zabbix_agentd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Zabbix agent"
+ start-stop-daemon --stop -u zabbix --pidfile /var/run/zabbix/zabbix_agentd.pid
+ eend $?
+}
diff --git a/net-analyzer/zabbix-agent/files/1.1.6/zabbix_agent.conf b/net-analyzer/zabbix-agent/files/1.1.6/zabbix_agent.conf
new file mode 100644
index 000000000000..42997388900e
--- /dev/null
+++ b/net-analyzer/zabbix-agent/files/1.1.6/zabbix_agent.conf
@@ -0,0 +1,25 @@
+# This is config file for zabbix_agent
+# To get more information about ZABBIX,
+# go http://www.zabbix.com
+
+# IP address of ZABBIX server
+# Connections from other hosts will be denied
+Server=127.0.0.1
+
+# Spend no more than Timeout seconds on processing
+# Must be between 1 and 30
+Timeout=3
+
+####### USER-DEFINED MONITORED PARAMETERS #######
+# Format: UserParameter=<key>,<shell command>
+# Note that shell command must not return empty string or EOL only
+#UserParameter=system.test,who|wc -l
+### Set of parameter for monitoring MySQL server (v3.23.42 and later)
+### Change -u<username> and add -p<password> if required
+#UserParameter=mysql.ping,mysqladmin -uroot ping|grep alive|wc -l
+#UserParameter=mysql.uptime,mysqladmin -uroot status|cut -f2 -d":"|cut -f1 -d"T"
+#UserParameter=mysql.threads,mysqladmin -uroot status|cut -f3 -d":"|cut -f1 -d"Q"
+#UserParameter=mysql.questions,mysqladmin -uroot status|cut -f4 -d":"|cut -f1 -d"S"
+#UserParameter=mysql.slowqueries,mysqladmin -uroot status|cut -f5 -d":"|cut -f1 -d"O"
+#UserParameter=mysql.qps,mysqladmin -uroot status|cut -f9 -d":"
+#UserParameter=mysql.version,mysql -V
diff --git a/net-analyzer/zabbix-agent/files/1.1.6/zabbix_agentd.conf b/net-analyzer/zabbix-agent/files/1.1.6/zabbix_agentd.conf
new file mode 100644
index 000000000000..e040f17efcc9
--- /dev/null
+++ b/net-analyzer/zabbix-agent/files/1.1.6/zabbix_agentd.conf
@@ -0,0 +1,70 @@
+# This is config file for zabbix_agentd
+# To get more information about ZABBIX, go http://www.zabbix.com
+
+############ GENERAL PARAMETERS #################
+
+# List of comma delimited IP addresses (or hostnames) of ZABBIX servers.
+# No spaces allowed. First entry is used for sending active checks.
+# Note that hostnames must resolve hostname->IP address and
+# IP address->hostname.
+Server=127.0.0.1
+
+# Server port for sending active checks
+ServerPort=10051
+
+# Unique hostname. Required for active checks.
+Hostname=localhost
+
+# Listen port. Default is 10050
+ListenPort=10050
+
+# IP address to bind agent
+# If missing, bind to all available IPs
+ListenIP=127.0.0.1
+
+# Number of pre-forked instances of zabbix_agentd.
+# Default value is 5
+# This parameter must be between 1 and 16
+StartAgents=5
+
+# How often refresh list of active checks. 2 minutes by default.
+#RefreshActiveChecks=120
+
+# Disable active checks. The agent will work in passive mode listening server.
+#DisableActive=1
+
+# Enable remote commands for ZABBIX agent. By default remote commands disabled.
+#EnableRemoteCommands=1
+
+# Specifies debug level
+# 0 - debug is not created
+# 1 - critical information
+# 2 - error information
+# 3 - warnings (default)
+# 4 - for debugging (produces lots of information)
+DebugLevel=3
+
+# Name of PID file
+PidFile=/var/run/zabbix/zabbix_agentd.pid
+
+# Name of log file.
+# If not set, syslog will be used
+LogFile=/var/log/zabbix/zabbix_agentd.log
+
+# Spend no more than Timeout seconds on processing
+# Must be between 1 and 30
+Timeout=3
+
+####### USER-DEFINED MONITORED PARAMETERS #######
+# Format: UserParameter=<key>,<shell command>
+# Note that shell command must not return empty string or EOL only
+#UserParameter=system.test,who|wc -l
+### Set of parameter for monitoring MySQL server (v3.23.42 and later)
+### Change -u<username> and add -p<password> if required
+#UserParameter=mysql.ping,mysqladmin -uroot ping|grep alive|wc -l
+#UserParameter=mysql.uptime,mysqladmin -uroot status|cut -f2 -d":"|cut -f1 -d"T"
+#UserParameter=mysql.threads,mysqladmin -uroot status|cut -f3 -d":"|cut -f1 -d"Q"
+#UserParameter=mysql.questions,mysqladmin -uroot status|cut -f4 -d":"|cut -f1 -d"S"
+#UserParameter=mysql.slowqueries,mysqladmin -uroot status|cut -f5 -d":"|cut -f1 -d"O"
+#UserParameter=mysql.qps,mysqladmin -uroot status|cut -f9 -d":"
+#UserParameter=mysql.version,mysql -V
diff --git a/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.0 b/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.0
index 283aa4fd7570..1a7147a3734e 100644
--- a/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.0
+++ b/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.0
@@ -1 +1,3 @@
MD5 e83a3b92f13942081ed2f3fe3f3084d8 zabbix-1.0.tar.gz 1847471
+RMD160 b09b509a05adf1962449356e6a24a9b36a7c914b zabbix-1.0.tar.gz 1847471
+SHA256 3368a2bd825fdc32075b469779037e556b3d02b64bcf8412cd3b8988cafb5e2e zabbix-1.0.tar.gz 1847471
diff --git a/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1.6 b/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1.6
new file mode 100644
index 000000000000..aede6b7cd4dd
--- /dev/null
+++ b/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1.6
@@ -0,0 +1,3 @@
+MD5 baa6896c5f41ed286bca3c40e419e1cf zabbix-1.1.6.tar.gz 1541835
+RMD160 93694315a710811631591554807d571de25922c6 zabbix-1.1.6.tar.gz 1541835
+SHA256 348b395df68a808c25cb96287bbb0460e531e46049b6be1bd5be236365022281 zabbix-1.1.6.tar.gz 1541835
diff --git a/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1_alpha7 b/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1_alpha7
index bee9b9502bd8..712004c058ef 100644
--- a/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1_alpha7
+++ b/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1_alpha7
@@ -1 +1,3 @@
MD5 a900c9838075690a8d04849cda42c67c zabbix-1.1alpha7.tar.gz 654347
+RMD160 2d888d1b22c44d8acd0feb41b51fc14f1c5da357 zabbix-1.1alpha7.tar.gz 654347
+SHA256 31509e7106c2ff6f197a298b5c8256e24d9b0c9dd9d1d7fe1d81c49393ea471d zabbix-1.1alpha7.tar.gz 654347
diff --git a/net-analyzer/zabbix-agent/zabbix-agent-1.1.6.ebuild b/net-analyzer/zabbix-agent/zabbix-agent-1.1.6.ebuild
new file mode 100644
index 000000000000..8f3094e6d0f7
--- /dev/null
+++ b/net-analyzer/zabbix-agent/zabbix-agent-1.1.6.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-agent/zabbix-agent-1.1.6.ebuild,v 1.1 2007/02/12 00:14:43 wschlich Exp $
+
+inherit eutils
+
+MY_P=${PN//-agent/}
+MY_PV=${PV//_/}
+DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers. Agent part."
+HOMEPAGE="http://www.zabbix.com/"
+SRC_URI="mirror://sourceforge/zabbix/${MY_P}-${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${MY_P}-${MY_PV}
+
+pkg_setup() {
+ enewgroup zabbix
+ enewuser zabbix -1 -1 /dev/null zabbix
+}
+pkg_postinst() {
+ # repeat fowners/fperms functionality from src_install()
+ # here to catch wrong permissions on existing files in
+ # the live filesystem (yeah, that sucks).
+ chown zabbix:zabbix \
+ ${ROOT}etc/zabbix \
+ ${ROOT}etc/zabbix/zabbix_agent.conf \
+ ${ROOT}etc/zabbix/zabbix_agentd.conf \
+ ${ROOT}var/log/zabbix \
+ ${ROOT}var/run/zabbix
+ chmod 0750 \
+ ${ROOT}etc/zabbix \
+ ${ROOT}var/log/zabbix \
+ ${ROOT}var/run/zabbix
+ chmod 0640 \
+ ${ROOT}etc/zabbix/zabbix_agent.conf \
+ ${ROOT}etc/zabbix/zabbix_agentd.conf
+}
+
+src_compile() {
+ econf --enable-agent || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir \
+ /etc/zabbix \
+ /var/log/zabbix \
+ /var/run/zabbix
+ keepdir \
+ /etc/zabbix \
+ /var/log/zabbix \
+ /var/run/zabbix
+ insinto /etc/zabbix
+ doins \
+ ${FILESDIR}/${PV}/zabbix_agent.conf \
+ ${FILESDIR}/${PV}/zabbix_agentd.conf
+ doinitd ${FILESDIR}/${PV}/init.d/zabbix-agentd
+ dosbin \
+ src/zabbix_agent/zabbix_agent \
+ src/zabbix_agent/zabbix_agentd
+ dobin \
+ src/zabbix_sender/zabbix_sender \
+ src/zabbix_get/zabbix_get
+ fowners zabbix:zabbix \
+ /etc/zabbix \
+ /etc/zabbix/zabbix_agent.conf \
+ /etc/zabbix/zabbix_agentd.conf \
+ /var/log/zabbix \
+ /var/run/zabbix
+ fperms 0750 \
+ /etc/zabbix \
+ /var/log/zabbix \
+ /var/run/zabbix
+ fperms 0640 \
+ /etc/zabbix/zabbix_agent.conf \
+ /etc/zabbix/zabbix_agentd.conf
+}