summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-17 03:53:49 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-17 03:53:49 +0000
commitf6bba75d2f84a457eb0a3c78cca0e8d3dc69005a (patch)
treeb65267c8bdeaec882c93915db08a437fb3bb2ef2 /net-analyzer/zniper
parentFix whitespace. (diff)
downloadgentoo-2-f6bba75d2f84a457eb0a3c78cca0e8d3dc69005a.tar.gz
gentoo-2-f6bba75d2f84a457eb0a3c78cca0e8d3dc69005a.tar.bz2
gentoo-2-f6bba75d2f84a457eb0a3c78cca0e8d3dc69005a.zip
Set RDEPEND. Respect LDFLAGS (bug #337738), CC, CFLAGS. Fix parallel make.
(Portage version: 2.2_rc82/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/zniper')
-rw-r--r--net-analyzer/zniper/ChangeLog10
-rw-r--r--net-analyzer/zniper/zniper-1.0-r1.ebuild (renamed from net-analyzer/zniper/zniper-1.0.ebuild)22
2 files changed, 27 insertions, 5 deletions
diff --git a/net-analyzer/zniper/ChangeLog b/net-analyzer/zniper/ChangeLog
index 1bdf5ad362fc..db4f14d68177 100644
--- a/net-analyzer/zniper/ChangeLog
+++ b/net-analyzer/zniper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/zniper
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zniper/ChangeLog,v 1.2 2007/10/29 15:11:43 jokey Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zniper/ChangeLog,v 1.3 2010/09/17 03:53:49 jer Exp $
+
+*zniper-1.0-r1 (17 Sep 2010)
+
+ 17 Sep 2010; Jeroen Roovers <jer@gentoo.org> -zniper-1.0.ebuild,
+ +zniper-1.0-r1.ebuild:
+ Set RDEPEND. Respect LDFLAGS (bug #337738), CC, CFLAGS. Fix parallel make.
29 Oct 2007; Markus Ullmann <jokey@gentoo.org> metadata.xml:
developed to end, reassigning to herd
diff --git a/net-analyzer/zniper/zniper-1.0.ebuild b/net-analyzer/zniper/zniper-1.0-r1.ebuild
index f31355775a4c..dc47b3c2e381 100644
--- a/net-analyzer/zniper/zniper-1.0.ebuild
+++ b/net-analyzer/zniper/zniper-1.0-r1.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zniper/zniper-1.0.ebuild,v 1.1 2007/04/07 18:23:53 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zniper/zniper-1.0-r1.ebuild,v 1.1 2010/09/17 03:53:49 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
DESCRIPTION="Displays and kill active TCP connections seen by the selected interface."
HOMEPAGE="http://www.signedness.org/tools/"
@@ -13,11 +17,23 @@ IUSE=""
DEPEND="net-libs/libpcap
sys-libs/ncurses"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/"zniper"
+src_prepare() {
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ -e 's|@make|@$(MAKE)|g' \
+ || die "sed Makefile"
+}
+
src_compile() {
- emake -j1 linux_x86 || die "emake failed"
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ linux_x86 \
+ || die "emake failed"
}
src_install() {