summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-10-21 15:42:15 +0000
committerJon Hood <squinky86@gentoo.org>2006-10-21 15:42:15 +0000
commit618356c11be0e6cf6c8af781aadc186c804267ee (patch)
tree85f8fcc11c385b87f73cd3c9de2ed7c5577d653b /net-analyzer
parentAdd ~x86-fbsd keyword. (diff)
downloadgentoo-2-618356c11be0e6cf6c8af781aadc186c804267ee.tar.gz
gentoo-2-618356c11be0e6cf6c8af781aadc186c804267ee.tar.bz2
gentoo-2-618356c11be0e6cf6c8af781aadc186c804267ee.zip
Version bump, remove needless sed and dodoc.
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/httping/ChangeLog7
-rw-r--r--net-analyzer/httping/files/digest-httping-1.2.13
-rw-r--r--net-analyzer/httping/httping-1.2.1.ebuild33
3 files changed, 42 insertions, 1 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 47a4b42b6fce..294b4f35aff7 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.26 2006/07/22 20:25:50 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.27 2006/10/21 15:42:15 squinky86 Exp $
+
+*httping-1.2.1 (21 Oct 2006)
+
+ 21 Oct 2006; Jon Hood <squinky86@gentoo.org> +httping-1.2.1.ebuild:
+ Version bump, remove needless sed and dodoc.
22 Jul 2006; Marcelo Goes <vanquirius@gentoo.org> -httping-1.0.8.ebuild:
Remove old ebuild.
diff --git a/net-analyzer/httping/files/digest-httping-1.2.1 b/net-analyzer/httping/files/digest-httping-1.2.1
new file mode 100644
index 000000000000..bb3456ff8d9e
--- /dev/null
+++ b/net-analyzer/httping/files/digest-httping-1.2.1
@@ -0,0 +1,3 @@
+MD5 71a5d0d3f53867d0c990a608d7d679bd httping-1.2.1.tgz 12789
+RMD160 e150f3f369e5d5ea114f58ab725e41fce81b92ae httping-1.2.1.tgz 12789
+SHA256 53c243de88023f398a7ff76b99b2b9430f53222864d30b33a3f674b3c8b29317 httping-1.2.1.tgz 12789
diff --git a/net-analyzer/httping/httping-1.2.1.ebuild b/net-analyzer/httping/httping-1.2.1.ebuild
new file mode 100644
index 000000000000..3f44d32372f4
--- /dev/null
+++ b/net-analyzer/httping/httping-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.2.1.ebuild,v 1.1 2006/10/21 15:42:15 squinky86 Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="ssl"
+
+DEPEND=">=sys-libs/ncurses-5"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ local makefile
+ use ssl || makefile="-f Makefile.nossl"
+ export CC="$(tc-getCC)"
+ emake ${makefile} || die "make failed"
+}
+
+src_install() {
+ dobin httping || die
+ dodoc readme.txt
+}