summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 11:59:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 11:59:41 +0000
commit6824f4cd2f56a3c5400ac9570098943dd6b9ecd6 (patch)
tree6a482dd1bc7d7c72b641a335bcf03438f291e0ce /net-analyzer
parentAdd patch to fix build with --as-needed by Kevin Pyle, closes bug #247930. Al... (diff)
downloadgentoo-2-6824f4cd2f56a3c5400ac9570098943dd6b9ecd6.tar.gz
gentoo-2-6824f4cd2f56a3c5400ac9570098943dd6b9ecd6.tar.bz2
gentoo-2-6824f4cd2f56a3c5400ac9570098943dd6b9ecd6.zip
Add patch to fix build with --as-needed by Kevin Pyle, closes bug #247937.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/slurm/ChangeLog8
-rw-r--r--net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch45
-rw-r--r--net-analyzer/slurm/slurm-0.3.3.ebuild13
3 files changed, 61 insertions, 5 deletions
diff --git a/net-analyzer/slurm/ChangeLog b/net-analyzer/slurm/ChangeLog
index 9be1dc386b1c..241c0ca07687 100644
--- a/net-analyzer/slurm/ChangeLog
+++ b/net-analyzer/slurm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/slurm
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/slurm/ChangeLog,v 1.16 2007/02/20 00:31:09 jokey Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/slurm/ChangeLog,v 1.17 2009/06/02 11:59:40 flameeyes Exp $
+
+ 02 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org> slurm-0.3.3.ebuild,
+ +files/slurm-0.3.3-asneeded.patch:
+ Add patch to fix build with --as-needed by Kevin Pyle, closes bug #247937.
20 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch b/net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch
new file mode 100644
index 000000000000..43a91176acea
--- /dev/null
+++ b/net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch
@@ -0,0 +1,45 @@
+--- a/configure.in 2004-09-28 09:34:56.000000000 -0500
++++ b/configure.in 2009-02-14 12:42:52.000000000 -0600
+@@ -40,41 +40,15 @@
+ fi
+ AC_DEFINE(OSTYPE, ["${OSTYPE}"], [The operating system to build for])
+
+-for cursespath in /usr/include/ncurses.h /usr/local/include/ncurses.h /usr/local/include/ncurses/ncurses.h /opt/include/ncurses.h /opt/include/curses.h /usr/include/curses.h /usr/local/include/curses.h /dev/null
+-do
+- test -f "${cursespath}" && break
+-done
+-case ${cursespath} in
+- /usr/include/*)
+- CFLAGS="$CFLAGS -I/usr/include"
+- LDFLAGS=""
+- ;;
+- /usr/local/include/ncurses/*)
+- CFLAGS="${CFLAGS} -I/usr/local/include/ncurses"
+- LDFLAGS="-L/usr/local/lib"
+- SOLLDFLAGS="-R/usr/local/lib"
+- ;;
+- /usr/local/include/*)
+- CFLAGS="${CFLAGS} -I/usr/local/include"
+- LDFLAGS="-L/usr/local/lib"
+- SOLLDFLAGS="-R/usr/local/lib"
+- ;;
+- /opt/include/*)
+- CFLAGS="${CFLAGS} -I/opt/include"
+- LDFLAGS="-L/opt/lib"
+- SOLLDFLAGS="-R/opt/lib"
+- ;;
+-esac
+ # add Slowlaris -R and libraries to LDFLAGS
+ if test ${OSTYPE} = "solaris" ; then
+ LDFLAGS="${LDFLAGS} ${SOLLDFLAGS} -lnsl -lsocket -lkstat"
+ fi
+
+-AC_CHECK_LIB(fridge, vanilla_coke, echo "WTF?!", echo "Warning: No vanilla coke found in fridge.";echo "We highly suggest that you rectify this situation immediatly.")
+ ncurses_support="no"
+ curses_support="no"
+ color_support="no"
+-AC_CHECK_LIB(ncurses, use_default_colors, LDFLAGS="$LDFLAGS -lncurses"; CFLAGS="$CFLAGS -D_HAVE_NCURSES -D_HAVE_NCURSES_COLOR"; color_support="yes"; ncurses_support="yes", AC_CHECK_LIB(ncurses, use_default_colors, LDFLAGS="$LDFLAGS -lncurses"; CFLAGS="$CFLAGS -D_HAVE_NCURSES"; ncurses_support="yes"; echo "NO TRANSPARENCY SUPPORT in this ncurses lib", AC_CHECK_LIB(curses, initscr, LDFLAGS="$LDFLAGS -lcurses"; CFLAGS="$CFLAGS -D_HAVE_CURSES"; curses_support="yes"; echo "NO TRANSPARENCY SUPPORT in curses lib")))
++AC_CHECK_LIB(ncurses, use_default_colors, LIBS="-lncurses $LIBS"; CFLAGS="$CFLAGS -D_HAVE_NCURSES -D_HAVE_NCURSES_COLOR"; color_support="yes"; ncurses_support="yes")
+
+ # disable color support on Solaris for now
+ if test ${OSTYPE} = "solaris" ; then
diff --git a/net-analyzer/slurm/slurm-0.3.3.ebuild b/net-analyzer/slurm/slurm-0.3.3.ebuild
index d9d96eec2c8d..772ab21f4f63 100644
--- a/net-analyzer/slurm/slurm-0.3.3.ebuild
+++ b/net-analyzer/slurm/slurm-0.3.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/slurm/slurm-0.3.3.ebuild,v 1.6 2006/08/15 09:15:51 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/slurm/slurm-0.3.3.ebuild,v 1.7 2009/06/02 11:59:40 flameeyes Exp $
-inherit eutils
+inherit autotools eutils
DESCRIPTION="Realtime network interface monitor based on FreeBSD's pppstatus"
HOMEPAGE="http://www.wormulon.net/projects/slurm"
@@ -15,6 +15,13 @@ IUSE=""
DEPEND="sys-libs/ncurses"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
src_install() {
# binary
dobin slurm