summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-07-20 16:09:31 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-07-20 16:09:31 +0000
commit7ac6fbca3d3500ecbf0f9e891e622a9820bafbcc (patch)
tree2a2d8f8b5d9eb5be5fd6fb178753b0e5f09b4fa3 /net-analyzer
parentUpdate 3dgamers mirror listing. (diff)
downloadgentoo-2-7ac6fbca3d3500ecbf0f9e891e622a9820bafbcc.tar.gz
gentoo-2-7ac6fbca3d3500ecbf0f9e891e622a9820bafbcc.tar.bz2
gentoo-2-7ac6fbca3d3500ecbf0f9e891e622a9820bafbcc.zip
Fix building with newer postgres-packages, #230167
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins/ChangeLog9
-rw-r--r--net-analyzer/nagios-plugins/files/nagios-plugins-1.4.12-pgsqlconfigure.patch69
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.4.12-r101.ebuild (renamed from net-analyzer/nagios-plugins/nagios-plugins-1.4.12-r100.ebuild)8
3 files changed, 83 insertions, 3 deletions
diff --git a/net-analyzer/nagios-plugins/ChangeLog b/net-analyzer/nagios-plugins/ChangeLog
index 0676b6b0fd98..b8e702619f7a 100644
--- a/net-analyzer/nagios-plugins/ChangeLog
+++ b/net-analyzer/nagios-plugins/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/nagios-plugins
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.94 2008/07/02 15:03:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.95 2008/07/20 16:09:30 dertobi123 Exp $
+
+*nagios-plugins-1.4.12-r101 (20 Jul 2008)
+
+ 20 Jul 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +files/nagios-plugins-1.4.12-pgsqlconfigure.patch,
+ -nagios-plugins-1.4.12-r100.ebuild, +nagios-plugins-1.4.12-r101.ebuild:
+ Fix building with newer postgres-packages, #230167
02 Jul 2008; Jeroen Roovers <jer@gentoo.org>
nagios-plugins-1.4.11-r102.ebuild:
diff --git a/net-analyzer/nagios-plugins/files/nagios-plugins-1.4.12-pgsqlconfigure.patch b/net-analyzer/nagios-plugins/files/nagios-plugins-1.4.12-pgsqlconfigure.patch
new file mode 100644
index 000000000000..e5e713db2128
--- /dev/null
+++ b/net-analyzer/nagios-plugins/files/nagios-plugins-1.4.12-pgsqlconfigure.patch
@@ -0,0 +1,69 @@
+diff -Naur nagios-plugins-1.4.12.orig/configure.in nagios-plugins-1.4.12/configure.in
+--- nagios-plugins-1.4.12.orig/configure.in 2008-05-28 00:01:05.000000000 +0200
++++ nagios-plugins-1.4.12/configure.in 2008-07-20 18:02:42.000000000 +0200
+@@ -182,27 +182,34 @@
+ PGSQL=$withval,)
+ AC_CHECK_LIB(crypt,main)
+ if test "$ac_cv_lib_crypt_main" = "yes" -a "x$PGSQL" != "xno"; then
+- if test -n "$PGSQL"; then
+- LDFLAGS="$LDFLAGS -L$PGSQL/lib"
+- CPPFLAGS="$CPPFLAGS -I$PGSQL/include"
++ if test -x $with_pgsql/bin/pg_config ; then
++ np_pg_config="$with_pgsql/bin/pg_config"
+ fi
+- AC_CHECK_LIB(pq,PQsetdbLogin,,,-lcrypt)
+- if test "$ac_cv_lib_pq_PQsetdbLogin" = "yes"; then
+- AC_CHECK_HEADERS(pgsql/libpq-fe.h)
+- AC_CHECK_HEADERS(postgresql/libpq-fe.h)
+- AC_CHECK_HEADERS(libpq-fe.h)
+- if [[ -n "$PGSQL" -a "$ac_cv_header_libpq_fe_h" = "yes" ]]; then
+- PGLIBS="-L$PGSQL/lib -lpq -lcrypt"
+- PGINCLUDE="-I$PGSQL/include"
+- elif test "$ac_cv_header_pgsql_libpq_fe_h" = "yes"; then
+- PGLIBS="-lpq -lcrypt"
+- PGINCLUDE="-I/usr/include/pgsql"
+- elif test "$ac_cv_header_postgresql_libpq_fe_h" = "yes"; then
+- PGLIBS="-L$PGSQL/lib -lpq -lcrypt"
+- PGINCLUDE="-I/usr/include/postgresql"
+- elif test "$ac_cv_header_libpq_fe_h" = "yes"; then
+- PGLIBS="-L$PGSQL/lib -lpq -lcrypt"
+- PGINCLUDE="-I$PGSQL/include"
++ if test -z "$np_pg_config"; then
++ with_pgsql="no"
++ else
++ if test -n "$PGSQL"; then
++ LDFLAGS="$LDFLAGS -L`$np_pg_config --libdir`"
++ CPPFLAGS="$CPPFLAGS -I`$np_pg_config --includedir`"
++ fi
++ AC_CHECK_LIB(pq,PQsetdbLogin,,,-lcrypt)
++ if test "$ac_cv_lib_pq_PQsetdbLogin" = "yes"; then
++ AC_CHECK_HEADERS(pgsql/libpq-fe.h)
++ AC_CHECK_HEADERS(postgresql/libpq-fe.h)
++ AC_CHECK_HEADERS(libpq-fe.h)
++ if [[ -n "$PGSQL" -a "$ac_cv_header_libpq_fe_h" = "yes" ]]; then
++ PGLIBS="-L`$np_pg_config --libdir` -lpq -lcrypt"
++ PGINCLUDE="-I`$np_pg_config --includedir`"
++ elif test "$ac_cv_header_pgsql_libpq_fe_h" = "yes"; then
++ PGLIBS="-lpq -lcrypt"
++ PGINCLUDE="-I`$np_pg_config --includedir`"
++ elif test "$ac_cv_header_postgresql_libpq_fe_h" = "yes"; then
++ PGLIBS="-L`$np_pg_config --libdir` -lpq -lcrypt"
++ PGINCLUDE="-I`$np_pg_config --includedir`"
++ elif test "$ac_cv_header_libpq_fe_h" = "yes"; then
++ PGLIBS="-L`$np_pg_config --libdir` -lpq -lcrypt"
++ PGINCLUDE="-I`$np_pg_config --includedir`"
++ fi
+ fi
+ if test -z "$PGINCLUDE"; then
+ AC_MSG_WARN([Skipping PostgreSQL plugin (check_pgsql)])
+@@ -212,10 +219,6 @@
+ AC_SUBST(PGINCLUDE)
+ EXTRAS="$EXTRAS check_pgsql"
+ fi
+- else
+- AC_MSG_WARN([Skipping PostgreSQL plugin (check_pgsql)])
+- AC_MSG_WARN([LIBS="$LIBS" CPPFLAGS="$CPPFLAGS"])
+- AC_MSG_WARN([install PostgreSQL libs to compile this plugin (see REQUIREMENTS).])
+ fi
+ else
+ AC_MSG_WARN([Skipping PostgreSQL plugin (check_pgsql)])
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.4.12-r100.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.4.12-r101.ebuild
index b24e39a24f6c..98d31d12d061 100644
--- a/net-analyzer/nagios-plugins/nagios-plugins-1.4.12-r100.ebuild
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.4.12-r101.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.12-r100.ebuild,v 1.2 2008/05/31 08:22:02 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.12-r101.ebuild,v 1.1 2008/07/20 16:09:30 dertobi123 Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -55,6 +55,7 @@ src_unpack() {
fi
epatch "${FILESDIR}"/${PN}-1.4.10-contrib.patch
+ epatch "${FILESDIR}"/${P}-pgsqlconfigure.patch
AT_M4DIR="m4 gl/m4" eautoreconf
}
@@ -68,9 +69,12 @@ src_compile() {
conf="${conf} --without-openssl"
fi
+ if use postgres; then
+ conf="${conf} --with-pgsql=/usr"
+ fi
+
econf \
$(use_with mysql) \
- $(use_with postgres pgsql) \
$(use_with ipv6) \
${conf} \
--host=${CHOST} \