summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-07-27 14:09:29 +0000
committerJustin Lecher <jlec@gentoo.org>2015-07-27 14:09:29 +0000
commit81ae0b99ce1a014884c313091da3b1415d177fe3 (patch)
treeeb478e76bf8883947eb67cac311427704e420d59 /net-analyzer
parentVersion Bump (diff)
downloadgentoo-2-81ae0b99ce1a014884c313091da3b1415d177fe3.tar.gz
gentoo-2-81ae0b99ce1a014884c313091da3b1415d177fe3.tar.bz2
gentoo-2-81ae0b99ce1a014884c313091da3b1415d177fe3.zip
Version Bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/openvas-cli/ChangeLog7
-rw-r--r--net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/net-analyzer/openvas-cli/ChangeLog b/net-analyzer/openvas-cli/ChangeLog
index 1e6bdec396ea..3ac1e462d7b7 100644
--- a/net-analyzer/openvas-cli/ChangeLog
+++ b/net-analyzer/openvas-cli/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/openvas-cli
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-cli/ChangeLog,v 1.16 2015/04/07 14:27:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-cli/ChangeLog,v 1.17 2015/07/27 14:09:29 jlec Exp $
+
+*openvas-cli-1.4.2 (27 Jul 2015)
+
+ 27 Jul 2015; Justin Lecher <jlec@gentoo.org> +openvas-cli-1.4.2.ebuild:
+ Version Bump
*openvas-cli-1.4.0 (06 Apr 2015)
diff --git a/net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild b/net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild
new file mode 100644
index 000000000000..cdfc33789241
--- /dev/null
+++ b/net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild,v 1.1 2015/07/27 14:09:29 jlec Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DL_ID=2141
+
+DESCRIPTION="A remote security scanner for Linux (OpenVAS-cli)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/${DL_ID}/${P/_beta/+beta}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=" ~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=net-analyzer/openvas-libraries-8.0.4
+ !net-analyzer/openvas-client"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_beta/+beta}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLOCALSTATEDIR="${EPREFIX}"/var
+ -DSYSCONFDIR="${EPREFIX}"/etc
+ )
+ cmake-utils_src_configure
+}