summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2006-04-08 02:55:49 +0000
committerLance Albertson <ramereth@gentoo.org>2006-04-08 02:55:49 +0000
commit88b3cdd8a75bb772cb2d8430a4a1046b6ae3a408 (patch)
tree587c8497bb1500cb497a8ebee5ef8730cd01cbd1 /net-analyzer
parentrepoman: Trim trailing whitespace (diff)
downloadgentoo-2-88b3cdd8a75bb772cb2d8430a4a1046b6ae3a408.tar.gz
gentoo-2-88b3cdd8a75bb772cb2d8430a4a1046b6ae3a408.tar.bz2
gentoo-2-88b3cdd8a75bb772cb2d8430a4a1046b6ae3a408.zip
version bump
(Portage version: 2.0.54)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-core/ChangeLog8
-rw-r--r--net-analyzer/nagios-core/Manifest4
-rw-r--r--net-analyzer/nagios-core/files/digest-nagios-core-2.22
-rw-r--r--net-analyzer/nagios-core/nagios-core-2.2.ebuild228
4 files changed, 240 insertions, 2 deletions
diff --git a/net-analyzer/nagios-core/ChangeLog b/net-analyzer/nagios-core/ChangeLog
index 88439e784ea6..7147ba5d30d2 100644
--- a/net-analyzer/nagios-core/ChangeLog
+++ b/net-analyzer/nagios-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nagios-core
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.73 2006/04/03 02:38:04 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.74 2006/04/08 02:55:49 ramereth Exp $
+
+*nagios-core-2.2 (08 Apr 2006)
+
+ 08 Apr 2006; Lance Albertson <ramereth@gentoo.org>
+ +nagios-core-2.2.ebuild:
+ * Version bump
*nagios-core-2.1 (03 Apr 2006)
diff --git a/net-analyzer/nagios-core/Manifest b/net-analyzer/nagios-core/Manifest
index a050211542ce..55c77801c24f 100644
--- a/net-analyzer/nagios-core/Manifest
+++ b/net-analyzer/nagios-core/Manifest
@@ -1,4 +1,4 @@
-MD5 2870ac00ef7eb364a2a1c31f4847353e ChangeLog 13175
+MD5 1ee4f52fc4f8583250c34448c209c697 ChangeLog 13305
MD5 446906907cccdbf195442373c6f17f77 files/2.x-series-nsca.patch 767
MD5 673bda0ac6ab9230d23331e7f3846b7b files/99_nagios.conf 350
MD5 f2947dec6b9a839da79606bcc394036b files/conf.d 409
@@ -6,6 +6,7 @@ MD5 9ead897e0a8a7edc783916948e023b1f files/digest-nagios-core-1.2-r4 218
MD5 587bd1eafc5547df269b6f82c7d6cf29 files/digest-nagios-core-1.3 151
MD5 97842ad243d5d658f8b20b06c92c72a5 files/digest-nagios-core-2.0 131
MD5 b1bb7bf2bf468173ad54269b86b0c500 files/digest-nagios-core-2.1 131
+MD5 1361a960bf4c649e2199db3afd6a975c files/digest-nagios-core-2.2 131
MD5 f83fb59efe215d8191866a95685b4b39 files/nagios 1416
MD5 dad3fb46e8f73ac54d9239a542bc82e0 files/nagios.conf 362
MD5 cee7d66cc61be3558af44ab177d99e1f files/submit_check_result_via_nsca.patch 585
@@ -14,3 +15,4 @@ MD5 6e955d838dba98d7ac157ca9e3f4e0af nagios-core-1.2-r4.ebuild 7240
MD5 cea5a3d589fdd00d45f20544f65759e5 nagios-core-1.3.ebuild 7472
MD5 50c60e546174daae11e5a52077a98df2 nagios-core-2.0.ebuild 6013
MD5 25ce85109cc79fcb6c6f00e2cd3a2a3f nagios-core-2.1.ebuild 6013
+MD5 25ce85109cc79fcb6c6f00e2cd3a2a3f nagios-core-2.2.ebuild 6013
diff --git a/net-analyzer/nagios-core/files/digest-nagios-core-2.2 b/net-analyzer/nagios-core/files/digest-nagios-core-2.2
new file mode 100644
index 000000000000..88aa14284b15
--- /dev/null
+++ b/net-analyzer/nagios-core/files/digest-nagios-core-2.2
@@ -0,0 +1,2 @@
+MD5 6b679390ce57974a0f69145e0918372f nagios-2.0b.cfg-sample.gz 8990
+MD5 38d375fa728d8475b65af63af85d6cea nagios-2.2.tar.gz 1734695
diff --git a/net-analyzer/nagios-core/nagios-core-2.2.ebuild b/net-analyzer/nagios-core/nagios-core-2.2.ebuild
new file mode 100644
index 000000000000..08e458c4910c
--- /dev/null
+++ b/net-analyzer/nagios-core/nagios-core-2.2.ebuild
@@ -0,0 +1,228 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-2.2.ebuild,v 1.1 2006/04/08 02:55:49 ramereth Exp $
+
+inherit eutils apache-module toolchain-funcs gnuconfig
+
+MY_P=${PN/-core}-${PV/_}
+DESCRIPTION="Nagios Core - Check daemon, CGIs, docs"
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="mirror://sourceforge/nagios/${MY_P}.tar.gz
+ mirror://gentoo/nagios-2.0b.cfg-sample.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="noweb perl debug apache2"
+# mysql postgres
+DEPEND="virtual/mailx
+ !noweb? (
+ >=media-libs/jpeg-6b-r3
+ >=media-libs/libpng-1.2.5-r4
+ >=media-libs/gd-1.8.3-r5
+ ${NEED_APACHE_DEPEND}
+ perl? ( net-analyzer/traceroute )
+ )
+ perl? ( >=dev-lang/perl-5.6.1-r7 )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ # If there's a gd lib on the system, it will try to build with it.
+ # check if gdlib-config is on, and then check its output.
+ if [[ -x ${ROOT}usr/bin/gdlib-config ]]; then
+ if [[ ! $(${ROOT}usr/bin/gdlib-config --libs | grep -- -ljpeg) ]]; then
+ eerror "Your gd has been compiled without jpeg support."
+ eerror "Please re-emerge gd:"
+ eerror "# USE="jpeg" emerge gd"
+ die "pkg_setup failed"
+ fi
+ fi
+
+ enewgroup nagios
+
+ if use noweb; then
+ enewuser nagios -1 /bin/bash /dev/null nagios
+ else
+ enewuser nagios -1 /bin/bash /dev/null apache
+ usermod -G apache nagios
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/2.x-series-nsca.patch
+ # ppc64 needs this
+ gnuconfig_update
+}
+
+src_compile() {
+ local myconf
+
+ if use perl
+ then
+ myconf="${myconf} --enable-embedded-perl --with-perlcache"
+ fi
+
+ if use debug; then
+ myconf="${myconf} --enable-DEBUG0"
+ myconf="${myconf} --enable-DEBUG1"
+ myconf="${myconf} --enable-DEBUG2"
+ myconf="${myconf} --enable-DEBUG3"
+ myconf="${myconf} --enable-DEBUG4"
+ myconf="${myconf} --enable-DEBUG5"
+ fi
+
+ if use noweb; then
+ myconf="${myconf} --with-command-grp=nagios"
+ else
+ myconf="${myconf} --with-command-grp=apache"
+ fi
+
+ ./configure ${myconf} \
+ --host=${CHOST} \
+ --prefix=/usr/nagios \
+ --localstatedir=/var/nagios \
+ --sysconfdir=/etc/nagios \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ emake CC=$(tc-getCC) nagios || die "make failed"
+
+ if use !noweb ; then
+ # Only compile the CGI's if "noweb" useflag is not set.
+ make CC=$(tc-getCC) DESTDIR=${D} cgis || die
+ fi
+
+ emake -C contrib all || "contrib make filed"
+
+}
+
+src_install() {
+ dodoc Changelog INSTALLING LEGAL LICENSE README UPGRADING
+ docinto contrib
+ dodoc contrib/README
+
+ if use noweb; then
+ sed -i -e 's/cd $(SRC_CGI) && $(MAKE) $@/# line removed due to noweb use flag/' \
+ -e 's/cd $(SRC_HTM) && $(MAKE) $@/# line removed due to noweb use flag/' \
+ Makefile
+ fi
+
+ sed -i -e 's/^contactgroups$//g' Makefile
+
+ make DESTDIR=${D} install
+ make DESTDIR=${D} install-config
+ make DESTDIR=${D} install-commandmode
+
+ docinto sample-configs
+ dodoc ${D}/etc/nagios/*
+ rm ${D}/etc/nagios/*
+
+ newdoc ${WORKDIR}/nagios-2.0b.cfg-sample nagios.cfg-sample
+
+ #contribs are not configured by the configure script, we'll configure them overselves...
+ find ${S}/contrib/ -type f | xargs sed -e 's:/usr/local/nagios/var/rw:/var/nagios/rw:;
+ s:/usr/local/nagios/libexec:/usr/nagios/libexec:;
+ s:/usr/local/nagios/etc:/etc/nagios:;
+ s:/usr/local/nagios/sbin:/usr/nagios/sbin:;' -i
+
+ insinto /usr/share/doc/${PF}/contrib
+ doins -r contrib/eventhandlers
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/nagios
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.d nagios
+
+ chmod 644 ${S}/contrib/*.cgi
+ into /usr/nagios
+ for bin in `find contrib/ -type f -perm 0755 -maxdepth 1` ; do
+ dobin $bin
+ done
+
+ # Apache Module
+ if use !noweb; then
+ if use apache2; then
+ insinto ${APACHE2_MODULES_CONFDIR}
+ doins ${FILESDIR}/99_nagios.conf
+ else
+ insinto ${APACHE1_MODULES_CONFDIR}
+ doins ${FILESDIR}/nagios.conf
+ fi
+ if use perl; then
+ into /usr/nagios ; dosbin contrib/traceroute.cgi
+ fi
+ fi
+
+ for dir in etc/nagios usr/nagios var/nagios ; do
+ chown -R nagios:nagios ${D}/${dir} || die "Failed chown of ${D}/${dir}"
+ done
+}
+
+pkg_preinst() {
+ keepdir /etc/nagios
+ keepdir /var/nagios
+ keepdir /var/nagios/archives
+ keepdir /usr/nagios/share/ssi
+ keepdir /var/nagios/rw
+
+ if use noweb; then
+ chown -R nagios:nagios ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
+ else
+ chown -R nagios:apache ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
+ fi
+
+ chmod ug+s ${D}/var/nagios/rw || die "Failed Chmod of ${D}/var/nagios/rw"
+ chmod 0750 ${D}/etc/nagios || die "Failed chmod of ${D}/etc/nagios"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The example config files are located at /usr/share/doc/${PF}/sample-configs/."
+ einfo
+ einfo "Also, if you want nagios to start at boot time"
+ einfo "remember to execute:"
+ einfo " rc-update add nagios default"
+ einfo
+
+ if use !noweb; then
+ einfo "This does not include cgis that are perl-dependent"
+ einfo "Currently traceroute.cgi is perl-dependent"
+ einfo "To have ministatus.cgi requires copying of ministatus.c"
+ einfo "to cgi directory for compiling."
+
+ if use apache2; then
+ einfo " Edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
+ else
+ einfo " Edit /etc/conf.d/apache and add \"-D NAGIOS\""
+ fi
+
+ einfo
+ einfo "That will make nagios's web front end visable via"
+ einfo "http://localhost/nagios/"
+ einfo
+
+ else
+ einfo "Please note that you have installed Nagios without web interface."
+ einfo "Please don't file any bugs about having no web interface when you do this."
+ einfo "Thank you!"
+ fi
+
+ einfo
+ einfo "If your kernel has /proc protection, nagios"
+ einfo "will not be happy as it relies on accessing the proc"
+ einfo "filesystem. You can fix this by adding nagios into"
+ einfo "the group wheel, but this is not recomended."
+ einfo
+
+ einfo
+ ewarn "Use /usr/nagios/bin/convertcfg for configuration file conversion"
+}
+
+pkg_prerm() {
+ /etc/init.d/nagios stop
+}