summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2007-07-29 08:49:12 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2007-07-29 08:49:12 +0000
commitc61b347c9d91e6eec2ea082d6d1d4880aa89b8eb (patch)
tree6c99961d9fb512c672a692de13c1d16619cd9759 /net-analyzer
parentPointless commit. Emptyspaces.. (diff)
downloadgentoo-2-c61b347c9d91e6eec2ea082d6d1d4880aa89b8eb.tar.gz
gentoo-2-c61b347c9d91e6eec2ea082d6d1d4880aa89b8eb.tar.bz2
gentoo-2-c61b347c9d91e6eec2ea082d6d1d4880aa89b8eb.zip
Version bump, bug #184713
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/echoping/ChangeLog8
-rw-r--r--net-analyzer/echoping/echoping-6.0.2.ebuild52
-rw-r--r--net-analyzer/echoping/files/digest-echoping-6.0.23
3 files changed, 62 insertions, 1 deletions
diff --git a/net-analyzer/echoping/ChangeLog b/net-analyzer/echoping/ChangeLog
index 5d6e77b2f54e..bea1ca13fa52 100644
--- a/net-analyzer/echoping/ChangeLog
+++ b/net-analyzer/echoping/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/echoping
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/ChangeLog,v 1.10 2007/07/09 12:10:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/ChangeLog,v 1.11 2007/07/29 08:49:11 dertobi123 Exp $
+
+*echoping-6.0.2 (29 Jul 2007)
+
+ 29 Jul 2007; Tobias Scherbaum <dertobi123@gentoo.org>
+ +echoping-6.0.2.ebuild:
+ Version bump, bug #184713
09 Jul 2007; Raúl Porcel <armin76@gentoo.org> echoping-6.0.1.ebuild:
x86 stable
diff --git a/net-analyzer/echoping/echoping-6.0.2.ebuild b/net-analyzer/echoping/echoping-6.0.2.ebuild
new file mode 100644
index 000000000000..ca75944fb856
--- /dev/null
+++ b/net-analyzer/echoping/echoping-6.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/echoping-6.0.2.ebuild,v 1.1 2007/07/29 08:49:11 dertobi123 Exp $
+
+inherit eutils
+
+DESCRIPTION="echoping is a small program to test performances of remote servers"
+HOMEPAGE="http://echoping.sourceforge.net/"
+SRC_URI="mirror://sourceforge/echoping/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls http icp idn priority smtp ssl tos postgres ldap"
+
+DEPEND="gnutls? ( >=net-libs/gnutls-1.0.17 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ idn? ( net-dns/libidn )
+ postgres? ( dev-db/postgresql )
+ ldap? ( net-nds/openldap )"
+
+pkg_setup() {
+ # bug 141782 - conflicting USE flags - ssl and gnutls
+ if use ssl && use gnutls ; then
+ eerror "You cannot emerge net-analyzer/echoping with both"
+ eerror "ssl and gnutls USE flags set. Please choose one."
+ die "echoping cannot use both ssl and gnutls at once"
+ fi
+}
+
+src_compile() {
+ econf \
+ --config-cache \
+ --disable-ttcp \
+ $(use_with gnutls) \
+ $(use_enable http) \
+ $(use_enable icp) \
+ $(use_with idn libidn) \
+ $(use_enable smtp) \
+ $(use_enable tos) \
+ $(use_enable priority) \
+ $(use_with ssl) || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ # They are not installed by make install
+ dodoc README AUTHORS ChangeLog DETAILS NEWS TODO
+}
diff --git a/net-analyzer/echoping/files/digest-echoping-6.0.2 b/net-analyzer/echoping/files/digest-echoping-6.0.2
new file mode 100644
index 000000000000..99c6edbe5a94
--- /dev/null
+++ b/net-analyzer/echoping/files/digest-echoping-6.0.2
@@ -0,0 +1,3 @@
+MD5 991478532b56ab3b6f46ea9fa332626f echoping-6.0.2.tar.gz 1660983
+RMD160 73ee80f4b666fde3a0e02589388e485c487005fc echoping-6.0.2.tar.gz 1660983
+SHA256 1dfa4c45bf461b2379ff91773ed7136176e2abac9e85c26bc9654942b5155eac echoping-6.0.2.tar.gz 1660983