summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-03-10 10:40:26 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-03-10 10:40:26 +0000
commite41e391e505178c65fe789957a8ad75bdda31890 (patch)
treef30144da890b42695860423f41824db959b369d7 /net-analyzer
parentFixed deps; >=2.4 depends on >=python-2.4 - bug 84596. (diff)
downloadgentoo-2-e41e391e505178c65fe789957a8ad75bdda31890.tar.gz
gentoo-2-e41e391e505178c65fe789957a8ad75bdda31890.tar.bz2
gentoo-2-e41e391e505178c65fe789957a8ad75bdda31890.zip
It's called use_with not 'use with'.. also, it's postgres not postgress.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins/ChangeLog5
-rw-r--r--net-analyzer/nagios-plugins/Manifest22
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.4.ebuild24
3 files changed, 23 insertions, 28 deletions
diff --git a/net-analyzer/nagios-plugins/ChangeLog b/net-analyzer/nagios-plugins/ChangeLog
index 0acb2917b9c8..5e97aa49486a 100644
--- a/net-analyzer/nagios-plugins/ChangeLog
+++ b/net-analyzer/nagios-plugins/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/nagios-plugins
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.32 2005/02/26 03:53:24 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.33 2005/03/10 10:40:26 ka0ttic Exp $
+
+ 10 Mar 2005; Aaron Walker <ka0ttic@gentoo.org> nagios-plugins-1.4.ebuild:
+ It's called use_with not 'use with'.. also, it's postgres not postgress.
26 Feb 2005; Daniel Black <dragonheart@gentoo.org>
nagios-plugins-1.4.ebuild:
diff --git a/net-analyzer/nagios-plugins/Manifest b/net-analyzer/nagios-plugins/Manifest
index 0ee1bcb725ed..9c621c4a3e02 100644
--- a/net-analyzer/nagios-plugins/Manifest
+++ b/net-analyzer/nagios-plugins/Manifest
@@ -1,21 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 422ffa6daead79f7102ab0fd940f17c5 ChangeLog 5275
-MD5 28e87bdecda2a6c56ad1fc2dc3f339db nagios-plugins-1.3.1.ebuild 1708
+MD5 db7c1cdf80277983cdf1538085c2fa05 nagios-plugins-1.4.ebuild 3195
MD5 3d4ab29e2f2b2c45d731ace02bd24baa nagios-plugins-1.3.1-r1.ebuild 2865
+MD5 28e87bdecda2a6c56ad1fc2dc3f339db nagios-plugins-1.3.1.ebuild 1708
+MD5 f71e0f56748f65c9c069445c3ae53c58 ChangeLog 5427
MD5 a3aa02d9b004cdb8629496aa61024fb7 metadata.xml 256
-MD5 d02cbf1204fc13c7d7965c1348460714 nagios-plugins-1.4.ebuild 3106
-MD5 c8c25561d4871462ea03dc0490ced91b files/check_swap.c.patch 2212
MD5 39af7074b023625d9a75730bd6932437 files/digest-nagios-plugins-1.3.1 72
-MD5 39af7074b023625d9a75730bd6932437 files/digest-nagios-plugins-1.3.1-r1 72
+MD5 c8c25561d4871462ea03dc0490ced91b files/check_swap.c.patch 2212
+MD5 639ea6f5791cdf3ad540489c66d1f356 files/digest-nagios-plugins-1.4 70
MD5 acb0b2b914b27b67b9a33807b1e6838e files/install-opts-fix.diff 3168
MD5 ee71da291efd7427bd9786591a98df34 files/nagios-plugins-noradius.patch 2661
-MD5 639ea6f5791cdf3ad540489c66d1f356 files/digest-nagios-plugins-1.4 70
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCH/K6mdTrptrqvGERAu9bAJ9hcTRGfUNBJXH+LLcN/ZyugaladgCfcguK
-4U5tMoKHSTt/l9kAI+l0KWI=
-=46Ru
------END PGP SIGNATURE-----
+MD5 39af7074b023625d9a75730bd6932437 files/digest-nagios-plugins-1.3.1-r1 72
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.4.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.4.ebuild
index 1907c844d22b..c20370b55206 100644
--- a/net-analyzer/nagios-plugins/nagios-plugins-1.4.ebuild
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.ebuild,v 1.2 2005/02/26 03:53:24 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.ebuild,v 1.3 2005/03/10 10:40:26 ka0ttic Exp $
inherit eutils
@@ -50,10 +50,10 @@ src_compile() {
#fi
./configure \
- `use_with mysql` \
- `use_with postgress` \
- `use with ssl openssl` \
- `use with ipv6` \
+ $(use_with mysql) \
+ $(use_with postgres) \
+ $(use_with ssl openssl) \
+ $(use_with ipv6) \
--host=${CHOST} \
--prefix=/usr/nagios \
--with-nagios-user=nagios \
@@ -64,19 +64,21 @@ src_compile() {
#fix problem with additional -
sed -i -e 's:/bin/ps -axwo:/bin/ps axwo:g' config.h || die "sed failed"
- make || die
+ make || die "make failed"
}
src_install() {
mv ${S}/contrib/check_compaq_insight.pl ${S}/contrib/check_compaq_insight.pl.msg
chmod +x ${S}/contrib/*.pl
- sed -i -e '1s;#!.*;#!/usr/bin/perl -w;' ${S}/contrib/*.pl
- sed -i -e '30s/use lib utils.pm;/use utils;/' ${S}/contrib/check_file_age.pl
+ sed -i -e '1s;#!.*;#!/usr/bin/perl -w;' ${S}/contrib/*.pl || die "sed failed"
+ sed -i -e '30s/use lib utils.pm;/use utils;/' ${S}/contrib/check_file_age.pl \
+ || die "sed failed"
- dodoc ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS BUGS CHANGES CODING COPYING
- Changelog FAQ INSTALL LEGAL NEWS README REQUIREMENTS SUPPORT
- make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS BUGS CHANGES CODING COPYING \
+ Changelog FAQ INSTALL LEGAL NEWS README REQUIREMENTS SUPPORT
+
+ make DESTDIR="${D}" install || die "make install failed"
if use mysql || use postgres; then
dodir /usr/nagios/libexec