summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2005-07-04 21:34:36 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2005-07-04 21:34:36 +0000
commit8500ca4bd43120a5eaa53632e658dac35bade94e (patch)
treeba61f57319ad689704b87719745f3cfe3712263a /net-dialup/multiimonc
parentVersion bump #97887 by Peter Simons. (diff)
downloadgentoo-2-8500ca4bd43120a5eaa53632e658dac35bade94e.tar.gz
gentoo-2-8500ca4bd43120a5eaa53632e658dac35bade94e.tar.bz2
gentoo-2-8500ca4bd43120a5eaa53632e658dac35bade94e.zip
Added patch for #97526.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-dialup/multiimonc')
-rw-r--r--net-dialup/multiimonc/ChangeLog6
-rw-r--r--net-dialup/multiimonc/Manifest3
-rw-r--r--net-dialup/multiimonc/files/0.3.6-TextScrollWindow.diff18
-rw-r--r--net-dialup/multiimonc/multiimonc-0.3.6.ebuild9
4 files changed, 33 insertions, 3 deletions
diff --git a/net-dialup/multiimonc/ChangeLog b/net-dialup/multiimonc/ChangeLog
index 765408dddc30..801e0bb2142d 100644
--- a/net-dialup/multiimonc/ChangeLog
+++ b/net-dialup/multiimonc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/multiimonc
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/multiimonc/ChangeLog,v 1.4 2005/06/12 16:04:47 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/multiimonc/ChangeLog,v 1.5 2005/07/04 21:34:36 hansmi Exp $
+
+ 04 Jul 2005; Michael Hanselmann <hansmi@gentoo.org>
+ +files/0.3.6-TextScrollWindow.diff, multiimonc-0.3.6.ebuild:
+ Added patch for #97526.
12 Jun 2005; Michael Hanselmann <hansmi@gentoo.org>
-multiimonc-0.3.5.ebuild, multiimonc-0.3.6.ebuild:
diff --git a/net-dialup/multiimonc/Manifest b/net-dialup/multiimonc/Manifest
index fe15aa1edc24..f6f9af1d5f21 100644
--- a/net-dialup/multiimonc/Manifest
+++ b/net-dialup/multiimonc/Manifest
@@ -1,4 +1,5 @@
MD5 8713e089cd57dc168f2e660676f408d3 metadata.xml 361
MD5 a7a78d48032034c803f643d0cff7bb00 ChangeLog 2423
-MD5 9f4b16957acac34c0bd38ccbb69b4ff4 multiimonc-0.3.6.ebuild 744
+MD5 3b32478975c583a46a8aa074abc7002c multiimonc-0.3.6.ebuild 868
+MD5 27a94c69d14897cce8aad4061b77b3f1 files/0.3.6-TextScrollWindow.diff 731
MD5 3b0e2974aedea907c4f10800a66c7652 files/digest-multiimonc-0.3.6 69
diff --git a/net-dialup/multiimonc/files/0.3.6-TextScrollWindow.diff b/net-dialup/multiimonc/files/0.3.6-TextScrollWindow.diff
new file mode 100644
index 000000000000..b239556d27db
--- /dev/null
+++ b/net-dialup/multiimonc/files/0.3.6-TextScrollWindow.diff
@@ -0,0 +1,18 @@
+Index: TextScrollWindow.h
+===================================================================
+RCS file: /home/users/michael/cvs/MultiImonC/src/TextScrollWindow.h,v
+retrieving revision 1.4
+diff -u -r1.4 TextScrollWindow.h
+--- TextScrollWindow.h 10 Jul 2004 19:25:39 -0000 1.4
++++ TextScrollWindow.h 4 Jul 2005 21:27:51 -0000
+@@ -29,8 +29,8 @@
+ class TextScrollWindow: public wxFrame {
+ public:
+ TextScrollWindow(const wxFrame* parent,
+- wxString i_strTitle = "",
+- wxString i_strText = "");
++ wxString i_strTitle = wxT(""),
++ wxString i_strText = wxT(""));
+ void SetText(wxString& i_strText);
+ private:
+ void OnSave(wxCommandEvent &event);
diff --git a/net-dialup/multiimonc/multiimonc-0.3.6.ebuild b/net-dialup/multiimonc/multiimonc-0.3.6.ebuild
index 446e34085119..ffef5e8d451f 100644
--- a/net-dialup/multiimonc/multiimonc-0.3.6.ebuild
+++ b/net-dialup/multiimonc/multiimonc-0.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/multiimonc/multiimonc-0.3.6.ebuild,v 1.3 2005/06/12 16:04:47 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/multiimonc/multiimonc-0.3.6.ebuild,v 1.4 2005/07/04 21:34:36 hansmi Exp $
inherit eutils
@@ -19,6 +19,13 @@ DEPEND="=x11-libs/wxGTK-2.4*
virtual/libc
virtual/x11"
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ epatch ${FILESDIR}/${PV}-TextScrollWindow.diff || die "epatch failed"
+ cd ${S}
+}
+
src_compile() {
econf || die "could not configure"
emake || die "emake failed"