summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-05-30 20:54:12 +0000
committerAlin Năstac <mrness@gentoo.org>2006-05-30 20:54:12 +0000
commit41c68a37282fc6fb1a24c9b33f9c17981d103f77 (patch)
treede30d3f63bee10639bb54c3eb8715ebeaa815b68 /net-dialup/xl2tpd
parentAdded patch that allows to compile on systems with broken fnmatch function (l... (diff)
downloadgentoo-2-41c68a37282fc6fb1a24c9b33f9c17981d103f77.tar.gz
gentoo-2-41c68a37282fc6fb1a24c9b33f9c17981d103f77.tar.bz2
gentoo-2-41c68a37282fc6fb1a24c9b33f9c17981d103f77.zip
Initial import from bug #134029.
(Portage version: 2.0.54-r2)
Diffstat (limited to 'net-dialup/xl2tpd')
-rw-r--r--net-dialup/xl2tpd/ChangeLog10
-rw-r--r--net-dialup/xl2tpd/Manifest3
-rw-r--r--net-dialup/xl2tpd/files/digest-xl2tpd-1.041
-rw-r--r--net-dialup/xl2tpd/files/l2tpd-init32
-rw-r--r--net-dialup/xl2tpd/metadata.xml6
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.04.ebuild31
6 files changed, 83 insertions, 0 deletions
diff --git a/net-dialup/xl2tpd/ChangeLog b/net-dialup/xl2tpd/ChangeLog
new file mode 100644
index 000000000000..010fce269fff
--- /dev/null
+++ b/net-dialup/xl2tpd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-dialup/xl2tpd
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.1 2006/05/30 20:54:12 mrness Exp $
+
+*xl2tpd-1.04 (30 May 2006)
+
+ 30 May 2006; Alin Nastac <mrness@gentoo.org> +files/l2tpd-init,
+ +metadata.xml, +xl2tpd-1.04.ebuild:
+ Initial import from bug #134029, thanks to Alexandre Ghisoli <alex@ghisoli.ch>.
+
diff --git a/net-dialup/xl2tpd/Manifest b/net-dialup/xl2tpd/Manifest
new file mode 100644
index 000000000000..fb7f0a697566
--- /dev/null
+++ b/net-dialup/xl2tpd/Manifest
@@ -0,0 +1,3 @@
+MD5 c0494910abd2a9c98e958d5b764d4d0b files/digest-xl2tpd-1.04 63
+MD5 c97eaae6e975be2b251ef3dc9b63098a files/l2tpd-init 623
+MD5 d4af3de40fed1b6758262401d2ff20fd xl2tpd-1.04.ebuild 721
diff --git a/net-dialup/xl2tpd/files/digest-xl2tpd-1.04 b/net-dialup/xl2tpd/files/digest-xl2tpd-1.04
new file mode 100644
index 000000000000..06dc4f677b24
--- /dev/null
+++ b/net-dialup/xl2tpd/files/digest-xl2tpd-1.04
@@ -0,0 +1 @@
+MD5 36220cff74221fff461d93c9334adbb1 xl2tpd-1.04.tar.gz 138139
diff --git a/net-dialup/xl2tpd/files/l2tpd-init b/net-dialup/xl2tpd/files/l2tpd-init
new file mode 100644
index 000000000000..b118736cc36b
--- /dev/null
+++ b/net-dialup/xl2tpd/files/l2tpd-init
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/files/l2tpd-init,v 1.1 2006/05/30 20:54:12 mrness Exp $
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [[ ! -f /etc/l2tpd/l2tpd.conf ]] ; then
+ eerror "Missing /etc/l2tpd/l2tpd.conf configuration file!"
+ eerror "Example configuration file could be found in doc directory."
+ return 1
+ fi
+
+ return 0
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting l2tpd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/l2tpd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping l2tpd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/l2tpd.pid
+ eend $?
+}
diff --git a/net-dialup/xl2tpd/metadata.xml b/net-dialup/xl2tpd/metadata.xml
new file mode 100644
index 000000000000..eb06d7f5b8ea
--- /dev/null
+++ b/net-dialup/xl2tpd/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+ <longdescription>The Layer 2 Tunneling Protocol (L2TP) daemon mantained by Xelerance Corporation.</longdescription>
+</pkgmetadata>
diff --git a/net-dialup/xl2tpd/xl2tpd-1.04.ebuild b/net-dialup/xl2tpd/xl2tpd-1.04.ebuild
new file mode 100644
index 000000000000..0c14ede66136
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.04.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.04.ebuild,v 1.1 2006/05/30 20:54:12 mrness Exp $
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="http://www.xelerance.com/software/xl2tpd/"
+SRC_URI="http://www.xelerance.com/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!net-dialup/l2tpd
+ net-dialup/ppp"
+
+S="${WORKDIR}/xl2tp-${PV}"
+
+src_install() {
+ dosbin l2tpd
+ doman doc/*.[85]
+
+ dodoc BUGS CHANGELOG CREDITS README TODO \
+ doc/rfc2661.txt doc/*.sample
+
+ dodir /etc/l2tpd
+ head -n 2 doc/l2tp-secrets.sample > "${D}/etc/l2tpd/l2tp-secrets"
+ fperms 0600 /etc/l2tpd/l2tp-secrets
+
+ newinitd "${FILESDIR}/l2tpd-init" l2tpd
+}