summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-01-08 16:50:12 +0000
committerMike Gilbert <floppym@gentoo.org>2014-01-08 16:50:12 +0000
commit1362c2a5190799913c8f91bc871108404d4815a1 (patch)
treec155126475f6d717d2b5a291bc34d8d67ef444d9 /net-dialup
parentInstall sample config file as /etc/xl2tpd/xl2tpd.conf. (diff)
downloadgentoo-2-1362c2a5190799913c8f91bc871108404d4815a1.tar.gz
gentoo-2-1362c2a5190799913c8f91bc871108404d4815a1.tar.bz2
gentoo-2-1362c2a5190799913c8f91bc871108404d4815a1.zip
Revbump for last change.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/xl2tpd/ChangeLog7
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.3.1-r4.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/net-dialup/xl2tpd/ChangeLog b/net-dialup/xl2tpd/ChangeLog
index fb40f6c33a9e..33c0201ac854 100644
--- a/net-dialup/xl2tpd/ChangeLog
+++ b/net-dialup/xl2tpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/xl2tpd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.42 2014/01/08 16:49:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.43 2014/01/08 16:50:12 floppym Exp $
+
+*xl2tpd-1.3.1-r4 (08 Jan 2014)
+
+ 08 Jan 2014; Mike Gilbert <floppym@gentoo.org> +xl2tpd-1.3.1-r4.ebuild:
+ Revbump for last change.
08 Jan 2014; Mike Gilbert <floppym@gentoo.org> xl2tpd-1.3.1-r3.ebuild:
Install sample config file as /etc/xl2tpd/xl2tpd.conf.
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.1-r4.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.1-r4.ebuild
new file mode 100644
index 000000000000..51a60ca96f07
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.3.1-r4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.3.1-r4.ebuild,v 1.1 2014/01/08 16:50:12 floppym Exp $
+
+EAPI="5"
+
+inherit eutils systemd toolchain-funcs vcs-snapshot
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="http://www.xelerance.com/services/software/xl2tpd/"
+SRC_URI="https://github.com/xelerance/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dnsretry +kernel"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}
+ net-dialup/ppp"
+DEPEND+=" kernel? ( >=sys-kernel/linux-headers-2.6.23 )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.3.0-LDFLAGS.patch"
+ epatch "${FILESDIR}/${PN}-1.3.1-CFLAGS.patch"
+ epatch "${FILESDIR}/${PN}-1.3.1-no-type-punning-b119c0da.patch"
+ epatch "${FILESDIR}/${PN}-1.3.1-kernelmode.patch"
+ sed -i Makefile -e 's| -O2||g' || die "sed Makefile"
+ # The below patch is questionable. Why wasn't it submitted upstream? If it
+ # ever breaks, it will just be removed. -darkside 20120914
+ use dnsretry && epatch "${FILESDIR}/${PN}-dnsretry.patch"
+ # Remove bundled headers
+ rm -r linux || die
+}
+
+src_compile() {
+ tc-export CC
+ export OSFLAGS="-DLINUX"
+ use kernel && OSFLAGS+=" -DUSE_KERNEL"
+ emake
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+ dodoc CREDITS README.xl2tpd BUGS CHANGES TODO doc/README.patents doc/rfc2661.txt
+ insinto /etc/xl2tpd
+ newins doc/l2tpd.conf.sample xl2tpd.conf
+ newins doc/l2tp-secrets.sample l2tp-secrets
+ fperms 0600 /etc/xl2tpd/l2tp-secrets
+ newinitd "${FILESDIR}"/xl2tpd-init-r1 xl2tpd
+ systemd_dounit "${FILESDIR}"/xl2tpd.service
+ systemd_dotmpfilesd "${FILESDIR}"/xl2tpd.conf
+}