summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-08 08:58:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-08 08:58:20 +0000
commit314e4a67f8d92e7cb5cdbc6fe6837c72874958e0 (patch)
treeba4c4bde8bf0b12d5d25f5d9c1c49fd50cb63436 /net-dialup
parentRemove invalid USE debug inherited with gnome2.eclass. Disable mozilla plug-i... (diff)
downloadgentoo-2-314e4a67f8d92e7cb5cdbc6fe6837c72874958e0.tar.gz
gentoo-2-314e4a67f8d92e7cb5cdbc6fe6837c72874958e0.tar.bz2
gentoo-2-314e4a67f8d92e7cb5cdbc6fe6837c72874958e0.zip
Fix building with GLIBC 2.10+ wrt #277593. Rename modprobe.d/mwave to modprobe.d/mwave.conf.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/mwavem/ChangeLog9
-rw-r--r--net-dialup/mwavem/files/mwavem-2.0-glibc-2.10.patch40
-rw-r--r--net-dialup/mwavem/mwavem-2.0-r1.ebuild11
3 files changed, 53 insertions, 7 deletions
diff --git a/net-dialup/mwavem/ChangeLog b/net-dialup/mwavem/ChangeLog
index 2f5b6b910c98..c41bf41c686d 100644
--- a/net-dialup/mwavem/ChangeLog
+++ b/net-dialup/mwavem/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/mwavem
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mwavem/ChangeLog,v 1.16 2009/05/09 13:23:56 mrness Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mwavem/ChangeLog,v 1.17 2009/08/08 08:58:20 ssuominen Exp $
+
+ 08 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> mwavem-2.0-r1.ebuild,
+ +files/mwavem-2.0-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #277593. Rename modprobe.d/mwave to
+ modprobe.d/mwave.conf.
09 May 2009; Alin Năstac <mrness@gentoo.org> mwavem-2.0-r1.ebuild:
Migrate to EAPI 2.
diff --git a/net-dialup/mwavem/files/mwavem-2.0-glibc-2.10.patch b/net-dialup/mwavem/files/mwavem-2.0-glibc-2.10.patch
new file mode 100644
index 000000000000..fa867986ec22
--- /dev/null
+++ b/net-dialup/mwavem/files/mwavem-2.0-glibc-2.10.patch
@@ -0,0 +1,40 @@
+diff -ur mwavem-2.0.orig/src/include/mwmparsi.h mwavem-2.0/src/include/mwmparsi.h
+--- mwavem-2.0.orig/src/include/mwmparsi.h 2001-05-04 22:28:52.000000000 +0300
++++ mwavem-2.0/src/include/mwmparsi.h 2009-08-08 11:58:51.000000000 +0300
+@@ -516,8 +516,8 @@
+
+
+ #ifdef DEBUG
+- void dprintf(char *szFormat, ...);
+- #define DPF dprintf
++ void mwavem_dprintf(char *szFormat, ...);
++ #define DPF mwavem_dprintf
+
+ #else
+ #define DPF ((void)0)
+diff -ur mwavem-2.0.orig/src/include/mwmspcfc.h mwavem-2.0/src/include/mwmspcfc.h
+--- mwavem-2.0.orig/src/include/mwmspcfc.h 2001-05-04 22:28:52.000000000 +0300
++++ mwavem-2.0/src/include/mwmspcfc.h 2009-08-08 11:56:34.000000000 +0300
+@@ -705,8 +705,8 @@
+ void MWM_ENTRY mwmPostMessage(UINT uMsg, LONG wParam, LONG lParam); // @TBD
+
+ #ifdef DEBUG
+- void dprintf(char *szFormat, ...);
+- #define DPF dprintf
++ void mwavem_dprintf(char *szFormat, ...);
++ #define DPF mwavem_dprintf
+ #else
+ #define DPF ((void)0)
+ #endif
+diff -ur mwavem-2.0.orig/src/mwmlw32/mwmload.c mwavem-2.0/src/mwmlw32/mwmload.c
+--- mwavem-2.0.orig/src/mwmlw32/mwmload.c 2004-03-31 06:58:55.000000000 +0300
++++ mwavem-2.0/src/mwmlw32/mwmload.c 2009-08-08 11:56:50.000000000 +0300
+@@ -72,7 +72,7 @@
+
+
+ #define MODNAME "MWMODEM"
+-void dprintf(char *szFormat, ...)
++void mwavem_dprintf(char *szFormat, ...)
+ {
+ /*if (usDebugWindow)
+ {*/
diff --git a/net-dialup/mwavem/mwavem-2.0-r1.ebuild b/net-dialup/mwavem/mwavem-2.0-r1.ebuild
index 97172cc947c4..59d38fcf2a4a 100644
--- a/net-dialup/mwavem/mwavem-2.0-r1.ebuild
+++ b/net-dialup/mwavem/mwavem-2.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mwavem/mwavem-2.0-r1.ebuild,v 1.3 2009/05/09 13:23:56 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mwavem/mwavem-2.0-r1.ebuild,v 1.4 2009/08/08 08:58:20 ssuominen Exp $
EAPI="2"
-inherit autotools
+inherit autotools eutils
DESCRIPTION="User level application for IBM Mwave modem"
HOMEPAGE="http://oss.software.ibm.com/acpmodem/"
@@ -12,16 +12,17 @@ SRC_URI="ftp://www-126.ibm.com/pub/acpmodem/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="~amd64 x86"
IUSE=""
src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
eautoreconf
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
exeinto /usr/sbin
doexe "${FILESDIR}/mwave-dev-handler"
@@ -30,7 +31,7 @@ src_install() {
newins "${FILESDIR}/mwave.devfs" mwave
insinto /etc/modprobe.d
- newins "${FILESDIR}/mwave.modules" mwave
+ newins "${FILESDIR}/mwave.modules" mwave.conf
dodoc AUTHORS ChangeLog FAQ NEWS README README.devfs THANKS
docinto doc