summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-12-25 17:58:13 +0000
committerMike Gilbert <floppym@gentoo.org>2012-12-25 17:58:13 +0000
commit5ba4fccb9a9b70dd18e76a45c9d31e8adf369727 (patch)
tree43f5fc27f082bcf96e6a07641f54c3eea8c3b5fb /net-dialup
parentFix build of stable ebuild, bug #448494. (diff)
downloadgentoo-2-5ba4fccb9a9b70dd18e76a45c9d31e8adf369727.tar.gz
gentoo-2-5ba4fccb9a9b70dd18e76a45c9d31e8adf369727.tar.bz2
gentoo-2-5ba4fccb9a9b70dd18e76a45c9d31e8adf369727.zip
Fix path in init script.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/xl2tpd/ChangeLog8
-rw-r--r--net-dialup/xl2tpd/files/xl2tpd-init-r16
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.3.1-r1.ebuild46
3 files changed, 55 insertions, 5 deletions
diff --git a/net-dialup/xl2tpd/ChangeLog b/net-dialup/xl2tpd/ChangeLog
index dd817e7e9bc0..1779ed03dba1 100644
--- a/net-dialup/xl2tpd/ChangeLog
+++ b/net-dialup/xl2tpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/xl2tpd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.29 2012/09/14 20:34:25 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.30 2012/12/25 17:58:12 floppym Exp $
+
+*xl2tpd-1.3.1-r1 (25 Dec 2012)
+
+ 25 Dec 2012; Mike Gilbert <floppym@gentoo.org> +xl2tpd-1.3.1-r1.ebuild,
+ files/xl2tpd-init-r1:
+ Fix path in init script.
14 Sep 2012; Jeremy Olexa <darkside@gentoo.org> -xl2tpd-1.2.4.ebuild,
-files/xl2tpd-1.2.4-as-needed.patch, -xl2tpd-1.2.6-r1.ebuild,
diff --git a/net-dialup/xl2tpd/files/xl2tpd-init-r1 b/net-dialup/xl2tpd/files/xl2tpd-init-r1
index 56766e5891c5..af069692f009 100644
--- a/net-dialup/xl2tpd/files/xl2tpd-init-r1
+++ b/net-dialup/xl2tpd/files/xl2tpd-init-r1
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/files/xl2tpd-init-r1,v 1.1 2012/09/10 19:28:12 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/files/xl2tpd-init-r1,v 1.2 2012/12/25 17:58:13 floppym Exp $
depend() {
need net
@@ -13,9 +13,7 @@ checkconfig() {
return 1
fi
- if [ ! -d /var/run/nscd ] ; then
- checkpath -d -m 755 /var/run/nscd
- fi
+ checkpath -d -m 755 /var/run/xl2tpd
return 0
}
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.1-r1.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..1d334d4b03f6
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.3.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.3.1-r1.ebuild,v 1.1 2012/12/25 17:58:12 floppym Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="http://www.xelerance.com/services/software/xl2tpd/"
+SRC_URI="https://github.com/xelerance/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dnsretry"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}
+ net-dialup/ppp"
+
+S="${WORKDIR}/xelerance-${PN}-95445fc"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.3.0-LDFLAGS.patch"
+ sed -i Makefile -e 's| -O2 ||g' || die "sed Makefile"
+ # The below patch is questionable. Why wasn't it submitted upstream? If it
+ # ever breaks, it will just be removed. -darkside 20120914
+ use dnsretry && epatch "${FILESDIR}/${PN}-dnsretry.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ dodoc CREDITS README.xl2tpd BUGS CHANGES TODO doc/README.patents doc/rfc2661.txt
+
+ dodir /etc/xl2tpd
+ cp doc/l2tp-secrets.sample "${ED}/etc/xl2tpd/l2tp-secrets" || die
+ cp doc/l2tpd.conf.sample "${ED}/etc/xl2tpd/xl2tpd.conf" || die
+ fperms 0600 /etc/xl2tpd/l2tp-secrets
+ newinitd "${FILESDIR}"/xl2tpd-init-r1 xl2tpd
+}