summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-06-24 12:15:50 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-06-24 12:15:50 +0000
commit8d7c4886a6f0afd4e16ef8be8dad03cc13168dc6 (patch)
tree7ade08138e101ffd98d9516c5971697a9a38dc29 /net-dialup
parentRevision bump: EAPI 5, epatch_user, respect CC, AR and RANLIB, wrt bug #514866 (diff)
downloadgentoo-2-8d7c4886a6f0afd4e16ef8be8dad03cc13168dc6.tar.gz
gentoo-2-8d7c4886a6f0afd4e16ef8be8dad03cc13168dc6.tar.bz2
gentoo-2-8d7c4886a6f0afd4e16ef8be8dad03cc13168dc6.zip
Add patch for latest revision, that is accidantly missing
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/rp-l2tp/ChangeLog6
-rw-r--r--net-dialup/rp-l2tp/files/rp-l2tp-0.4-build.patch68
2 files changed, 73 insertions, 1 deletions
diff --git a/net-dialup/rp-l2tp/ChangeLog b/net-dialup/rp-l2tp/ChangeLog
index fe733bf523d5..74ad908a4b47 100644
--- a/net-dialup/rp-l2tp/ChangeLog
+++ b/net-dialup/rp-l2tp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/rp-l2tp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/rp-l2tp/ChangeLog,v 1.20 2014/06/24 12:11:04 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/rp-l2tp/ChangeLog,v 1.21 2014/06/24 12:15:50 pinkbyte Exp $
+
+ 24 Jun 2014; Sergey Popov <pinkbyte@gentoo.org>
+ +files/rp-l2tp-0.4-build.patch:
+ Add patch for latest revision, that is accidantly missing
*rp-l2tp-0.4-r3 (24 Jun 2014)
diff --git a/net-dialup/rp-l2tp/files/rp-l2tp-0.4-build.patch b/net-dialup/rp-l2tp/files/rp-l2tp-0.4-build.patch
new file mode 100644
index 000000000000..7bb534b67940
--- /dev/null
+++ b/net-dialup/rp-l2tp/files/rp-l2tp-0.4-build.patch
@@ -0,0 +1,68 @@
+--- Makefile.in.orig 2014-06-24 15:20:47.028342728 +0400
++++ Makefile.in 2014-06-24 15:21:07.468320934 +0400
+@@ -39,8 +39,8 @@
+
+ libl2tp.a: $(OBJS)
+ rm -f $@
+- ar -rc $@ $^
+- ranlib $@ || true
++ $(AR) -rc $@ $^
++ @RANLIB@ $@ || true
+
+ l2tpd: libl2tp.a libevent/libevent.a
+ $(MAKE) -C handlers
+--- libevent/Makefile.in.orig 2002-09-30 23:45:00.000000000 +0400
++++ libevent/Makefile.in 2014-06-24 15:24:31.535105268 +0400
+@@ -18,20 +18,20 @@
+
+ libevent.a: $(OBJS)
+ rm -f libevent.a
+- ar -cq libevent.a $(OBJS)
++ $(AR) -cq libevent.a $(OBJS)
+ @RANLIB@ libevent.a
+
+ event.o: event.c $(HDRS)
+- gcc $(CFLAGS) -c -o event.o event.c
++ $(CC) $(CFLAGS) -c -o event.o event.c
+
+ hash.o: hash.c $(HDRS)
+- gcc $(CFLAGS) -c -o hash.o hash.c
++ $(CC) $(CFLAGS) -c -o hash.o hash.c
+
+ event_sig.o: event_sig.c $(HDRS)
+- gcc $(CFLAGS) -c -o event_sig.o event_sig.c
++ $(CC) $(CFLAGS) -c -o event_sig.o event_sig.c
+
+ event_tcp.o: event_tcp.c $(HDRS)
+- gcc $(CFLAGS) -c -o event_tcp.o event_tcp.c
++ $(CC) $(CFLAGS) -c -o event_tcp.o event_tcp.c
+
+ clean: FORCE
+ rm -f *.a *.o *~
+--- handlers/Makefile.in.orig 2014-06-24 15:31:35.186667624 +0400
++++ handlers/Makefile.in 2014-06-24 15:32:26.659615281 +0400
+@@ -20,19 +20,19 @@
+ all: $(HANDLERS) l2tp-control
+
+ l2tp-control: cmd-control.o
+- gcc $(LDFLAGS) -o l2tp-control cmd-control.o
++ $(CC) $(CFLAGS) $(LDFLAGS) -o l2tp-control cmd-control.o
+
+ cmd-control.o: cmd-control.c
+- gcc $(CFLAGS) -c -o $@ $^
++ $(CC) $(CFLAGS) -c -o $@ $^
+
+ %.o: %.c
+- gcc $(CFLAGS) -fPIC -c -o $@ $<
++ $(CC) $(CFLAGS) -fPIC -c -o $@ $<
+
+ sync-pppd.so: pty.o sync-pppd.o
+- gcc $(LDFLAGS) -shared -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^
+
+ cmd.so: cmd.o dstring.o
+- gcc $(LDFLAGS) -shared -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^
+
+ clean:
+ rm -f *.so *.o *~