summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-10-11 10:42:47 +0000
committerAlin Năstac <mrness@gentoo.org>2007-10-11 10:42:47 +0000
commitb061d10797808f340bd115009058be79ebd0f534 (patch)
tree1b7c0f538c1726738bb89febd55de21df971013d /net-dialup
parentStable on ppc64; bug #190303 (diff)
downloadgentoo-2-b061d10797808f340bd115009058be79ebd0f534.tar.gz
gentoo-2-b061d10797808f340bd115009058be79ebd0f534.tar.bz2
gentoo-2-b061d10797808f340bd115009058be79ebd0f534.zip
Version bump (#195459).
(Portage version: 2.1.2.12)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/umtsmon/ChangeLog7
-rw-r--r--net-dialup/umtsmon/files/digest-umtsmon-0.73
-rw-r--r--net-dialup/umtsmon/umtsmon-0.7.ebuild65
3 files changed, 74 insertions, 1 deletions
diff --git a/net-dialup/umtsmon/ChangeLog b/net-dialup/umtsmon/ChangeLog
index 79e919a13b97..de8b184bb069 100644
--- a/net-dialup/umtsmon/ChangeLog
+++ b/net-dialup/umtsmon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/umtsmon
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/umtsmon/ChangeLog,v 1.4 2007/10/02 16:13:28 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/umtsmon/ChangeLog,v 1.5 2007/10/11 10:42:46 mrness Exp $
+
+*umtsmon-0.7 (11 Oct 2007)
+
+ 11 Oct 2007; Alin Năstac <mrness@gentoo.org> +umtsmon-0.7.ebuild:
+ Version bump (#195459).
02 Oct 2007; Alin Năstac <mrness@gentoo.org> umtsmon-0.6.ebuild:
Use eqmake3 for generating the makefile (#194373). Install README and TODO
diff --git a/net-dialup/umtsmon/files/digest-umtsmon-0.7 b/net-dialup/umtsmon/files/digest-umtsmon-0.7
new file mode 100644
index 000000000000..a87d42418cc4
--- /dev/null
+++ b/net-dialup/umtsmon/files/digest-umtsmon-0.7
@@ -0,0 +1,3 @@
+MD5 cb2dc2a3b06a9945181c0a60c7f46a21 umtsmon-0.7.src.tar.gz 232095
+RMD160 65be563fcd39d7fd595fcb39b35d8680ef45af5b umtsmon-0.7.src.tar.gz 232095
+SHA256 296f20ffe48af297a5a9c13bd4e835c396cbba38a8abdcf14c45e977da1f8c8b umtsmon-0.7.src.tar.gz 232095
diff --git a/net-dialup/umtsmon/umtsmon-0.7.ebuild b/net-dialup/umtsmon/umtsmon-0.7.ebuild
new file mode 100644
index 000000000000..a2f985fea52f
--- /dev/null
+++ b/net-dialup/umtsmon/umtsmon-0.7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/umtsmon/umtsmon-0.7.ebuild,v 1.1 2007/10/11 10:42:46 mrness Exp $
+
+inherit eutils qt3
+
+DESCRIPTION="UMTSmon is a tool to control and monitor a wireless mobile network card (GPRS, EDGE, WCDMA, UMTS, EV-DO, HSDPA)"
+HOMEPAGE="http://umtsmon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/umtsmon/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="$(qt_min_version 3.3)
+ dev-libs/libusb"
+RDEPEND="${DEPEND}
+ net-dialup/ppp
+ sys-apps/pcmciautils"
+
+# for i18n support (probably will appear in version 0.8)
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+#MY_AVAILABLE_LINGUAS=" foo bar"
+#IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_compile() {
+ eqmake3 || die "eqmake3 failed"
+ emake || die "emake failed"
+
+ # for i18n support (probably will appear in version 0.8)
+ #local MY_LINGUAS="" lang
+
+ #for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ # if use linguas_${lang} ; then
+ # MY_LINGUAS="${MY_LINGUAS} ${lang}"
+ # fi
+ #done
+ #if [[ -z "${MY_LINGUAS}" ]] ; then
+ # #If no language is selected, install 'em all
+ # MY_LINGUAS="${MY_AVAILABLE_LINGUAS}"
+ #fi
+
+ #einfo "Following langpacks will be installed:"
+ #einfo " ${MY_LINGUAS}"
+
+ #for lang in ${MY_LINGUAS}; do
+ # lrelease i18n/umtsmon_${lang}.ts \
+ # || die "failed to install langpack for ${lang} language"
+ #done
+}
+
+src_install() {
+ dobin umtsmon || die "dobin failed"
+
+ domenu umtsmon.desktop
+ doicon images/128
+
+ # for i18n support (probably will appear in version 0.8)
+ #insinto /usr/share/umtsmon/i18n
+ #doins i18n/*.qm
+
+ dodoc AUTHORS README TODO
+}