summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-08-12 07:57:32 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-08-12 07:57:32 +0000
commitc278fc3e8e31e93e2865611fedf2fa43bb72a24a (patch)
tree39dcfa24901ab6cd965d66adfd34e42ca7a38d7b /net-dialup
parentx86 stable, see bug 500372. Thanks Myckel Habets for testing. (diff)
downloadgentoo-2-c278fc3e8e31e93e2865611fedf2fa43bb72a24a.tar.gz
gentoo-2-c278fc3e8e31e93e2865611fedf2fa43bb72a24a.tar.bz2
gentoo-2-c278fc3e8e31e93e2865611fedf2fa43bb72a24a.zip
Use latest ppp version
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/rp-pppoe/ChangeLog7
-rw-r--r--net-dialup/rp-pppoe/rp-pppoe-3.11-r2.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/net-dialup/rp-pppoe/ChangeLog b/net-dialup/rp-pppoe/ChangeLog
index 317600b402de..12574aa548bf 100644
--- a/net-dialup/rp-pppoe/ChangeLog
+++ b/net-dialup/rp-pppoe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/rp-pppoe
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/rp-pppoe/ChangeLog,v 1.105 2014/02/22 09:27:55 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/rp-pppoe/ChangeLog,v 1.106 2014/08/12 07:57:32 polynomial-c Exp $
+
+*rp-pppoe-3.11-r2 (12 Aug 2014)
+
+ 12 Aug 2014; Lars Wendler <polynomial-c@gentoo.org> +rp-pppoe-3.11-r2.ebuild:
+ Use latest ppp version.
*rp-pppoe-3.11-r1 (22 Feb 2014)
diff --git a/net-dialup/rp-pppoe/rp-pppoe-3.11-r2.ebuild b/net-dialup/rp-pppoe/rp-pppoe-3.11-r2.ebuild
new file mode 100644
index 000000000000..9dedc7a3ceb4
--- /dev/null
+++ b/net-dialup/rp-pppoe/rp-pppoe-3.11-r2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/rp-pppoe/rp-pppoe-3.11-r2.ebuild,v 1.1 2014/08/12 07:57:32 polynomial-c Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic autotools
+
+PPP_P="ppp-2.4.7"
+
+DESCRIPTION="A user-mode PPPoE client and server suite for Linux"
+HOMEPAGE="http://www.roaringpenguin.com/pppoe/"
+SRC_URI="http://www.roaringpenguin.com/files/download/${P}.tar.gz
+ ftp://ftp.samba.org/pub/ppp/${PPP_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="X"
+
+RDEPEND="net-dialup/ppp
+ X? ( dev-lang/tk )"
+# see bug #230491
+DEPEND="|| ( <sys-kernel/linux-headers-2.6.24 >=sys-kernel/linux-headers-2.6.25 )
+ ${RDEPEND}"
+
+src_prepare() {
+ # Patch to enable integration of pppoe-start and pppoe-stop with
+ # baselayout-1.11.x so that the pidfile can be found reliably per interface
+ epatch "${FILESDIR}/${PN}-3.10-gentoo-netscripts.patch"
+
+ epatch "${FILESDIR}/${PN}-3.10-username-charset.patch" # bug 82410
+ epatch "${FILESDIR}/${PN}-3.10-plugin-options.patch"
+ epatch "${FILESDIR}/${PN}-3.10-autotools.patch"
+ epatch "${FILESDIR}/${PN}-3.10-session-offset.patch" # bug 204476
+ has_version '<sys-kernel/linux-headers-2.6.35' && \
+ epatch "${FILESDIR}/${PN}-3.10-linux-headers.patch" #334197
+ epatch "${FILESDIR}/${PN}-3.10-posix-source-sigaction.patch"
+ epatch "${FILESDIR}/${PN}-3.11-gentoo.patch"
+
+ cd "${S}"/src || die
+ eautoreconf
+}
+
+src_configure() {
+ addpredict /dev/ppp
+
+ cd "${S}/src" || die
+ econf --enable-plugin=../../${PPP_P}
+}
+
+src_compile() {
+ cd "${S}/src" || die
+ emake
+
+ if use X; then
+ make -C "${S}/gui" || die "gui make failed"
+ fi
+}
+
+src_install () {
+ cd "${S}/src" || die
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+
+ #Don't use compiled rp-pppoe plugin - see pkg_preinst below
+ local pppoe_plugin="${D}/etc/ppp/plugins/rp-pppoe.so"
+ if [ -f "${pppoe_plugin}" ] ; then
+ rm "${pppoe_plugin}" || die
+ fi
+
+ if use X; then
+ emake -C "${S}/gui" \
+ DESTDIR="${D}" \
+ datadir=/usr/share/doc/${PF}/ \
+ install
+ dosym /usr/share/doc/${PF}/tkpppoe /usr/share/tkpppoe
+ fi
+}
+
+pkg_preinst() {
+ # Use the rp-pppoe plugin that comes with net-dialup/pppd
+ local PPPD_VER=$(best_version net-dialup/ppp)
+ PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER%%-*} #reduce it to ${PV}
+ if [ -n "${PPPD_VER}" ] && [ -f "${ROOT}/usr/lib/pppd/${PPPD_VER}/rp-pppoe.so" ] ; then
+ dosym /usr/lib/pppd/${PPPD_VER}/rp-pppoe.so /etc/ppp/plugins/rp-pppoe.so
+ fi
+}
+
+pkg_postinst() {
+ elog "Use pppoe-setup to configure your dialup connection."
+}