summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-11-19 13:11:19 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-11-19 13:11:19 +0000
commit39f6c2cd897b188d8d596363e4371b611b054f27 (patch)
tree8ec1d560584b11a53a43789023d4efefd83f9853 /net-dns/knot
parentVersion bump to latest, stabilise older everywhere, drop oldest. (diff)
downloadgentoo-2-39f6c2cd897b188d8d596363e4371b611b054f27.tar.gz
gentoo-2-39f6c2cd897b188d8d596363e4371b611b054f27.tar.bz2
gentoo-2-39f6c2cd897b188d8d596363e4371b611b054f27.zip
Version bump to latest release, drop older.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'net-dns/knot')
-rw-r--r--net-dns/knot/ChangeLog7
-rw-r--r--net-dns/knot/knot-1.1.1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-dns/knot/ChangeLog b/net-dns/knot/ChangeLog
index 38d254918a80..305ed5fc92b3 100644
--- a/net-dns/knot/ChangeLog
+++ b/net-dns/knot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/knot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/ChangeLog,v 1.13 2012/10/21 15:42:31 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/ChangeLog,v 1.14 2012/11/19 13:11:19 scarabeus Exp $
+
+*knot-1.1.1 (19 Nov 2012)
+
+ 19 Nov 2012; Tomáš Chvátal <scarabeus@gentoo.org> +knot-1.1.1.ebuild:
+ Version bump to latest release, drop older.
21 Oct 2012; Tomáš Chvátal <scarabeus@gentoo.org> knot-1.1.0.ebuild:
Use elog instead of einfo.
diff --git a/net-dns/knot/knot-1.1.1.ebuild b/net-dns/knot/knot-1.1.1.ebuild
new file mode 100644
index 000000000000..7ae394e5be1b
--- /dev/null
+++ b/net-dns/knot/knot-1.1.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/knot-1.1.1.ebuild,v 1.1 2012/11/19 13:11:19 scarabeus Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="http://www.knot-dns.cz/"
+SRC_URI="http://public.nic.cz/files/knot-dns/${P/_/-}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/openssl
+ dev-libs/userspace-rcu
+"
+# sys-libs/glibc
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/flex
+ virtual/yacc
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-move-pidfile-to-var.patch
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
+ --libexecdir="${EPREFIX}/usr/libexec/${PN}" \
+ --disable-lto \
+ --enable-recvmmsg \
+ $(use_enable debug debug server,zones,xfr,packet,dname,rr,ns,hash,compiler) \
+ $(use_enable debug debuglevel details)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/knot.init" knot-dns
+}
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]] ; then
+ elog "Remember to recompile all zones after update. Run:"
+ elog " # knotc stop"
+ elog " # knotc compile"
+ elog " # knotc start"
+ fi
+}