summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-04-19 10:45:05 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-04-19 10:45:05 +0000
commit834616a1e6df96d2f4b200612ef14a4e8d213503 (patch)
treee8cd333fc03af2dc2d62c04663c0c728d3bffce3 /net-dns/noip-updater
parentVersion bump. (diff)
downloadgentoo-2-834616a1e6df96d2f4b200612ef14a4e8d213503.tar.gz
gentoo-2-834616a1e6df96d2f4b200612ef14a4e8d213503.tar.bz2
gentoo-2-834616a1e6df96d2f4b200612ef14a4e8d213503.zip
version bump as per bug #173827 thanks to Dekel Amrani
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-dns/noip-updater')
-rw-r--r--net-dns/noip-updater/ChangeLog10
-rw-r--r--net-dns/noip-updater/files/digest-noip-updater-2.1.43
-rw-r--r--net-dns/noip-updater/noip-updater-2.1.4.ebuild60
3 files changed, 71 insertions, 2 deletions
diff --git a/net-dns/noip-updater/ChangeLog b/net-dns/noip-updater/ChangeLog
index c839083dd210..3433e60bf961 100644
--- a/net-dns/noip-updater/ChangeLog
+++ b/net-dns/noip-updater/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/noip-updater
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/noip-updater/ChangeLog,v 1.19 2006/10/29 02:21:31 dragonheart Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/noip-updater/ChangeLog,v 1.20 2007/04/19 10:45:05 dragonheart Exp $
+
+*noip-updater-2.1.4 (19 Apr 2007)
+
+ 19 Apr 2007; Daniel Black <dragonheart@gentoo.org>
+ +noip-updater-2.1.4.ebuild:
+ version bump as per bug #173827 thanks to Dekel Amrani
*noip-updater-2.1.3 (29 Oct 2006)
diff --git a/net-dns/noip-updater/files/digest-noip-updater-2.1.4 b/net-dns/noip-updater/files/digest-noip-updater-2.1.4
new file mode 100644
index 000000000000..927f3e502e3b
--- /dev/null
+++ b/net-dns/noip-updater/files/digest-noip-updater-2.1.4
@@ -0,0 +1,3 @@
+MD5 d65e221016a61cd4e412242c34c71ff1 noip-2.1.4.tar.gz 102789
+RMD160 77960ab3e9b87eac843408831ae45e297e7effc8 noip-2.1.4.tar.gz 102789
+SHA256 8912301be611b842d0cf1a335275c367f3a80d507bc53c7460c68b52d71b1a7c noip-2.1.4.tar.gz 102789
diff --git a/net-dns/noip-updater/noip-updater-2.1.4.ebuild b/net-dns/noip-updater/noip-updater-2.1.4.ebuild
new file mode 100644
index 000000000000..cefe9673fa8b
--- /dev/null
+++ b/net-dns/noip-updater/noip-updater-2.1.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/noip-updater/noip-updater-2.1.4.ebuild,v 1.1 2007/04/19 10:45:05 dragonheart Exp $
+
+inherit eutils toolchain-funcs
+
+IUSE=""
+
+MY_P=${P/-updater/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="no-ip.com dynamic DNS updater"
+HOMEPAGE="http://www.no-ip.com"
+SRC_URI="http://www.no-ip.com/client/linux/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/libc"
+
+DEPEND="${RDEPEND} sys-devel/gcc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/noip-2.1.3-cflags.patch || die
+ sed -i \
+ -e "s:\(#define CONFIG_FILEPATH\).*:\1 \"/etc\":" \
+ -e "s:\(#define CONFIG_FILENAME\).*:\1 \"/etc/no-ip2.conf\":" \
+ noip2.c || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ PREFIX=/usr \
+ CONFDIR=/etc || die
+}
+
+src_install() {
+ into /usr
+ dosbin noip2
+ dodoc README.FIRST COPYING
+ exeinto /etc/init.d
+ newexe "${FILESDIR}"/noip2.start noip
+}
+
+pkg_postinst() {
+ einfo "Configuration can be done manually via:"
+ einfo "/usr/sbin/noip2 -C or "
+ einfo "first time you use the /etc/init.d/noip script; or"
+ einfo "by using this ebuild's config option."
+}
+
+pkg_config() {
+ cd /tmp
+ einfo "Answer the following questions."
+ noip2 -C || die
+}
+