summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-05-01 21:19:04 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-05-01 21:19:04 +0000
commitaadbf918e5ad8a41965237e36aeefc41b97e3457 (patch)
tree2e13b59ba0c0352228d36912ef5f2b0036666083 /net-dns/noip-updater
parentVersion bump. (diff)
downloadgentoo-2-aadbf918e5ad8a41965237e36aeefc41b97e3457.tar.gz
gentoo-2-aadbf918e5ad8a41965237e36aeefc41b97e3457.tar.bz2
gentoo-2-aadbf918e5ad8a41965237e36aeefc41b97e3457.zip
fix bug #218001 - no ebuild changes just a new rc script without a space that needs to be picked up
(Portage version: 2.1.4.4, RepoMan options: --force)
Diffstat (limited to 'net-dns/noip-updater')
-rw-r--r--net-dns/noip-updater/ChangeLog7
-rw-r--r--net-dns/noip-updater/files/noip2.start2
-rw-r--r--net-dns/noip-updater/noip-updater-2.1.7-r1.ebuild57
3 files changed, 64 insertions, 2 deletions
diff --git a/net-dns/noip-updater/ChangeLog b/net-dns/noip-updater/ChangeLog
index a27f3e9f6c8b..5308d61c1ea9 100644
--- a/net-dns/noip-updater/ChangeLog
+++ b/net-dns/noip-updater/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/noip-updater
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/noip-updater/ChangeLog,v 1.31 2008/03/05 19:37:16 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/noip-updater/ChangeLog,v 1.32 2008/05/01 21:19:04 dragonheart Exp $
+
+*noip-updater-2.1.7-r1 (02 May 2008)
+
+ 02 May 2008; Daniel Black <dragonheart@gentoo.org> noip-updater-2.1.7-r1.ebuild:
+ as per bug #218001 there was a extra space in the init script. Thanks to Roy for finding it.
05 Mar 2008; Santiago M. Mola <coldwind@gentoo.org>
noip-updater-2.1.7.ebuild:
diff --git a/net-dns/noip-updater/files/noip2.start b/net-dns/noip-updater/files/noip2.start
index 32afcea637e6..a955c7780979 100644
--- a/net-dns/noip-updater/files/noip2.start
+++ b/net-dns/noip-updater/files/noip2.start
@@ -1,4 +1,4 @@
-#! /sbin/runscript
+#!/sbin/runscript
depend() {
need localmount
diff --git a/net-dns/noip-updater/noip-updater-2.1.7-r1.ebuild b/net-dns/noip-updater/noip-updater-2.1.7-r1.ebuild
new file mode 100644
index 000000000000..0e73a632a3be
--- /dev/null
+++ b/net-dns/noip-updater/noip-updater-2.1.7-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/noip-updater/noip-updater-2.1.7-r1.ebuild,v 1.1 2008/05/01 21:19:04 dragonheart Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/-updater/}
+DESCRIPTION="no-ip.com dynamic DNS updater"
+HOMEPAGE="http://www.no-ip.com"
+SRC_URI="http://www.no-ip.com/client/linux/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ~mips ~ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/gcc"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/noip-2.1.3-cflags.patch
+ epatch "${FILESDIR}"/noip-2.1.4-daemon.patch
+ sed -i \
+ -e "s:\(#define CONFIG_FILEPATH\).*:\1 \"/etc\":" \
+ -e "s:\(#define CONFIG_FILENAME\).*:\1 \"/etc/no-ip2.conf\":" \
+ noip2.c || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ PREFIX=/usr \
+ CONFDIR=/etc || die "emake failed"
+}
+
+src_install() {
+ dosbin noip2
+ dodoc README.FIRST
+ newinitd "${FILESDIR}"/noip2.start noip
+}
+
+pkg_postinst() {
+ elog "Configuration can be done manually via:"
+ elog "/usr/sbin/noip2 -C or "
+ elog "first time you use the /etc/init.d/noip script; or"
+ elog "by using this ebuild's config option."
+}
+
+pkg_config() {
+ cd /tmp
+ einfo "Answer the following questions."
+ noip2 -C || die
+}