summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-06-17 23:53:35 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-06-17 23:53:35 +0000
commit1b1882b4ec75f6033050b9e68c816660baba7577 (patch)
tree581d3251cdebfa5a43541745916d1670c2202060 /net-dns
parentAdd better support for finding out-of-tree builds when searching in /lib/modules (diff)
downloadgentoo-2-1b1882b4ec75f6033050b9e68c816660baba7577.tar.gz
gentoo-2-1b1882b4ec75f6033050b9e68c816660baba7577.tar.bz2
gentoo-2-1b1882b4ec75f6033050b9e68c816660baba7577.zip
Version bumped. Removed libevent USE flag. Fixed python handling.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/unbound/ChangeLog7
-rw-r--r--net-dns/unbound/unbound-1.4.5.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/net-dns/unbound/ChangeLog b/net-dns/unbound/ChangeLog
index 7f8e3df9ea8d..1605ae2c9c25 100644
--- a/net-dns/unbound/ChangeLog
+++ b/net-dns/unbound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/unbound
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.14 2010/04/23 08:51:39 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.15 2010/06/17 23:53:35 matsuu Exp $
+
+*unbound-1.4.5 (17 Jun 2010)
+
+ 17 Jun 2010; MATSUU Takuto <matsuu@gentoo.org> +unbound-1.4.5.ebuild:
+ Version bumped. Removed libevent USE flag. Fixed python handling.
23 Apr 2010; Fabian Groffen <grobian@gentoo.org> unbound-1.4.4.ebuild:
Marked ~x64-macos, bug #312015
diff --git a/net-dns/unbound/unbound-1.4.5.ebuild b/net-dns/unbound/unbound-1.4.5.ebuild
new file mode 100644
index 000000000000..cb8c04f459e4
--- /dev/null
+++ b/net-dns/unbound/unbound-1.4.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.5.ebuild,v 1.1 2010/06/17 23:53:35 matsuu Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+inherit eutils multilib python
+
+DESCRIPTION="A validating, recursive and caching DNS resolver"
+HOMEPAGE="http://unbound.net/"
+SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+#IUSE="debug gost python static test threads"
+IUSE="debug python static test threads"
+
+RDEPEND="dev-libs/libevent
+ >=dev-libs/openssl-0.9.8
+ >=net-libs/ldns-1.4[ssl]"
+# gost? ( >=dev-libs/openssl-1 )
+
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ test? (
+ net-dns/ldns-utils[examples]
+ dev-util/splint
+ app-text/wdiff
+ )"
+
+pkg_setup() {
+ python_set_active_version 2
+ enewgroup unbound
+ enewuser unbound -1 -1 /etc/unbound unbound
+}
+
+src_configure() {
+ econf \
+ --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
+ --with-ldns="${EPREFIX}"/usr \
+ --with-libevent="${EPREFIX}"/usr \
+ $(use_enable debug) \
+ $(use_enable debug lock-checks) \
+ $(use_enable debug alloc-checks) \
+ $(use_enable debug alloc-lite) \
+ $(use_enable debug alloc-nonregional) \
+ $(use_enable static static-exe) \
+ $(use_with threads pthreads) \
+ $(use_with python pyunbound) \
+ $(use_with python pythonmodule) || die
+# $(use_enable gost) \
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # bug #299016
+ if use python ; then
+ rm "${ED}/usr/$(get_libdir)"/python*/site-packages/_unbound.*a || die
+ fi
+
+ newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
+ newconfd "${FILESDIR}/unbound.confd" unbound || die "newconfd failed"
+
+ dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES} || die "dodoc failed"
+ # bug #315519
+ dodoc contrib/unbound_munin_ || die "dodoc failed"
+
+ exeinto /usr/share/${PN}
+ doexe contrib/{update-anchor,update-itar,split-itar}.sh || die "doexe failed"
+}