summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-07-16 03:52:59 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-07-16 03:52:59 +0000
commit1d5ebe6a6b2063f4a1f127ede3adfe1b945298c6 (patch)
tree5cd62444c073dd035b921192aeca527e59622d64 /net-dns
parentUpdate live ebuild to remove revdep-rebuild.sh when installed in a prefix env... (diff)
downloadgentoo-2-1d5ebe6a6b2063f4a1f127ede3adfe1b945298c6.tar.gz
gentoo-2-1d5ebe6a6b2063f4a1f127ede3adfe1b945298c6.tar.bz2
gentoo-2-1d5ebe6a6b2063f4a1f127ede3adfe1b945298c6.zip
Version bumped. The ebuild was submitted by TANABE Ken-ichi.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/unbound/ChangeLog6
-rw-r--r--net-dns/unbound/files/unbound-1.4.12-gentoo.patch12
-rw-r--r--net-dns/unbound/unbound-1.4.12.ebuild98
3 files changed, 115 insertions, 1 deletions
diff --git a/net-dns/unbound/ChangeLog b/net-dns/unbound/ChangeLog
index 23df5426b5f4..f2a75b084a6f 100644
--- a/net-dns/unbound/ChangeLog
+++ b/net-dns/unbound/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/unbound
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.27 2011/07/03 01:28:00 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.28 2011/07/16 03:52:59 matsuu Exp $
+
+ 16 Jul 2011; MATSUU Takuto <matsuu@gentoo.org>
+ +files/unbound-1.4.12-gentoo.patch:
+ Version bumped. The ebuild was submitted by TANABE Ken-ichi.
*unbound-1.4.11 (03 Jul 2011)
diff --git a/net-dns/unbound/files/unbound-1.4.12-gentoo.patch b/net-dns/unbound/files/unbound-1.4.12-gentoo.patch
new file mode 100644
index 000000000000..57920689783e
--- /dev/null
+++ b/net-dns/unbound/files/unbound-1.4.12-gentoo.patch
@@ -0,0 +1,12 @@
+diff -Naur unbound-1.4.12.orig/doc/example.conf.in unbound-1.4.12/doc/example.conf.in
+--- unbound-1.4.12.orig/doc/example.conf.in 2011-07-14 17:33:37.000000000 +0900
++++ unbound-1.4.12/doc/example.conf.in 2011-07-16 10:01:06.644402341 +0900
+@@ -334,7 +334,7 @@
+ # with several entries, one file per entry.
+ # Zone file format, with DS and DNSKEY entries.
+ # Note this gets out of date, use auto-trust-anchor-file please.
+- # trust-anchor-file: ""
++ # trust-anchor-file: "@UNBOUND_ROOTKEY_FILE@"
+
+ # Trusted key for validation. DS or DNSKEY. specify the RR on a
+ # single line, surrounded by "". TTL is ignored. class is IN default.
diff --git a/net-dns/unbound/unbound-1.4.12.ebuild b/net-dns/unbound/unbound-1.4.12.ebuild
new file mode 100644
index 000000000000..5a3446ab7e8f
--- /dev/null
+++ b/net-dns/unbound/unbound-1.4.12.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.12.ebuild,v 1.1 2011/07/16 03:52:59 matsuu Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils flag-o-matic python
+
+DESCRIPTION="A validating, recursive and caching DNS resolver"
+HOMEPAGE="http://unbound.net/"
+SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="debug gost python static-libs test threads"
+
+RDEPEND="dev-libs/expat
+ dev-libs/libevent
+ >=dev-libs/openssl-0.9.8
+ >=net-libs/ldns-1.6.5[ssl,gost?]"
+
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ test? (
+ net-dns/ldns-utils[examples]
+ dev-util/splint
+ app-text/wdiff
+ )"
+
+# bug #347415
+RDEPEND="${RDEPEND}
+ net-dns/dnssec-root"
+
+pkg_setup() {
+ enewgroup unbound
+ enewuser unbound -1 -1 /etc/unbound unbound
+}
+
+src_prepare() {
+ # To avoid below error messages, set 'trust-anchor-file' to same value in
+ # 'auto-trust-anchor-file'.
+ # [23109:0] error: Could not open autotrust file for writing, # /etc/dnssec/root-anchors.txt: Permission denied
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack || die
+ econf \
+ --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
+ --with-ldns="${EPREFIX}"/usr \
+ --with-libevent="${EPREFIX}"/usr \
+ --with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt \
+ $(use_enable debug) \
+ $(use_enable gost) \
+ $(use_enable static-libs static) \
+ $(use_with threads pthreads) \
+ $(use_with python pyunbound) \
+ $(use_with python pythonmodule) \
+ --disable-rpath || die
+
+ # http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
+ # $(use_enable debug lock-checks) \
+ # $(use_enable debug alloc-checks) \
+ # $(use_enable debug alloc-lite) \
+ # $(use_enable debug alloc-nonregional) \
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # bug #299016
+ if use python ; then
+ find "${ED}" -name '_unbound.{la,a}' -delete || die
+ fi
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
+ fi
+
+ newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
+ newconfd "${FILESDIR}/unbound.confd" unbound || die "newconfd failed"
+
+ dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES} || die "dodoc failed"
+
+ # bug #315519
+ #exeinto /usr/libexec/munin/plugins
+ #doexe contrib/unbound_munin_ || die "doexe failed"
+ dodoc contrib/unbound_munin_ || die "dodoc failed"
+
+ docinto selinux
+ dodoc contrib/selinux/* || die "dodoc failed"
+
+ exeinto /usr/share/${PN}
+ doexe contrib/update-anchor.sh || die "doexe failed"
+}