summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-06-07 13:31:11 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-06-07 13:31:11 +0000
commitaf77370e713c3893e58496e8dff179c1876e7f49 (patch)
treeda3bbba604263fdb8bea2cb460dea300a93a9479 /net-firewall/iptables
parentClosing #51418. (Manifest recommit) (diff)
downloadgentoo-2-af77370e713c3893e58496e8dff179c1876e7f49.tar.gz
gentoo-2-af77370e713c3893e58496e8dff179c1876e7f49.tar.bz2
gentoo-2-af77370e713c3893e58496e8dff179c1876e7f49.zip
Possble fix for #46817.
Diffstat (limited to 'net-firewall/iptables')
-rw-r--r--net-firewall/iptables/ChangeLog8
-rw-r--r--net-firewall/iptables/iptables-1.2.9-r1.ebuild7
2 files changed, 10 insertions, 5 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 1d15da1d7f66..5b4f712fad2d 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,9 +1,11 @@
# ChangeLog for net-firewall/iptables
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.26 2004/06/07 13:24:36 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.27 2004/06/07 13:31:11 aliz Exp $
- 07 Jun 2004; Daniel Ahlberg <aliz@gentoo.org> iptables-1.2.9.ebuild:
- Handle extensionpatches that was added for 1.2.9-r1. Closing #51418.
+ 07 Jun 2004; Daniel Ahlberg <aliz@gentoo.org> iptables-1.2.9-r1.ebuild:
+ + Only run check_KV if /usr/src/liunx is a symlink or a directory, possible fix
+ for #46817.
+ + Handle extensionpatches that was added for 1.2.9-r1. Closing #51418.
10 May 2004; Daniel Ahlberg <aliz@gentoo.org> iptables-1.2.9-r1.ebuild:
CFLAGS must have -O flag, closing #44204
diff --git a/net-firewall/iptables/iptables-1.2.9-r1.ebuild b/net-firewall/iptables/iptables-1.2.9-r1.ebuild
index 2ea8956d9d4e..66cf9ffaf943 100644
--- a/net-firewall/iptables/iptables-1.2.9-r1.ebuild
+++ b/net-firewall/iptables/iptables-1.2.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r1.ebuild,v 1.3 2004/05/10 14:07:04 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r1.ebuild,v 1.4 2004/06/07 13:31:11 aliz Exp $
inherit eutils flag-o-matic
@@ -39,7 +39,10 @@ src_unpack() {
}
src_compile() {
- check_KV
+ # Only check_KV if /usr/src/linux exists
+ if [ -L ${ROOT}/usr/src/linux -o -d ${ROOT}/usr/src/linux ]; then
+ check_KV
+ fi
# prevent it from causing ICMP errors.
# http://bugs.gentoo.org/show_bug.cgi?id=23645