summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-09 21:52:35 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-09 21:52:35 +0000
commitde270ae1d9ca29a14357902e154a9b88ae0ac450 (patch)
treecedbb8dac72795a0d00bf32f71f6d13913dcdb1d /net-firewall/iptables
parentMinor fix (Manifest recommit) (diff)
downloadgentoo-2-de270ae1d9ca29a14357902e154a9b88ae0ac450.tar.gz
gentoo-2-de270ae1d9ca29a14357902e154a9b88ae0ac450.tar.bz2
gentoo-2-de270ae1d9ca29a14357902e154a9b88ae0ac450.zip
Fix use invocation and replace unnecessary subshell with if..then..fi
Diffstat (limited to 'net-firewall/iptables')
-rw-r--r--net-firewall/iptables/ChangeLog6
-rw-r--r--net-firewall/iptables/iptables-1.2.7a-r3.ebuild2
-rw-r--r--net-firewall/iptables/iptables-1.2.9-r1.ebuild10
-rw-r--r--net-firewall/iptables/iptables-1.2.9.ebuild4
4 files changed, 14 insertions, 8 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 5b4f712fad2d..6ad481c00b82 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/iptables
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.27 2004/06/07 13:31:11 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.28 2004/06/09 21:52:35 agriffis Exp $
+
+ 09 Jun 2004; Aron Griffis <agriffis@gentoo.org> iptables-1.2.7a-r3.ebuild,
+ iptables-1.2.9-r1.ebuild, iptables-1.2.9.ebuild:
+ Fix use invocation and replace unnecessary subshell with if..then..fi
07 Jun 2004; Daniel Ahlberg <aliz@gentoo.org> iptables-1.2.9-r1.ebuild:
+ Only run check_KV if /usr/src/liunx is a symlink or a directory, possible fix
diff --git a/net-firewall/iptables/iptables-1.2.7a-r3.ebuild b/net-firewall/iptables/iptables-1.2.7a-r3.ebuild
index 648e6b4a8857..34a3ee566965 100644
--- a/net-firewall/iptables/iptables-1.2.7a-r3.ebuild
+++ b/net-firewall/iptables/iptables-1.2.7a-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.7a-r3.ebuild,v 1.5 2004/04/21 11:58:22 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.7a-r3.ebuild,v 1.6 2004/06/09 21:52:35 agriffis Exp $
inherit eutils
diff --git a/net-firewall/iptables/iptables-1.2.9-r1.ebuild b/net-firewall/iptables/iptables-1.2.9-r1.ebuild
index 66cf9ffaf943..d7dbb1478992 100644
--- a/net-firewall/iptables/iptables-1.2.9-r1.ebuild
+++ b/net-firewall/iptables/iptables-1.2.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r1.ebuild,v 1.4 2004/06/07 13:31:11 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r1.ebuild,v 1.5 2004/06/09 21:52:35 agriffis Exp $
inherit eutils flag-o-matic
@@ -79,7 +79,7 @@ src_install() {
insinto /etc/conf.d
newins ${FILESDIR}/${PF}.confd iptables
- if [ `use ipv6` ]; then
+ if use ipv6; then
dodir /var/lib/ip6tables ; keepdir /var/lib/ip6tables
exeinto /etc/init.d
newexe ${FILESDIR}/${PF/iptables/ip6tables}.init ip6tables
@@ -104,7 +104,9 @@ pkg_postinst() {
einfo "Until a more permanent solution is implemented adding the following"
einfo "to /etc/conf.d/local.start will enable ipforwarding at bootup:"
einfo " echo \"1\" > /proc/sys/net/ipv4/conf/all/forwarding"
- use ipv6 >/dev/null && ( einfo "and/or"
+ if useq ipv6; then
+ einfo "and/or"
einfo " echo \"1\" > /proc/sys/net/ipv6/conf/all/forwarding"
- einfo "for ipv6." )
+ einfo "for ipv6."
+ fi
}
diff --git a/net-firewall/iptables/iptables-1.2.9.ebuild b/net-firewall/iptables/iptables-1.2.9.ebuild
index ca10d1b1b986..936e418ff500 100644
--- a/net-firewall/iptables/iptables-1.2.9.ebuild
+++ b/net-firewall/iptables/iptables-1.2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9.ebuild,v 1.11 2004/06/07 13:24:36 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9.ebuild,v 1.12 2004/06/09 21:52:35 agriffis Exp $
inherit eutils flag-o-matic
@@ -71,7 +71,7 @@ src_install() {
insinto /etc/conf.d
newins ${FILESDIR}/iptables.confd iptables
- if [ `use ipv6` ]; then
+ if use ipv6; then
dodir /var/lib/ip6tables ; keepdir /var/lib/ip6tables
exeinto /etc/init.d
newexe ${FILESDIR}/ip6tables.init ip6tables