summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-11-18 13:39:06 +0000
committerCédric Krier <cedk@gentoo.org>2007-11-18 13:39:06 +0000
commit01ee79fea1fc038cbcc7afb1320c82f10833c5e2 (patch)
treeeb6b3425fb1f86d8dd565ddca52cca64666a516b /net-firewall/nufw
parentStable on ppc64; bug #196481 (diff)
downloadgentoo-2-01ee79fea1fc038cbcc7afb1320c82f10833c5e2.tar.gz
gentoo-2-01ee79fea1fc038cbcc7afb1320c82f10833c5e2.tar.bz2
gentoo-2-01ee79fea1fc038cbcc7afb1320c82f10833c5e2.zip
Version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-firewall/nufw')
-rw-r--r--net-firewall/nufw/ChangeLog7
-rw-r--r--net-firewall/nufw/files/digest-nufw-2.2.83
-rw-r--r--net-firewall/nufw/nufw-2.2.8.ebuild98
3 files changed, 107 insertions, 1 deletions
diff --git a/net-firewall/nufw/ChangeLog b/net-firewall/nufw/ChangeLog
index 27d79d8c525e..cbcc15abd1cf 100644
--- a/net-firewall/nufw/ChangeLog
+++ b/net-firewall/nufw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/nufw
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/nufw/ChangeLog,v 1.19 2007/11/12 13:06:33 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/nufw/ChangeLog,v 1.20 2007/11/18 13:39:05 cedk Exp $
+
+*nufw-2.2.8 (18 Nov 2007)
+
+ 18 Nov 2007; Cédric Krier <cedk@gentoo.org> +nufw-2.2.8.ebuild:
+ Version bump
*nufw-2.2.7 (12 Nov 2007)
diff --git a/net-firewall/nufw/files/digest-nufw-2.2.8 b/net-firewall/nufw/files/digest-nufw-2.2.8
new file mode 100644
index 000000000000..3c07b9e239a7
--- /dev/null
+++ b/net-firewall/nufw/files/digest-nufw-2.2.8
@@ -0,0 +1,3 @@
+MD5 b5dd4eb606faa56661ec4c3e3a45b5c5 nufw-2.2.8.tar.bz2 542010
+RMD160 8723d70b66fe0d0f07ecb89a806356b6554be304 nufw-2.2.8.tar.bz2 542010
+SHA256 ef479e7006e2037d78331d5f7f35fa6fffc23bcea9e05e793db723a5052dbf1f nufw-2.2.8.tar.bz2 542010
diff --git a/net-firewall/nufw/nufw-2.2.8.ebuild b/net-firewall/nufw/nufw-2.2.8.ebuild
new file mode 100644
index 000000000000..d487a9cc4202
--- /dev/null
+++ b/net-firewall/nufw/nufw-2.2.8.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/nufw/nufw-2.2.8.ebuild,v 1.1 2007/11/18 13:39:05 cedk Exp $
+
+inherit autotools ssl-cert eutils
+
+DESCRIPTION="An enterprise grade authenticating firewall based on netfilter"
+HOMEPAGE="http://www.nufw.org/"
+SRC_URI="http://www.nufw.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug ldap mysql pam pam_nuauth plaintext postgres prelude \
+unicode nfqueue nfconntrack static syslog test"
+
+DEPEND=">=dev-libs/glib-2
+ dev-libs/libgcrypt
+ >=dev-libs/cyrus-sasl-2
+ net-firewall/iptables
+ >=net-libs/gnutls-1.1
+ ldap? ( >=net-nds/openldap-2 )
+ mysql? ( virtual/mysql )
+ pam? ( sys-libs/pam )
+ pam_nuauth? ( sys-libs/pam )
+ postgres? ( dev-db/postgresql )
+ nfqueue? ( net-libs/libnfnetlink
+ net-libs/libnetfilter_queue )
+ nfconntrack? ( net-libs/libnetfilter_conntrack )"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:^#\(nuauth_tls_key="/etc/nufw/\)nuauth-key.pem:\1nuauth.key:' \
+ -e 's:^#\(nuauth_tls_cert="/etc/nufw/\)nuauth-cert.pem:\1nuauth.pem:' \
+ conf/nuauth.conf || die "sed failed"
+ epatch "$FILESDIR"/${PN}-2.2.6-auth_mysql.patch
+
+ # This tests requre inl_tests to be installed. We don't have it now in our
+ # tree so we disable them for now... for more information see tests/README
+ use test && sed -i "s:\(^TESTS=test_all.py\):#\1:" tests/Makefile.am
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --with-shared \
+ $(use_enable static) \
+ $(use_enable pam_nuauth pam-nuauth) \
+ $(use_with prelude prelude-log) \
+ $(use_with mysql mysql-log) \
+ $(use_with mysql mysql-auth) \
+ $(use_with postgres pgsql-log) \
+ $(use_with syslog syslog-log) \
+ $(use_with plaintext plaintext-auth) \
+ --with-mark-group \
+ $(use_with pam system-auth) \
+ $(use_with ldap) \
+ $(use_with nfqueue) \
+ $(use_with nfconntrack) \
+ $(use_with unicode utf8) \
+ $(use_enable debug) \
+ --sysconfdir="/etc/nufw" \
+ --localstatedir="/var" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ ewarn "Some tests are skiped! If you wish to run them read tests/README and"
+ ewarn "do that manually."
+ ebeep 5
+ make check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}"/nufw-init.d nufw
+ newconfd "${FILESDIR}"/nufw-conf.d nufw
+
+ newinitd "${FILESDIR}"/nuauth-init.d nuauth
+ newconfd "${FILESDIR}"/nuauth-conf.d nuauth
+
+ insinto /etc/nufw
+ doins conf/nuauth.conf
+ docert nufw nuauth
+ keepdir /var/run/nuauth
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ docinto scripts
+ dodoc scripts/{clean_conntrack.pl,nuaclgen,nutop,README,ulog_rotate_daily.sh,ulog_rotate_weekly.sh}
+ docinto conf
+ dodoc conf/*.{nufw,schema,conf,dump,xml}
+}