summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-01-22 08:38:50 +0000
committerPeter Volkov <pva@gentoo.org>2009-01-22 08:38:50 +0000
commit447f4ff42654e39acec03cf99aac953726da44bd (patch)
tree27e1948242e71e08d357be8686e1d4e945bb9250 /net-firewall/shorewall6
parentVersion bump, bug #255437, thank Vieri for all work. (diff)
downloadgentoo-2-447f4ff42654e39acec03cf99aac953726da44bd.tar.gz
gentoo-2-447f4ff42654e39acec03cf99aac953726da44bd.tar.bz2
gentoo-2-447f4ff42654e39acec03cf99aac953726da44bd.zip
Initial import, bug #255437, thank Vieri for all work.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'net-firewall/shorewall6')
-rw-r--r--net-firewall/shorewall6/ChangeLog10
-rw-r--r--net-firewall/shorewall6/files/shorewall6.initd80
-rw-r--r--net-firewall/shorewall6/metadata.xml9
-rw-r--r--net-firewall/shorewall6/shorewall6-4.2.4.1.ebuild71
4 files changed, 170 insertions, 0 deletions
diff --git a/net-firewall/shorewall6/ChangeLog b/net-firewall/shorewall6/ChangeLog
new file mode 100644
index 000000000000..d3c0ef736efb
--- /dev/null
+++ b/net-firewall/shorewall6/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-firewall/shorewall6
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.1 2009/01/22 08:38:50 pva Exp $
+
+*shorewall6-4.2.4.1 (22 Jan 2009)
+
+ 22 Jan 2009; Peter Volkov <pva@gentoo.org> +files/shorewall6.initd,
+ +metadata.xml, +shorewall6-4.2.4.1.ebuild:
+ Initial import, bug #255437, thank Vieri for all work.
+
diff --git a/net-firewall/shorewall6/files/shorewall6.initd b/net-firewall/shorewall6/files/shorewall6.initd
new file mode 100644
index 000000000000..bb778fa19aca
--- /dev/null
+++ b/net-firewall/shorewall6/files/shorewall6.initd
@@ -0,0 +1,80 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/files/shorewall6.initd,v 1.1 2009/01/22 08:38:50 pva Exp $
+
+opts="start stop restart clear reset refresh check"
+
+depend() {
+ need net
+ provide firewall
+ after ulogd
+}
+
+start() {
+ ebegin "Starting firewall"
+ /sbin/shorewall6 -f start 1>/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping firewall"
+ /sbin/shorewall6 stop 1>/dev/null
+ eend $?
+}
+
+restart() {
+ # shorewall comes with its own control script that includes a
+ # restart function, so refrain from calling svc_stop/svc_start
+ # here. Note that this comment is required to fix bug 55576;
+ # runscript.sh greps this script... (09 Jul 2004 agriffis)
+ ebegin "Restarting firewall"
+ /sbin/shorewall6 status >/dev/null
+ if [ $? != 0 ] ; then
+ svc_start
+ else
+ if [ -f /var/lib/shorewall6/restore ] ; then
+ /sbin/shorewall6 restore
+ else
+ /sbin/shorewall6 restart 1>/dev/null
+ fi
+ fi
+ eend $?
+}
+
+clear() {
+ # clear will remove all the rules and bring the system to an unfirewalled
+ # state. (21 Nov 2004 eldad)
+
+ ebegin "Clearing all firewall rules and setting policy to ACCEPT"
+ /sbin/shorewall6 clear
+ eend $?
+}
+
+reset() {
+ # reset the packet and byte counters in the firewall
+
+ ebegin "Resetting the packet and byte counters in the firewall"
+ /sbin/shorewall6 reset
+ eend $?
+}
+
+refresh() {
+ # refresh the rules involving the broadcast addresses of firewall
+ # interfaces, the black list, traffic control rules and
+ # ECN control rules
+
+ ebegin "Refreshing firewall rules"
+ /sbin/shorewall6 refresh
+ eend $?
+}
+
+check() {
+ # perform cursory validation of the zones, interfaces, hosts, rules
+ # and policy files. CAUTION: does not parse and validate the generated
+ # iptables commands.
+
+ ebegin "Checking configuration files"
+ /sbin/shorewall6 check
+ eend $?
+}
diff --git a/net-firewall/shorewall6/metadata.xml b/net-firewall/shorewall6/metadata.xml
new file mode 100644
index 000000000000..89012d402a0c
--- /dev/null
+++ b/net-firewall/shorewall6/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<maintainer>
+ <email>rentorbuy@yahoo.com</email>
+ <name>Vieri</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-firewall/shorewall6/shorewall6-4.2.4.1.ebuild b/net-firewall/shorewall6/shorewall6-4.2.4.1.ebuild
new file mode 100644
index 000000000000..0d581f77c121
--- /dev/null
+++ b/net-firewall/shorewall6/shorewall6-4.2.4.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/shorewall6-4.2.4.1.ebuild,v 1.1 2009/01/22 08:38:50 pva Exp $
+
+inherit versionator linux-info
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/6/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="Shoreline Firewall with IPv6 support."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.4.0
+ sys-apps/iproute2
+ >=net-firewall/shorewall-perl-${MY_PV_BASE}
+ !<net-firewall/shorewall-4.0"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if kernel_is lt 2 6 25 ; then
+ die "${PN} requires at least kernel 2.6.25."
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die "doinitd failed"
+
+ dodoc releasenotes.txt
+ if use doc; then
+ cp -pR Samples6 "${D}/usr/share/doc/${PF}"
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo "There are man pages for ${PN}(8)."
+ einfo "For additional information, see"
+ einfo "http://www.shorewall.net/IPV6Support.html"
+ use doc && einfo "Sample configuration files are in /usr/share/doc/${PF}."
+ einfo
+ elog "If you wish to include DNS names in your IPv6 configuration files,"
+ elog "you must have Perl 5.10 and must emerge dev-perl/Socket6."
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+ einfo
+}