summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-02-28 11:42:23 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-02-28 11:42:23 +0000
commit3141567875cc04d64590844689b9db36fb770827 (patch)
tree46b3acf5cf6e5caee3f2f0e1d6223e4a1fb5a8a5 /net-firewall/ufw/files
parentBump to 1.0, with permission from dagger. Fix glib single-includes bug in a h... (diff)
downloadgentoo-2-3141567875cc04d64590844689b9db36fb770827.tar.gz
gentoo-2-3141567875cc04d64590844689b9db36fb770827.tar.bz2
gentoo-2-3141567875cc04d64590844689b9db36fb770827.zip
Update per proxy-maintainer request. Remove overshadowed versions.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/ufw/files')
-rw-r--r--net-firewall/ufw/files/ufw-0.30.1-encoding.patch15
-rw-r--r--net-firewall/ufw/files/ufw-0.30.1-python-abis.patch21
2 files changed, 36 insertions, 0 deletions
diff --git a/net-firewall/ufw/files/ufw-0.30.1-encoding.patch b/net-firewall/ufw/files/ufw-0.30.1-encoding.patch
new file mode 100644
index 000000000000..a4626ef0cff0
--- /dev/null
+++ b/net-firewall/ufw/files/ufw-0.30.1-encoding.patch
@@ -0,0 +1,15 @@
+Fixes usage with ufw-frontends.
+upstream bug report: https://bugs.launchpad.net/ufw/+bug/921758
+--- src/util.py
++++ src/util.py
+@@ -205,8 +205,9 @@
+
+ def open_file_read(f):
+ '''Opens the specified file read-only'''
++ import codecs
+ try:
+- orig = open(f, 'r')
++ orig = codecs.open(f, 'r', "UTF-8")
+ except Exception:
+ raise
+
diff --git a/net-firewall/ufw/files/ufw-0.30.1-python-abis.patch b/net-firewall/ufw/files/ufw-0.30.1-python-abis.patch
new file mode 100644
index 000000000000..b924012790e4
--- /dev/null
+++ b/net-firewall/ufw/files/ufw-0.30.1-python-abis.patch
@@ -0,0 +1,21 @@
+This patch fixes strings substitution in common.py during package
+build with ebuild supporting installation for multiple Python versions.
+
+With support for multiple Python versions in the ebuild, seems the
+file isn't copied from staging/ to build-*/lib/ufw/ after being
+modified. That's why the copy needs to be done "manually" here.
+The issue occurs with "setup.py build -b build-XXX" followed by
+"setup.py build -b build-XXX install".
+
+probably related: https://bugs.launchpad.net/ufw/+bug/819600
+--- setup.py
++++ setup.py
+@@ -89,6 +89,8 @@
+ "-i",
+ "s%#SHARE_DIR#%" + real_sharedir + "%g",
+ os.path.join('staging', file)])
++ self.copy_file(os.path.join('staging', file),
++ os.path.join(self.build_base, "lib", "ufw"))
+
+ # Now byte-compile everything
+ super(Install, self).run()