summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2013-12-02 20:00:01 +0000
committerConstanze Hausner <constanze@gentoo.org>2013-12-02 20:00:01 +0000
commit1f3ca39dd4414db2c0104e7016aed5246f5e0d25 (patch)
treed78de0a1db1b2a6a9790ca96d4aeb109af97b4e6 /net-firewall
parentVersion Bump; Thanks to Thomas D. (diff)
downloadgentoo-2-1f3ca39dd4414db2c0104e7016aed5246f5e0d25.tar.gz
gentoo-2-1f3ca39dd4414db2c0104e7016aed5246f5e0d25.tar.bz2
gentoo-2-1f3ca39dd4414db2c0104e7016aed5246f5e0d25.zip
Version Bump; Thanks to Thomas D.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key BB80F419010E3EC3)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall-core/ChangeLog8
-rw-r--r--net-firewall/shorewall-core/files/4.5.21.4/shorewallrc23
-rw-r--r--net-firewall/shorewall-core/shorewall-core-4.5.21.4.ebuild74
3 files changed, 104 insertions, 1 deletions
diff --git a/net-firewall/shorewall-core/ChangeLog b/net-firewall/shorewall-core/ChangeLog
index b0a5405fe375..1c70c336f5f0 100644
--- a/net-firewall/shorewall-core/ChangeLog
+++ b/net-firewall/shorewall-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/ChangeLog,v 1.47 2013/10/26 18:36:13 constanze Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/ChangeLog,v 1.48 2013/12/02 20:00:01 constanze Exp $
+
+*shorewall-core-4.5.21.4 (02 Dec 2013)
+
+ 02 Dec 2013; Constanze Hausner <constanze@gentoo.org>
+ +files/4.5.21.4/shorewallrc, +shorewall-core-4.5.21.4.ebuild:
+ Version Bump; Thanks to Thomas D.
*shorewall-core-4.5.21.2 (26 Oct 2013)
diff --git a/net-firewall/shorewall-core/files/4.5.21.4/shorewallrc b/net-firewall/shorewall-core/files/4.5.21.4/shorewallrc
new file mode 100644
index 000000000000..46f5eb9a3603
--- /dev/null
+++ b/net-firewall/shorewall-core/files/4.5.21.4/shorewallrc
@@ -0,0 +1,23 @@
+#
+# Gentoo Shorewall 4.5 rc file
+#
+BUILD= #Default is to detect the build system
+HOST=gentoo #Gentoo GNU Linux
+PREFIX=@GENTOO_PORTAGE_EPREFIX@/usr #Top-level directory for shared files, libraries, etc.
+SHAREDIR=${PREFIX}/share #Directory for arch-neutral files.
+LIBEXECDIR=${PREFIX}/share #Directory for executable scripts.
+PERLLIBDIR=${PREFIX}/share/shorewall #Directory to install Shorewall Perl module directory
+CONFDIR=@GENTOO_PORTAGE_EPREFIX@/etc #Directory where subsystem configurations are installed
+SBINDIR=@GENTOO_PORTAGE_EPREFIX@/sbin #Directory where system administration programs are installed
+MANDIR=${PREFIX}/share/man #Directory where manpages are installed.
+INITDIR=${CONFDIR}/init.d #Directory where SysV init scripts are installed.
+INITFILE=${PRODUCT} #Name of the product's installed SysV init script
+INITSOURCE=init.gentoo.sh #Name of the distributed file to be installed as the SysV init script
+ANNOTATED= #If non-zero, annotated configuration files are installed
+SYSTEMD=@GENTOO_PORTAGE_EPREFIX@/usr/lib/systemd/system #Directory where .service files are installed (systems running systemd only)
+SERVICEFILE=gentoo.service #Name of the distributed file to be installed as systemd service file
+SYSCONFFILE=default.gentoo #Name of the distributed file to be installed in $SYSCONFDIR
+SYSCONFDIR=${CONFDIR}/conf.d #Directory where SysV init parameter files are installed
+SPARSE= #If non-empty, only install $PRODUCT/$PRODUCT.conf in $CONFDIR
+VARLIB=@GENTOO_PORTAGE_EPREFIX@/var/lib #Directory where product variable data is stored.
+VARDIR=${VARLIB}/${PRODUCT} #Directory where product variable data is stored.
diff --git a/net-firewall/shorewall-core/shorewall-core-4.5.21.4.ebuild b/net-firewall/shorewall-core/shorewall-core-4.5.21.4.ebuild
new file mode 100644
index 000000000000..6d8712599bb9
--- /dev/null
+++ b/net-firewall/shorewall-core/shorewall-core-4.5.21.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/shorewall-core-4.5.21.4.ebuild,v 1.1 2013/12/02 20:00:01 constanze Exp $
+
+EAPI="5"
+
+inherit eutils prefix versionator
+
+MY_URL_PREFIX=
+case ${P} in
+ *_beta* | \
+ *_rc*)
+ MY_URL_PREFIX='development/'
+ ;;
+esac
+
+MY_PV=${PV/_rc/-RC}
+MY_PV=${MY_PV/_beta/-Beta}
+MY_P=${PN}-${MY_PV}
+
+MY_MAJOR_RELEASE_NUMBER=$(get_version_component_range 1-2)
+MY_MAJORMINOR_RELEASE_NUMBER=$(get_version_component_range 1-3)
+
+DESCRIPTION="Core libraries of shorewall / shorewall(6)-lite"
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_URL_PREFIX}${MY_MAJOR_RELEASE_NUMBER}/shorewall-${MY_MAJORMINOR_RELEASE_NUMBER}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="
+ >=dev-lang/perl-5.10
+ virtual/perl-Digest-SHA
+ !<net-firewall/shorewall-4.5.0.1
+ selinux? ( sec-policy/selinux-shorewall )
+"
+RDEPEND="
+ ${DEPEND}
+ >=net-firewall/iptables-1.4.20
+ sys-apps/iproute2[-minimal]
+ sys-devel/bc
+ sys-apps/coreutils
+"
+
+DOCS=( changelog.txt releasenotes.txt )
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ cp "${FILESDIR}"/${PVR}/shorewallrc "${S}"/shorewallrc.gentoo || die "Copying shorewallrc failed"
+ eprefixify "${S}"/shorewallrc.gentoo
+
+ epatch_user
+}
+
+src_configure() {
+ :;
+}
+
+src_install() {
+ DESTDIR="${D}" ./install.sh shorewallrc.gentoo || die "install.sh failed"
+ default
+}
+
+pkg_postinst() {
+ if ! has_version sys-apps/net-tools; then
+ elog "It is recommended to install sys-apps/net-tools which will provide the"
+ elog "the 'arp' utility which will give you a better 'shorewall-lite dump' output:"
+ elog ""
+ elog " # emerge sys-apps/net-tools"
+ fi
+}