summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-08-09 09:58:10 +0000
committerJeroen Roovers <jer@gentoo.org>2014-08-09 09:58:10 +0000
commit9fd10b5ea98550e80e1503093488da924a63b8dc (patch)
tree68f1433727668f9dba578ab57508e673e25d02f3 /net-firewall
parentStable for ppc, wrt bug #519396 (diff)
downloadgentoo-2-9fd10b5ea98550e80e1503093488da924a63b8dc.tar.gz
gentoo-2-9fd10b5ea98550e80e1503093488da924a63b8dc.tar.bz2
gentoo-2-9fd10b5ea98550e80e1503093488da924a63b8dc.zip
Version bump.
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipt_netflow/ChangeLog8
-rw-r--r--net-firewall/ipt_netflow/files/ipt_netflow-2.0-configure.patch10
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-2.0.ebuild69
3 files changed, 86 insertions, 1 deletions
diff --git a/net-firewall/ipt_netflow/ChangeLog b/net-firewall/ipt_netflow/ChangeLog
index c028178e6035..9281212db47d 100644
--- a/net-firewall/ipt_netflow/ChangeLog
+++ b/net-firewall/ipt_netflow/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipt_netflow
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.14 2014/07/18 12:41:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.15 2014/08/09 09:58:09 jer Exp $
+
+*ipt_netflow-2.0 (09 Aug 2014)
+
+ 09 Aug 2014; Jeroen Roovers <jer@gentoo.org> +ipt_netflow-2.0.ebuild,
+ +files/ipt_netflow-2.0-configure.patch:
+ Version bump.
18 Jul 2014; Jeroen Roovers <jer@gentoo.org> -ipt_netflow-1.8-r3.ebuild,
ipt_netflow-1.8-r4.ebuild, files/ipt_netflow-1.8-pax-const.patch,
diff --git a/net-firewall/ipt_netflow/files/ipt_netflow-2.0-configure.patch b/net-firewall/ipt_netflow/files/ipt_netflow-2.0-configure.patch
new file mode 100644
index 000000000000..f6b3a005ba21
--- /dev/null
+++ b/net-firewall/ipt_netflow/files/ipt_netflow-2.0-configure.patch
@@ -0,0 +1,10 @@
+--- a/configure
++++ b/configure
+@@ -421,7 +421,6 @@
+ iptables_find_version #IPTVER
+ iptables_try_pkgconfig #try to configure from pkg-config
+ iptables_find_src #IPTSRC
+-iptables_src_version #check that IPTSRC match to IPTVER
+ iptables_inc #IPTINC
+ iptables_modules #IPTLIB
+
diff --git a/net-firewall/ipt_netflow/ipt_netflow-2.0.ebuild b/net-firewall/ipt_netflow/ipt_netflow-2.0.ebuild
new file mode 100644
index 000000000000..0612b60c6c3c
--- /dev/null
+++ b/net-firewall/ipt_netflow/ipt_netflow-2.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ipt_netflow-2.0.ebuild,v 1.1 2014/08/09 09:58:09 jer Exp $
+
+EAPI=5
+inherit eutils linux-info linux-mod multilib toolchain-funcs
+
+DESCRIPTION="Netflow iptables module"
+HOMEPAGE="http://sourceforge.net/projects/ipt-netflow"
+SRC_URI="mirror://sourceforge/ipt-netflow/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="pax_kernel"
+
+RDEPEND="net-firewall/iptables"
+DEPEND="${RDEPEND}
+ virtual/linux-sources
+ virtual/pkgconfig
+"
+
+# set S before MODULE_NAMES
+S=${WORKDIR}/${PN/_/-}-${PV}
+
+BUILD_TARGETS="all"
+CONFIG_CHECK="~IP_NF_IPTABLES"
+MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
+
+IPT_LIB="/usr/$(get_libdir)/xtables"
+
+src_prepare() {
+ sed -i \
+ -e 's:make -C:$(MAKE) -C:g' \
+ -e 's:gcc -O2:$(CC) $(CFLAGS) $(LDFLAGS):' \
+ -e 's:gcc:$(CC) $(CFLAGS) $(LDFLAGS):' \
+ Makefile.in || die
+
+ # bug #455984
+ epatch "${FILESDIR}"/${PN}-2.0-configure.patch
+
+ epatch_user
+}
+
+src_configure() {
+ local IPT_VERSION="$($(tc-getPKG_CONFIG) --modversion xtables)"
+ # econf can not be used, cause configure script fails when see unknown parameter
+ # ipt-src need to be defined, see bug #455984
+ ./configure \
+ --ipt-lib="${IPT_LIB}" \
+ --ipt-src="/usr/" \
+ --ipt-ver="${IPT_VERSION}" \
+ --kdir="${KV_DIR}" \
+ --kver="${KV_FULL}" \
+ || die 'configure failed'
+}
+
+src_compile() {
+ emake ARCH="$(tc-arch-kernel)" CC="$(tc-getCC)" all
+}
+
+src_install() {
+ linux-mod_src_install
+ exeinto "${IPT_LIB}"
+ doexe libipt_NETFLOW.so
+ doheader ipt_NETFLOW.h
+ dodoc README*
+}