summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2009-04-27 09:04:28 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2009-04-27 09:04:28 +0000
commitbae654882aa31abf19e993187e434be492190c97 (patch)
treec43847e3b0405207eb1601e972d31781100c9b74 /net-fs/autofs
parentBump (diff)
downloadgentoo-2-bae654882aa31abf19e993187e434be492190c97.tar.gz
gentoo-2-bae654882aa31abf19e993187e434be492190c97.tar.bz2
gentoo-2-bae654882aa31abf19e993187e434be492190c97.zip
Update patch set, probably fixing bugs #253806 and #255369
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/autofs')
-rw-r--r--net-fs/autofs/ChangeLog9
-rw-r--r--net-fs/autofs/autofs-5.0.4-r3.ebuild123
-rw-r--r--net-fs/autofs/files/autofs-5.0.4-user-ldflags-and-as-needed-v2.patch59
3 files changed, 190 insertions, 1 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index d2c3eb2e2894..23d78183c485 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/autofs
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.83 2009/04/08 13:14:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.84 2009/04/27 09:04:27 stefaan Exp $
+
+*autofs-5.0.4-r3 (27 Apr 2009)
+
+ 27 Apr 2009; Stefaan De Roeck <stefaan@gentoo.org>
+ +files/autofs-5.0.4-user-ldflags-and-as-needed-v2.patch,
+ +autofs-5.0.4-r3.ebuild:
+ Update patch set, probably fixing bugs #253806 and #255369
08 Apr 2009; Raúl Porcel <armin76@gentoo.org> autofs-5.0.3-r6.ebuild:
arm/ia64/sparc stable wrt #257097
diff --git a/net-fs/autofs/autofs-5.0.4-r3.ebuild b/net-fs/autofs/autofs-5.0.4-r3.ebuild
new file mode 100644
index 000000000000..a4995ffee702
--- /dev/null
+++ b/net-fs/autofs/autofs-5.0.4-r3.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.4-r3.ebuild,v 1.1 2009/04/27 09:04:27 stefaan Exp $
+
+inherit eutils multilib autotools
+
+IUSE="ldap sasl"
+DESCRIPTION="Kernel based automounter"
+HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
+SRC_URI_BASE="mirror://kernel/linux/daemons/${PN}/v5"
+# This list is taken directly from http://kernel.org/pub/linux/daemons/autofs/v5/patch_order-5.0.3
+# Please do not modify the order
+PATCH_LIST="
+ ${P}-fix-dumb-libxml2-check.patch
+ ${P}-expire-specific-submount-only.patch
+ ${P}-fix-negative-cache-non-existent-key.patch
+ ${P}-fix-ldap-detection.patch
+ ${P}-use-CLOEXEC-flag.patch
+ ${P}-fix-select-fd-limit.patch
+ ${P}-make-hash-table-scale-to-thousands-of-entries.patch
+ ${P}-fix-quoted-mess.patch
+ ${P}-use-CLOEXEC-flag-setmntent.patch
+ ${P}-fix-hosts-map-use-after-free.patch
+ ${P}-uris-list-locking-fix.patch
+ ${P}-renew-sasl-creds-upon-reconnect-fail.patch
+ ${P}-library-reload-fix-update.patch
+ ${P}-force-unlink-umount.patch
+ ${P}-always-read-file-maps.patch
+ ${P}-code-analysis-corrections.patch
+ ${P}-make-MAX_ERR_BUF-and-PARSE_MAX_BUF-use-easier-to-audit.patch
+ ${P}-easy-alloca-replacements.patch
+ ${P}-configure-libtirpc.patch
+ ${P}-ipv6-name-and-address-support.patch
+ ${P}-ipv6-parse.patch
+ ${P}-add-missing-changelog-entries.patch
+ ${P}-use-CLOEXEC-flag-setmntent-include-fix.patch
+ ${P}-easy-alloca-replacements-fix.patch
+ ${P}-libxml2-workaround-fix.patch
+ ${P}-configure-libtirpc-fix.patch
+ ${P}-add-nfs-mount-proto-default-conf-option.patch
+ ${P}-fix-bad-token-declare.patch
+ ${P}-fix-return-start-status-on-fail.patch
+ ${P}-fix-double-free-in-expire_proc.patch
+ ${P}-another-easy-alloca-replacements-fix.patch
+ ${P}-add-lsb-init-script-parameter-block.patch
+ ${P}-always-read-file-maps-fix.patch
+ ${P}-use-misc-device.patch
+ ${P}-fix-restorecon.patch
+ ${P}-clear-rpc-client-on-lookup-fail.patch
+ ${P}-fix-lsb-init-script-header.patch
+ ${P}-fix-memory-leak-reading-ldap-master.patch
+ ${P}-fix-st_remove_tasks-locking.patch
+ ${P}-reset-flex-scanner-when-setting-buffer.patch
+ ${P}-zero-s_magic-is-valid.patch
+ ${P}-use-percent-hack-for-master.patch
+ ${P}-use-intr-as-hosts-mount-default.patch
+ ${P}-fix-kernel-includes.patch
+ ${P}-dont-umount-existing-direct-mount-on-reread.patch"
+SRC_URI="${SRC_URI_BASE}/${P}.tar.bz2"
+for i in ${PATCH_LIST} ; do
+ SRC_URI="${SRC_URI} ${SRC_URI_BASE}/${i}"
+done ;
+DEPEND="virtual/libc
+ ldap? ( >=net-nds/openldap-2.0 )
+ sasl? ( virtual/krb5 )"
+ # currently, sasl code assumes the presence of kerberosV
+RDEPEND="${DEPEND}"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ for i in ${PATCH_LIST}; do
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${DISTDIR}"/${i}
+ done
+
+ cd "${S}"
+
+ # fixes bug #210762
+ epatch "${FILESDIR}"/${PN}-5.0.3-heimdal.patch
+
+ # fixes bugs #253412 and #247969
+ epatch "${FILESDIR}"/${P}-user-ldflags-and-as-needed-v2.patch
+
+ # # use CC and CFLAGS from environment (bug #154797)
+ # write these values in Makefile.conf
+ (echo "# Use the compiler and cflags determined by configure";
+ echo "CC := @CC@"; echo "CFLAGS := @CFLAGS@") >> Makefile.conf.in
+ # make sure Makefile.conf is parsed after Makefile.rules
+ sed -ni '/include Makefile.conf/{x; n; G}; p' Makefile
+ sed -i 's/^\(CC\|CXX\).*//' Makefile.rules
+ sed -i 's/^CFLAGS=-fPIE.*//' configure.in
+
+ # do not include <nfs/nfs.h>, rather <linux/nfs.h>,
+ # as the former is a lame header for the latter (bug #157968)
+ sed -i 's@nfs/nfs.h@linux/nfs.h@' include/rpc_subs.h
+
+ eautoreconf || die "Autoconf failed"
+}
+
+src_compile() {
+ CFLAGS="${CFLAGS}" \
+ econf \
+ $(use_with ldap openldap) \
+ $(use_with sasl) \
+ --enable-ignore-busy \
+ || die "configure failed"
+
+ emake DONTSTRIP=1 || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ newinitd "${FILESDIR}"/autofs5.rc1 autofs
+}
+
+pkg_postinst() {
+ elog "Note: If you plan on using autofs for automounting"
+ elog "remote NFS mounts without having the NFS daemon running"
+ elog "please add portmap to your default run-level."
+}
diff --git a/net-fs/autofs/files/autofs-5.0.4-user-ldflags-and-as-needed-v2.patch b/net-fs/autofs/files/autofs-5.0.4-user-ldflags-and-as-needed-v2.patch
new file mode 100644
index 000000000000..931ebf494878
--- /dev/null
+++ b/net-fs/autofs/files/autofs-5.0.4-user-ldflags-and-as-needed-v2.patch
@@ -0,0 +1,59 @@
+diff -ur autofs-5.0.4-old/Makefile.rules autofs-5.0.4/Makefile.rules
+--- autofs-5.0.4-old/Makefile.rules 2009-04-27 10:54:19.000000000 +0200
++++ autofs-5.0.4/Makefile.rules 2009-04-27 10:55:55.000000000 +0200
+@@ -24,16 +24,16 @@
+
+ ifdef DEBUG
+ CFLAGS ?= -g -Wall -DDEBUG
+-LDFLAGS = -g
++AUTOFS_LDFLAGS = -g
+ STRIP = :
+ else
+ ifdef DONTSTRIP
+ CFLAGS ?= -O2 -g
+-LDFLAGS = -g
++AUTOFS_LDFLAGS = -g
+ STRIP = :
+ else
+ CFLAGS ?= -O2 -Wall
+-LDFLAGS = -s
++AUTOFS_LDFLAGS = -s
+ STRIP = strip --strip-debug
+ endif
+ endif
+@@ -45,15 +45,14 @@
+ SOLDFLAGS = -shared
+
+ CFLAGS += -D_REENTRANT -D_FILE_OFFSET_BITS=64
+-LDFLAGS += -lpthread
+
+ ifdef TIRPCLIB
+ CFLAGS += -I/usr/include/tirpc
+-LDFLAGS += $(TIRPCLIB)
++AUTOFS_LDFLAGS += $(TIRPCLIB)
+ endif
+
+ ifdef DMALLOCLIB
+-LDFLAGS += $(DMALLOCLIB)
++AUTOFS_LDFLAGS += $(DMALLOCLIB)
+ endif
+
+ # Standard rules
+diff -ur autofs-5.0.4-old/daemon/Makefile autofs-5.0.4/daemon/Makefile
+--- autofs-5.0.4-old/daemon/Makefile 2009-04-27 10:54:19.000000000 +0200
++++ autofs-5.0.4/daemon/Makefile 2009-04-27 10:54:37.000000000 +0200
+@@ -20,12 +20,12 @@
+ CFLAGS += -DAUTOFS_FLAG_DIR=\"$(autofsflagdir)\"
+ CFLAGS += -DVERSION_STRING=\"$(version)\"
+ LDFLAGS += -rdynamic
+-LIBS = -ldl
++LIBS = -ldl -lpthread
+
+ all: automount
+
+ automount: $(OBJS) $(AUTOFS_LIB)
+- $(CC) $(LDFLAGS) $(DAEMON_LDFLAGS) -o automount $(OBJS) $(AUTOFS_LIB) $(LIBS)
++ $(CC) $(AUTOFS_LDFLAGS) $(DAEMON_LDFLAGS) $(LDFLAGS) -o automount $(OBJS) $(AUTOFS_LIB) $(LIBS)
+ $(STRIP) automount
+
+ clean: