summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-12-29 03:56:07 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-12-29 03:56:07 +0000
commit8312c6cbed4c682577c6e752ff95c40d61c23c5d (patch)
tree06b28d703756193ad122deffc0950e1fbaefe32d /net-fs/fex
parentFixed missing games_pkg_setup. (diff)
downloadgentoo-2-8312c6cbed4c682577c6e752ff95c40d61c23c5d.tar.gz
gentoo-2-8312c6cbed4c682577c6e752ff95c40d61c23c5d.tar.bz2
gentoo-2-8312c6cbed4c682577c6e752ff95c40d61c23c5d.zip
Revision bump.
- fix building with GCC 4 (bug #182009) - fix building against log4cpp-1.0 by linking with -lpthread - added debug USE flag - respect user CFLAGS - ebuild cleanup (Portage version: 2.1.4_rc11)
Diffstat (limited to 'net-fs/fex')
-rw-r--r--net-fs/fex/ChangeLog14
-rw-r--r--net-fs/fex/fex-0.8.18-r1.ebuild (renamed from net-fs/fex/fex-0.8.18.ebuild)26
-rw-r--r--net-fs/fex/files/digest-fex-0.8.18-r1 (renamed from net-fs/fex/files/digest-fex-0.8.18)0
-rw-r--r--net-fs/fex/files/fex-0.8.18-gcc4.patch99
-rw-r--r--net-fs/fex/files/fex-0.8.18-lpthread.patch34
5 files changed, 166 insertions, 7 deletions
diff --git a/net-fs/fex/ChangeLog b/net-fs/fex/ChangeLog
index fcc18502dec2..ae8103f67547 100644
--- a/net-fs/fex/ChangeLog
+++ b/net-fs/fex/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-fs/fex
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/fex/ChangeLog,v 1.4 2007/05/11 01:14:32 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/fex/ChangeLog,v 1.5 2007/12/29 03:56:06 dirtyepic Exp $
+
+*fex-0.8.18-r1 (29 Dec 2007)
+
+ 29 Dec 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/fex-0.8.18-configure.patch, +files/fex-0.8.18-gcc4.patch,
+ -fex-0.8.18.ebuild, +fex-0.8.18-r1.ebuild:
+ Revision bump.
+ - fix building with GCC 4 (bug #182009)
+ - fix building against log4cpp-1.0 by linking with -lpthread
+ - added debug USE flag
+ - respect user CFLAGS
+ - ebuild cleanup
11 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
fix spelling of herd in metadata
diff --git a/net-fs/fex/fex-0.8.18.ebuild b/net-fs/fex/fex-0.8.18-r1.ebuild
index 11a455d60ad4..7e4345e56b73 100644
--- a/net-fs/fex/fex-0.8.18.ebuild
+++ b/net-fs/fex/fex-0.8.18-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/fex/fex-0.8.18.ebuild,v 1.2 2007/05/06 10:15:50 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/fex/fex-0.8.18-r1.ebuild,v 1.1 2007/12/29 03:56:06 dirtyepic Exp $
+
+inherit eutils autotools
DESCRIPTION="Fex is a replicating filesystem for disconnected computers similar to intermezzo"
HOMEPAGE="http://www.zahlfee.de/fex/fex.html"
@@ -9,7 +11,7 @@ SRC_URI="http://www.zahlfee.de/fex/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
+IUSE="debug"
DEPEND="dev-libs/confuse
dev-libs/log4cpp
@@ -17,16 +19,28 @@ DEPEND="dev-libs/confuse
dev-libs/popt
"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-lpthread.patch
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+
+ eautoreconf
+}
+
src_compile() {
- econf || die "econf failed"
+ econf \
+ $(use_enable debug) || die "econf failed"
+
emake || die "emake failed"
}
src_install() {
- einstall || die "install problem"
+ emake DESTDIR="${D}" install || die "emake install failed"
- newinitd ${FILESDIR}/${PN}.rc ${PN}d || die
- newconfd ${FILESDIR}/${PN}.conf.d ${PN}d || die
+ newinitd "${FILESDIR}"/${PN}.rc ${PN}d || die
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}d || die
}
pkg_postinst() {
diff --git a/net-fs/fex/files/digest-fex-0.8.18 b/net-fs/fex/files/digest-fex-0.8.18-r1
index 9e02e72f4ddd..9e02e72f4ddd 100644
--- a/net-fs/fex/files/digest-fex-0.8.18
+++ b/net-fs/fex/files/digest-fex-0.8.18-r1
diff --git a/net-fs/fex/files/fex-0.8.18-gcc4.patch b/net-fs/fex/files/fex-0.8.18-gcc4.patch
new file mode 100644
index 000000000000..00147faaea6f
--- /dev/null
+++ b/net-fs/fex/files/fex-0.8.18-gcc4.patch
@@ -0,0 +1,99 @@
+diff -Naur fex-0.8.18-orig/src/client.cpp fex-0.8.18/src/client.cpp
+--- fex-0.8.18-orig/src/client.cpp 2004-12-19 17:49:45.000000000 -0600
++++ fex-0.8.18/src/client.cpp 2007-12-28 21:03:30.000000000 -0600
+@@ -53,7 +53,7 @@
+ {
+ lc.info("start fullsync");
+ parent().write(fex_header(ME_FullSyncStart));
+- parent().wp()->createStateFile((unsigned)this, &_M_ClientFile);
++ parent().wp()->createStateFile((unsigned long)this, &_M_ClientFile);
+ }
+
+ void FullSyncDialog::
+diff -Naur fex-0.8.18-orig/src/dialog.cpp fex-0.8.18/src/dialog.cpp
+--- fex-0.8.18-orig/src/dialog.cpp 2005-05-11 10:20:52.000000000 -0600
++++ fex-0.8.18/src/dialog.cpp 2007-12-28 21:03:58.000000000 -0600
+@@ -224,7 +224,7 @@
+ ModLog::iterator i;
+ for(i = _M_Log.begin(); i != _M_Log.end(); i++) {
+ if (! FileListener::get().lock(parent().wp()->path() + i->first.str(),
+- (unsigned int)&parent())) {
++ (unsigned long)&parent())) {
+ ModLog::iterator j;
+ for(j = _M_Log.begin(); j != i; j++) {
+ FileListener::get().unlock(parent().wp(),
+diff -Naur fex-0.8.18-orig/src/filelistener.cpp fex-0.8.18/src/filelistener.cpp
+--- fex-0.8.18-orig/src/filelistener.cpp 2005-06-07 09:49:06.000000000 -0600
++++ fex-0.8.18/src/filelistener.cpp 2007-12-28 21:04:42.000000000 -0600
+@@ -355,7 +355,7 @@
+
+ _M_FDBuffer[0].reserve(MinFDBufferSize);
+ _M_FDBuffer[1].reserve(MinFDBufferSize);
+- _S_SignalBuffer = (int)&_M_FDBuffer[0];
++ _S_SignalBuffer = (long)&_M_FDBuffer[0];
+ _M_ReadBuffer = &_M_FDBuffer[1];
+
+ assert(! _S_WakeUpPipe.first);
+@@ -439,7 +439,7 @@
+ typedef FileListener::FileEvent::reqs_m::iterator iterator;
+
+ _M_ReadBuffer->reserve(_M_Handler->size() + MinFDBufferSize);
+- _S_SignalBuffer = (int)_M_ReadBuffer;
++ _S_SignalBuffer = (long)_M_ReadBuffer;
+ _M_ReadBuffer = &_M_FDBuffer[_M_ReadBuffer == &_M_FDBuffer[0] ? 1 : 0];
+
+ if (_S_RenewAll) {
+diff -Naur fex-0.8.18-orig/src/nmstl/netioevent fex-0.8.18/src/nmstl/netioevent
+--- fex-0.8.18-orig/src/nmstl/netioevent 2004-12-12 16:34:50.000000000 -0600
++++ fex-0.8.18/src/nmstl/netioevent 2007-12-28 21:05:51.000000000 -0600
+@@ -138,7 +138,7 @@
+ io_handler::set_ioh;
+
+ private:
+- inline void tcp_acceptor::ravail() {
++ inline void ravail() {
+ address a;
+ tcpsocket ioh = sock.accept(a);
+ if (ioh) {
+@@ -168,7 +168,7 @@
+ virtual ~tcp_acceptor() {}
+
+ protected:
+- inline void tcp_acceptor::ravail() {
++ inline void ravail() {
+ address a;
+ tcpsocket ioh = sock.accept(a);
+ if (ioh) {
+diff -Naur fex-0.8.18-orig/src/server.cpp fex-0.8.18/src/server.cpp
+--- fex-0.8.18-orig/src/server.cpp 2004-12-19 17:51:23.000000000 -0600
++++ fex-0.8.18/src/server.cpp 2007-12-28 21:06:27.000000000 -0600
+@@ -81,7 +81,7 @@
+ sendStatFile()
+ {
+ size_t size;
+- size = parent().wp()->createStateFile((unsigned)this, &_M_StateFile);
++ size = parent().wp()->createStateFile((unsigned long)this, &_M_StateFile);
+ omessage msg;
+ msg << _M_StateFile << size;
+ write(fex_header(ME_FullSyncState), msg);
+diff -Naur fex-0.8.18-orig/src/watchpoint.cpp fex-0.8.18/src/watchpoint.cpp
+--- fex-0.8.18-orig/src/watchpoint.cpp 2004-12-27 08:40:40.000000000 -0600
++++ fex-0.8.18/src/watchpoint.cpp 2007-12-28 21:07:31.000000000 -0600
+@@ -188,7 +188,7 @@
+ unsigned int lock_id,
+ bool do_sync)
+ {
+- if (lock_id == (unsigned int)this)
++ if (lock_id == (unsigned long)this)
+ return;
+
+ pair<ModLog::iterator, bool> res = _M_WriteLog->insert(key, state);
+@@ -327,7 +327,7 @@
+ save_state()
+ {
+ if (_M_Mode >= MO_fullsynched)
+- wp()->createStateFile((unsigned)this, NULL);
++ wp()->createStateFile((unsigned long)this, NULL);
+ }
+
+
diff --git a/net-fs/fex/files/fex-0.8.18-lpthread.patch b/net-fs/fex/files/fex-0.8.18-lpthread.patch
new file mode 100644
index 000000000000..0539fa9b9a8e
--- /dev/null
+++ b/net-fs/fex/files/fex-0.8.18-lpthread.patch
@@ -0,0 +1,34 @@
+diff -Naur fex-0.8.18-orig/configure.ac fex-0.8.18/configure.ac
+--- fex-0.8.18-orig/configure.ac 2005-06-07 12:31:43.000000000 -0600
++++ fex-0.8.18/configure.ac 2007-12-28 21:49:27.000000000 -0600
+@@ -21,9 +21,9 @@
+ [AS_HELP_STRING([--enable-debug], [build a debug version])])
+
+ if test "$enable_debug" = "yes"; then
+- CXXFLAGS="${CXXFLAGS} -O0 -g3";
++ CXXFLAGS="${CXXFLAGS}";
+ else
+- CXXFLAGS="-O2 -DNDEBUG ${CXXFLAGS}";
++ CXXFLAGS="-DNDEBUG ${CXXFLAGS}";
+ fi
+
+ AC_ARG_ENABLE([slink],
+@@ -68,6 +68,8 @@
+ AC_CHECK_HEADERS([ext/malloc_allocator.h])
+ AC_CHECK_HEADERS([linux/inotify.h])
+
++FEX_LINK="${FEX_LINK} -lpthread"
++
+ AC_CHECK_LIB([rsync],
+ [rs_delta_file],
+ [],
+@@ -89,7 +91,8 @@
+ AC_CHECK_LIB([log4cpp],
+ [main],
+ [],
+- [AC_MSG_ERROR([liblog4cpp must be installed])])
++ [AC_MSG_ERROR([liblog4cpp must be installed])],
++ [-lpthread])
+
+ AC_HEADER_STDC
+ AC_HEADER_DIRENT