summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-06-02 19:03:30 +0000
committerMike Frysinger <vapier@gentoo.org>2009-06-02 19:03:30 +0000
commitafda89fa0dc2e7904d9261658d9f7c6fa85b5c46 (patch)
tree39806fab61b021e969080c042cfbac0d39ba4b0b /net-fs/nfs-utils
parentRemove HPPA keywording from 4.3 ebuilds (see bug #225917 and bug #264121). (diff)
downloadgentoo-2-afda89fa0dc2e7904d9261658d9f7c6fa85b5c46.tar.gz
gentoo-2-afda89fa0dc2e7904d9261658d9f7c6fa85b5c46.tar.bz2
gentoo-2-afda89fa0dc2e7904d9261658d9f7c6fa85b5c46.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/nfs-utils')
-rw-r--r--net-fs/nfs-utils/ChangeLog7
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.2.0.ebuild110
2 files changed, 116 insertions, 1 deletions
diff --git a/net-fs/nfs-utils/ChangeLog b/net-fs/nfs-utils/ChangeLog
index 9aeba17da75b..9b79c0b62dfc 100644
--- a/net-fs/nfs-utils/ChangeLog
+++ b/net-fs/nfs-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/nfs-utils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.158 2009/05/30 22:01:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.159 2009/06/02 19:03:30 vapier Exp $
+
+*nfs-utils-1.2.0 (02 Jun 2009)
+
+ 02 Jun 2009; Mike Frysinger <vapier@gentoo.org> +nfs-utils-1.2.0.ebuild:
+ Version bump.
30 May 2009; Mike Frysinger <vapier@gentoo.org> nfs-utils-1.1.6-r1.ebuild,
files/nfs.confd, files/nfs.initd:
diff --git a/net-fs/nfs-utils/nfs-utils-1.2.0.ebuild b/net-fs/nfs-utils/nfs-utils-1.2.0.ebuild
new file mode 100644
index 000000000000..0acb4c5f0e79
--- /dev/null
+++ b/net-fs/nfs-utils/nfs-utils-1.2.0.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.2.0.ebuild,v 1.1 2009/06/02 19:03:30 vapier Exp $
+
+EAPI="1"
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="NFS client and server daemons"
+HOMEPAGE="http://linux-nfs.org/"
+SRC_URI="mirror://sourceforge/nfs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6 kerberos +nfsv3 +nfsv4 tcpd"
+
+# kth-krb doesn't provide the right include
+# files, and nfs-utils doesn't build against heimdal either,
+# so don't depend on virtual/krb.
+# (04 Feb 2005 agriffis)
+RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ sys-libs/e2fsprogs-libs
+ !net-nds/portmap
+ net-nds/rpcbind
+ net-libs/libtirpc
+ nfsv4? (
+ >=dev-libs/libevent-1.0b
+ >=net-libs/libnfsidmap-0.21-r1
+ kerberos? (
+ net-libs/librpcsecgss
+ net-libs/libgssglue
+ app-crypt/mit-krb5
+ )
+ )"
+# util-linux dep is to prevent man-page collision
+DEPEND="${RDEPEND}
+ >=sys-apps/util-linux-2.12r-r7"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.1.4-ascii-man.patch
+ epatch "${FILESDIR}"/${PN}-1.1.4-mtab-sym.patch
+ epatch "${FILESDIR}"/${PN}-1.1.4-no-exec.patch
+}
+
+src_compile() {
+ econf \
+ --with-statedir=/var/lib/nfs \
+ --enable-tirpc \
+ $(use_with tcpd tcp-wrappers) \
+ $(use_enable nfsv3) \
+ $(use_enable nfsv4) \
+ $(use_enable ipv6) \
+ $(use nfsv4 && use_enable kerberos gss || echo "--disable-gss")
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # Don't overwrite existing xtab/etab, install the original
+ # versions somewhere safe... more info in pkg_postinst
+ dodir /usr/lib/nfs
+ keepdir /var/lib/nfs/{sm,sm.bak}
+ mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
+ keepdir /var/lib/nfs
+
+ # Install some client-side binaries in /sbin
+ dodir /sbin
+ mv "${D}"/usr/sbin/rpc.statd "${D}"/sbin/ || die
+
+ dodoc ChangeLog README
+ docinto linux-nfs ; dodoc linux-nfs/*
+
+ insinto /etc
+ doins "${FILESDIR}"/exports
+
+ local f list="" opt_need=""
+ if use nfsv4 ; then
+ opt_need="rpc.idmapd"
+ list="${list} rpc.idmapd rpc.pipefs"
+ use kerberos && list="${list} rpc.gssd rpc.svcgssd"
+ fi
+ for f in nfs nfsmount rpc.statd ${list} ; do
+ newinitd "${FILESDIR}"/${f}.initd ${f} || die "doinitd ${f}"
+ done
+ newconfd "${FILESDIR}"/nfs.confd nfs
+ dosed "/^NFS_NEEDED_SERVICES=/s:=.*:=\"${opt_need}\":" /etc/conf.d/nfs #234132
+
+ # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
+ if ! use elibc_glibc ; then
+ dobin tools/rpcgen/rpcgen || die "rpcgen"
+ newdoc tools/rpcgen/README README.rpcgen
+ fi
+}
+
+pkg_postinst() {
+ # Install default xtab and friends if there's none existing.
+ # In src_install we put them in /usr/lib/nfs for safe-keeping, but
+ # the daemons actually use the files in /var/lib/nfs. This fixes
+ # bug 30486
+ local f
+ for f in "${ROOT}"/usr/$(get_libdir)/nfs/*; do
+ [[ -e ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
+ einfo "Copying default ${f##*/} from /usr/$(get_libdir)/nfs to /var/lib/nfs"
+ cp -pPR "${f}" "${ROOT}"/var/lib/nfs/
+ done
+}