summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-09-09 16:54:17 +0000
committerJeroen Roovers <jer@gentoo.org>2014-09-09 16:54:17 +0000
commit6d1c87ed173e24478907a273cea1b72f519d103c (patch)
treea98dfa8f7f68a6425066725bd642d73c13a92535 /net-fs
parentOld. (diff)
downloadgentoo-2-6d1c87ed173e24478907a273cea1b72f519d103c.tar.gz
gentoo-2-6d1c87ed173e24478907a273cea1b72f519d103c.tar.bz2
gentoo-2-6d1c87ed173e24478907a273cea1b72f519d103c.zip
function_entry -> zend_function_entry (bug #522444).
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/ncpfs/ChangeLog6
-rw-r--r--net-fs/ncpfs/files/ncpfs-2.2.6-zend_function_entry.patch11
-rw-r--r--net-fs/ncpfs/ncpfs-2.2.6-r3.ebuild8
3 files changed, 21 insertions, 4 deletions
diff --git a/net-fs/ncpfs/ChangeLog b/net-fs/ncpfs/ChangeLog
index b307fd835782..316ee166d913 100644
--- a/net-fs/ncpfs/ChangeLog
+++ b/net-fs/ncpfs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-fs/ncpfs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ChangeLog,v 1.34 2014/08/13 07:01:46 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ChangeLog,v 1.35 2014/09/09 16:54:17 jer Exp $
+
+ 09 Sep 2014; Jeroen Roovers <jer@gentoo.org> ncpfs-2.2.6-r3.ebuild,
+ +files/ncpfs-2.2.6-zend_function_entry.patch:
+ function_entry -> zend_function_entry (bug #522444).
13 Aug 2014; Joshua Kinard <kumba@gentoo.org> ncpfs-2.2.6-r3.ebuild,
-files/ncpfs-2.2.6-cve-2011-1679-1680.patch,
diff --git a/net-fs/ncpfs/files/ncpfs-2.2.6-zend_function_entry.patch b/net-fs/ncpfs/files/ncpfs-2.2.6-zend_function_entry.patch
new file mode 100644
index 000000000000..648cb8f7f770
--- /dev/null
+++ b/net-fs/ncpfs/files/ncpfs-2.2.6-zend_function_entry.patch
@@ -0,0 +1,11 @@
+--- a/contrib/php/php_auth_nds.c
++++ b/contrib/php/php_auth_nds.c
+@@ -1102,7 +1102,7 @@
+ php_info_print_table_end();
+ }
+
+-function_entry auth_nds_functions[] = {
++zend_function_entry auth_nds_functions[] = {
+ PHP_FE(auth_bindery, NULL)
+ PHP_FE(auth_nds, NULL)
+ PHP_FE(auth_tree, NULL)
diff --git a/net-fs/ncpfs/ncpfs-2.2.6-r3.ebuild b/net-fs/ncpfs/ncpfs-2.2.6-r3.ebuild
index 8404435696a5..8a210374e3ad 100644
--- a/net-fs/ncpfs/ncpfs-2.2.6-r3.ebuild
+++ b/net-fs/ncpfs/ncpfs-2.2.6-r3.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ncpfs-2.2.6-r3.ebuild,v 1.2 2014/08/13 07:01:46 kumba Exp $
-
-EAPI="5"
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ncpfs-2.2.6-r3.ebuild,v 1.3 2014/09/09 16:54:17 jer Exp $
+EAPI=5
inherit eutils pam
DESCRIPTION="Provides Access to Netware services using the NCP protocol"
@@ -60,6 +59,9 @@ src_prepare() {
# Bug 446696. This might need re-diffing if additional Makefile
# fixes are added.
epatch "${FILESDIR}"/${P}-makefile-fix-soname-link.patch
+
+ # bug 522444
+ epatch "${FILESDIR}"/${P}-zend_function_entry.patch
}
src_configure() {