summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2006-05-15 09:03:12 +0000
committerChristian Andreetta <satya@gentoo.org>2006-05-15 09:03:12 +0000
commit716e3215cdd02a0ff29ad418c159aadf0b8f3e9d (patch)
treee025b14a0939f0e18e1a04df0178f0ac874e45db /net-fs
parentversion bump (diff)
downloadgentoo-2-716e3215cdd02a0ff29ad418c159aadf0b8f3e9d.tar.gz
gentoo-2-716e3215cdd02a0ff29ad418c159aadf0b8f3e9d.tar.bz2
gentoo-2-716e3215cdd02a0ff29ad418c159aadf0b8f3e9d.zip
support for cups 1.2 libs location (bug #133133), removed msdfs use flag (included by default: bug #127839)
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog7
-rw-r--r--net-fs/samba/samba-3.0.22-r1.ebuild11
-rw-r--r--net-fs/samba/samba-3.0.22-r2.ebuild11
3 files changed, 16 insertions, 13 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index af58c193cb9c..b77a77fd6d9f 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.238 2006/04/28 23:10:49 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.239 2006/05/15 09:03:12 satya Exp $
+
+ 15 May 2006; Christian Andreetta <satya@gentoo.org>
+ samba-3.0.22-r1.ebuild, samba-3.0.22-r2.ebuild:
+ support for cups 1.2 libs location (bug #133133), removed msdfs use flag
+ (included by default: bug #127839)
28 Apr 2006; Jason Wever <weeve@gentoo.org> samba-3.0.22.ebuild:
Stable on SPARC wrt bug #124632.
diff --git a/net-fs/samba/samba-3.0.22-r1.ebuild b/net-fs/samba/samba-3.0.22-r1.ebuild
index b398f373a035..4c41941c674b 100644
--- a/net-fs/samba/samba-3.0.22-r1.ebuild
+++ b/net-fs/samba/samba-3.0.22-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.22-r1.ebuild,v 1.1 2006/04/27 12:36:49 satya Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.22-r1.ebuild,v 1.2 2006/05/15 09:03:12 satya Exp $
inherit eutils versionator
IUSE_LINGUAS="ja pl"
IUSE="acl async automount cups doc examples kerberos ldap ldapsam libclamav
- msdfs mysql oav pam postgres python quotas readline selinux swat syslog
+ mysql oav pam postgres python quotas readline selinux swat syslog
winbind xml xml2"
RESTRICT="test"
@@ -121,7 +121,6 @@ src_compile() {
$(use_with automount) \
$(use_enable cups) \
$(use_with kerberos krb5) \
- $(use_with msdfs) \
$(use_with pam) $(use_with pam pam_smbpass) \
$(use_with python) \
$(use_with quotas) $(use_with quotas sys-quotas) \
@@ -196,10 +195,10 @@ src_install() {
dosym samba/libsmbclient.so /usr/$(get_libdir)/libsmbclient.so.0
dosym samba/libsmbclient.so /usr/$(get_libdir)/libsmbclient.so
- # make the smb backend symlink for cups printing support..
+ # make the smb backend symlink for cups printing support (bug #133133)
if use cups; then
- dodir /usr/$(get_libdir)/cups/backend
- dosym ../../../bin/smbspool /usr/$(get_libdir)/cups/backend/smb
+ dodir $(cups-config --serverbin)/backend
+ dosym /usr/bin/smbspool $(cups-config --serverbin)/backend/smb
fi
# VFS plugin modules
diff --git a/net-fs/samba/samba-3.0.22-r2.ebuild b/net-fs/samba/samba-3.0.22-r2.ebuild
index b0e4e405e90d..5be648ff96b1 100644
--- a/net-fs/samba/samba-3.0.22-r2.ebuild
+++ b/net-fs/samba/samba-3.0.22-r2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.22-r2.ebuild,v 1.1 2006/04/27 17:06:36 satya Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.22-r2.ebuild,v 1.2 2006/05/15 09:03:12 satya Exp $
inherit eutils versionator
IUSE_LINGUAS="ja pl"
IUSE="acl async automount cups doc examples kerberos ldap ldapsam libclamav
- msdfs mysql oav pam postgres python quotas readline selinux swat syslog
+ mysql oav pam postgres python quotas readline selinux swat syslog
winbind xml xml2"
RESTRICT="test"
@@ -121,7 +121,6 @@ src_compile() {
$(use_with automount) \
$(use_enable cups) \
$(use_with kerberos krb5) \
- $(use_with msdfs) \
$(use_with pam) $(use_with pam pam_smbpass) \
$(use_with python) \
$(use_with quotas) $(use_with quotas sys-quotas) \
@@ -196,10 +195,10 @@ src_install() {
dosym samba/libsmbclient.so /usr/$(get_libdir)/libsmbclient.so.0
dosym samba/libsmbclient.so /usr/$(get_libdir)/libsmbclient.so
- # make the smb backend symlink for cups printing support..
+ # make the smb backend symlink for cups printing support (bug #133133)
if use cups; then
- dodir /usr/$(get_libdir)/cups/backend
- dosym ../../../bin/smbspool /usr/$(get_libdir)/cups/backend/smb
+ dodir $(cups-config --serverbin)/backend
+ dosym /usr/bin/smbspool $(cups-config --serverbin)/backend/smb
fi
# VFS plugin modules