summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-09-13 14:08:59 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-09-13 14:08:59 +0000
commitc6aa254fa62a713aa7731a86d31496ecd4ac826b (patch)
tree3225f0524f5c2755164503a118dfc262d39f9283 /net-fs
parentVersion bump. Removed old (diff)
downloadgentoo-2-c6aa254fa62a713aa7731a86d31496ecd4ac826b.tar.gz
gentoo-2-c6aa254fa62a713aa7731a86d31496ecd4ac826b.tar.bz2
gentoo-2-c6aa254fa62a713aa7731a86d31496ecd4ac826b.zip
Version bump
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog7
-rw-r--r--net-fs/samba/samba-4.1.0_rc3.ebuild153
2 files changed, 159 insertions, 1 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 32124b68c77e..5a71f3ee1fd6 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.602 2013/09/06 16:04:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.603 2013/09/13 14:08:59 polynomial-c Exp $
+
+*samba-4.1.0_rc3 (13 Sep 2013)
+
+ 13 Sep 2013; Lars Wendler <polynomial-c@gentoo.org> +samba-4.1.0_rc3.ebuild:
+ Version bump.
06 Sep 2013; Agostino Sarubbo <ago@gentoo.org> samba-3.6.16.ebuild:
Stable for sparc, wrt bug #478260
diff --git a/net-fs/samba/samba-4.1.0_rc3.ebuild b/net-fs/samba/samba-4.1.0_rc3.ebuild
new file mode 100644
index 000000000000..1ce55d07457d
--- /dev/null
+++ b/net-fs/samba/samba-4.1.0_rc3.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.1.0_rc3.ebuild,v 1.1 2013/09/13 14:08:59 polynomial-c Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit python-r1 waf-utils multilib linux-info systemd
+
+MY_PV="${PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+SRC_URI="mirror://samba/rc/${MY_P}.tar.gz"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+DESCRIPTION="Samba Suite Version 4"
+HOMEPAGE="http://www.samba.org/"
+LICENSE="GPL-3"
+
+SLOT="0"
+
+IUSE="acl addns ads aio avahi client cluster cups gnutls iprint
+ldap pam quota selinux syslog test winbind"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/iniparser
+ dev-libs/popt
+ sys-libs/readline
+ virtual/libiconv
+ dev-python/subunit
+ sys-libs/libcap
+ >=sys-libs/ldb-1.1.16
+ >=sys-libs/tdb-1.2.11[python]
+ >=sys-libs/talloc-2.0.8[python]
+ >=sys-libs/tevent-0.9.18
+ sys-libs/zlib
+ >=app-crypt/heimdal-1.5[-ssl]
+ addns? ( net-dns/bind-tools[gssapi] )
+ client? ( net-fs/cifs-utils[ads?] )
+ cluster? ( >=dev-db/ctdb-1.0.114_p1 )
+ ldap? ( net-nds/openldap )
+ gnutls? ( >=net-libs/gnutls-1.4.0 )
+ selinux? ( sec-policy/selinux-samba )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="ads? ( ldap )"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python_export_best
+ if use aio; then
+ if ! linux_config_exists || ! linux_chkconfig_present AIO; then
+ ewarn "You must enable AIO support in your kernel config, "
+ ewarn "to be able to support asynchronous I/O. "
+ ewarn "You can find it at"
+ ewarn
+ ewarn "General Support"
+ ewarn " Enable AIO support "
+ ewarn
+ ewarn "and recompile your kernel..."
+ fi
+ fi
+}
+
+src_configure() {
+ local myconf=''
+ use "cluster" && myconf+=" --with-ctdb-dir=/usr"
+ use "test" && myconf+=" --enable-selftest"
+ myconf="${myconf} \
+ --enable-fhs \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-modulesdir=/usr/$(get_libdir)/samba \
+ --with-pammodulesdir=/$(get_libdir)/security \
+ --disable-rpath \
+ --disable-rpath-install \
+ --nopyc \
+ --nopyo \
+ --bundled-libraries=ntdb \
+ --builtin-libraries=ntdb \
+ $(use_with addns dnsupdate) \
+ $(use_with acl) \
+ $(use_with ads) \
+ $(use_with aio aio-support) \
+ $(use_enable avahi) \
+ $(use_with cluster cluster-support) \
+ $(use_enable cups) \
+ $(use_enable gnutls) \
+ $(use_enable iprint) \
+ $(use_with ldap) \
+ $(use_with pam) \
+ $(use_with pam pam_smbpass) \
+ $(use_with quota) \
+ $(use_with syslog) \
+ $(use_with winbind)
+ "
+ use "ads" && myconf+=" --with-shared-modules=idmap_ad"
+
+ CPPFLAGS="-I/usr/include/et ${CPPFLAGS}" \
+ waf-utils_src_configure ${myconf}
+}
+
+src_install() {
+ waf-utils_src_install
+
+ # Seems like the build script gets the shebangs correct by itself
+ # (4.0.6)
+ #python_replicate_script \
+ # "${D}/usr/sbin/samba_dnsupdate" \
+ # "${D}/usr/sbin/samba_spnupdate" \
+ # "${D}/usr/sbin/samba_upgradedns" \
+ # "${D}/usr/sbin/samba_kcc" \
+ # "${D}/usr/bin/samba-tool"
+
+ # Make all .so files executable
+ find "${D}" -type f -name "*.so" -exec chmod +x {} +
+
+ # Install init script and conf.d file
+ newinitd "${CONFDIR}/samba4.initd-r1" samba
+ newconfd "${CONFDIR}/samba4.confd" samba
+
+ systemd_dotmpfilesd "${FILESDIR}"/samba.conf
+ systemd_dounit "${FILESDIR}"/nmbd.service
+ systemd_dounit "${FILESDIR}"/smbd.{service,socket}
+ systemd_newunit "${FILESDIR}"/smbd_at.service 'smbd@.service'
+ systemd_dounit "${FILESDIR}"/winbindd.service
+}
+
+src_test() {
+ "${WAF_BINARY}" test || die "test failed"
+}
+
+pkg_postinst() {
+ elog "This is is the first stable release of Samba 4.0"
+
+ ewarn "Be aware the this release contains the best of all of Samba's"
+ ewarn "technology parts, both a file server (that you can reasonably expect"
+ ewarn "to upgrade existing Samba 3.x releases to) and the AD domain"
+ ewarn "controller work previously known as 'samba4'."
+
+ elog "For further information and migration steps make sure to read "
+ elog "http://samba.org/samba/history/${P}.html "
+ elog "http://samba.org/samba/history/${PN}-4.0.0.html and"
+ elog "http://wiki.samba.org/index.php/Samba4/HOWTO "
+}