summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2007-03-25 17:53:04 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2007-03-25 17:53:04 +0000
commitb3f538879204dd133c6a5981d541196d8446e072 (patch)
treef66995e7d094350bd1e37c93ea68b5c47a56a070 /net-ftp/gproftpd
parentpatch added; ready for VDR-1.5.x (diff)
downloadgentoo-2-b3f538879204dd133c6a5981d541196d8446e072.tar.gz
gentoo-2-b3f538879204dd133c6a5981d541196d8446e072.tar.bz2
gentoo-2-b3f538879204dd133c6a5981d541196d8446e072.zip
version bump
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-ftp/gproftpd')
-rw-r--r--net-ftp/gproftpd/ChangeLog10
-rw-r--r--net-ftp/gproftpd/files/digest-gproftpd-8.3.13
-rw-r--r--net-ftp/gproftpd/gproftpd-8.3.1.ebuild64
3 files changed, 75 insertions, 2 deletions
diff --git a/net-ftp/gproftpd/ChangeLog b/net-ftp/gproftpd/ChangeLog
index 00a38668d724..0639286f8eb9 100644
--- a/net-ftp/gproftpd/ChangeLog
+++ b/net-ftp/gproftpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/gproftpd
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/gproftpd/ChangeLog,v 1.15 2006/11/01 18:54:41 dertobi123 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gproftpd/ChangeLog,v 1.16 2007/03/25 17:53:04 dertobi123 Exp $
+
+*gproftpd-8.3.1 (25 Mar 2007)
+
+ 25 Mar 2007; Tobias Scherbaum <dertobi123@gentoo.org>
+ +gproftpd-8.3.1.ebuild:
+ version bump
*gproftpd-8.2.8 (01 Nov 2006)
diff --git a/net-ftp/gproftpd/files/digest-gproftpd-8.3.1 b/net-ftp/gproftpd/files/digest-gproftpd-8.3.1
new file mode 100644
index 000000000000..7cdbdacd3ee7
--- /dev/null
+++ b/net-ftp/gproftpd/files/digest-gproftpd-8.3.1
@@ -0,0 +1,3 @@
+MD5 4daf47ad308ceb4eb431e9bfa6996771 gproftpd-8.3.1.tar.gz 605470
+RMD160 6f5c283e42d54f02f7d3c6b0292802e35794cada gproftpd-8.3.1.tar.gz 605470
+SHA256 3e52d1460c21776ba1828fec7eb142e92bf0b6b42780f67921ddaf0fce3452c7 gproftpd-8.3.1.tar.gz 605470
diff --git a/net-ftp/gproftpd/gproftpd-8.3.1.ebuild b/net-ftp/gproftpd/gproftpd-8.3.1.ebuild
new file mode 100644
index 000000000000..45ca7c745bd8
--- /dev/null
+++ b/net-ftp/gproftpd/gproftpd-8.3.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gproftpd/gproftpd-8.3.1.ebuild,v 1.1 2007/03/25 17:53:04 dertobi123 Exp $
+
+
+DESCRIPTION="GTK frontend to proftpd"
+HOMEPAGE="http://mange.dynup.net/linux.html"
+SRC_URI="http://mange.dynup.net/linux/gproftpd/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+
+IUSE="gnome ssl"
+
+# Requiring ProFTPD 1.2.9 due to security fixes
+DEPEND=">=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ >=x11-libs/pango-1.0
+ >=dev-libs/atk-1.0
+ dev-util/pkgconfig
+ >=media-libs/freetype-2.0
+ ssl? ( >=dev-libs/openssl-0.9.6f )"
+
+RDEPEND="${DEPEND}
+ >=net-ftp/proftpd-1.2.9"
+
+src_compile() {
+ local modules includes myconf
+
+ #location of proftpd.conf
+ myconf="/etc/proftpd"
+
+ if use ssl; then
+ einfo ssl
+ # enable mod_tls
+ modules="${modules}:mod_tls"
+ includes="${include}:/usr/kerberos/include"
+ fi
+
+ econf --sysconfdir=${myconf} \
+ --localstatedir=/var \
+ --with-modules=${modules} \
+ --with-includes=${includes} || die "./configure failed"
+ emake || die "Build failure"
+}
+
+src_install () {
+ emake DESTDIR=${D} install || die "Installation failure"
+
+# Add the Gnome menu entry
+ if use gnome; then
+ insinto /usr/share/gnome/apps/Internet/
+ doins ${S}/desktop/net-gproftpd.desktop
+ fi
+
+ dodoc AUTHORS ChangeLog COPYING INSTALL README
+}
+
+pkg_postinst() {
+ einfo "gproftpd looks for your proftpd.conf file in /etc/proftpd"
+ einfo "run gproftpd with the option -c to specify an alternate location"
+ einfo "ex: gproftpd -c /etc/proftpd.conf"
+ ewarn "Do NOT edit /etc/conf.d/proftpd with this program"
+}