summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-11-15 14:27:32 +0000
committerAchim Gottinger <achim@gentoo.org>2001-11-15 14:27:32 +0000
commit336b80ea6bed0eeb32860aa7ef925e46fab318db (patch)
tree5fa3849cb8519a2c1dc4c51ca75646e4f3b75566 /net-ftp/lukemftp
parentthis patched version is no longer required after I found the pilot-link (diff)
downloadgentoo-2-336b80ea6bed0eeb32860aa7ef925e46fab318db.tar.gz
gentoo-2-336b80ea6bed0eeb32860aa7ef925e46fab318db.tar.bz2
gentoo-2-336b80ea6bed0eeb32860aa7ef925e46fab318db.zip
obsolete patch (same as less)
Diffstat (limited to 'net-ftp/lukemftp')
-rw-r--r--net-ftp/lukemftp/files/digest-lukemftp-1.5-r31
-rw-r--r--net-ftp/lukemftp/files/lukemftp-1.5-r3-gentoo.diff85
-rw-r--r--net-ftp/lukemftp/lukemftp-1.5-r3.ebuild46
3 files changed, 0 insertions, 132 deletions
diff --git a/net-ftp/lukemftp/files/digest-lukemftp-1.5-r3 b/net-ftp/lukemftp/files/digest-lukemftp-1.5-r3
deleted file mode 100644
index 72709ac09d1b..000000000000
--- a/net-ftp/lukemftp/files/digest-lukemftp-1.5-r3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0cd0fc2e3fca21ca56647b2e1142a01a lukemftp-1.5.tar.gz 266240
diff --git a/net-ftp/lukemftp/files/lukemftp-1.5-r3-gentoo.diff b/net-ftp/lukemftp/files/lukemftp-1.5-r3-gentoo.diff
deleted file mode 100644
index cc2f396f5eec..000000000000
--- a/net-ftp/lukemftp/files/lukemftp-1.5-r3-gentoo.diff
+++ /dev/null
@@ -1,85 +0,0 @@
---- src/extern.h~ Sun Aug 6 08:51:22 2000
-+++ src/extern.h Thu Nov 15 13:47:21 2001
-@@ -147,7 +147,7 @@
- void get(int, char **);
- struct cmd *getcmd(const char *);
- int getit(int, char **, int, const char *);
--struct option *getoption(const char *);
-+struct option2 *getoption(const char *);
- char *getoptionvalue(const char *);
- void getremoteinfo(void);
- int getreply(int);
---- src/cmds.c~ Wed Aug 2 12:52:51 2000
-+++ src/cmds.c Thu Nov 15 13:44:52 2001
-@@ -2556,7 +2556,7 @@
- void
- setoption(int argc, char *argv[])
- {
-- struct option *o;
-+ struct option2 *o;
-
- code = -1;
- if (argc == 0 || (argc != 1 && argc != 3)) {
-@@ -2591,7 +2591,7 @@
- void
- unsetoption(int argc, char *argv[])
- {
-- struct option *o;
-+ struct option2 *o;
-
- code = -1;
- if (argc == 0 || argc != 2) {
---- src/ftp_var.h~ Wed Aug 2 12:52:51 2000
-+++ src/ftp_var.h Thu Nov 15 13:43:53 2001
-@@ -147,7 +147,7 @@
- /*
- * Format of option table
- */
--struct option {
-+struct option2 {
- char *name;
- char *value;
- };
---- src/main.c~ Thu Nov 15 13:36:15 2001
-+++ src/main.c Thu Nov 15 13:46:13 2001
-@@ -516,7 +516,7 @@
- static char buf[MAXPATHLEN];
-
- if (prompt == NULL) {
-- struct option *o;
-+ struct option2 *o;
-
- o = getoption("prompt");
- if (o == NULL)
-@@ -537,7 +537,7 @@
- static char buf[MAXPATHLEN];
-
- if (rprompt == NULL) {
-- struct option *o;
-+ struct option2 *o;
-
- o = getoption("rprompt");
- if (o == NULL)
-@@ -913,11 +913,11 @@
- }
- }
-
--struct option *
-+struct option2 *
- getoption(const char *name)
- {
- const char *p;
-- struct option *c;
-+ struct option2 *c;
-
- if (name == NULL)
- return (NULL);
-@@ -931,7 +931,7 @@
- char *
- getoptionvalue(const char *name)
- {
-- struct option *c;
-+ struct option2 *c;
-
- if (name == NULL)
- errx(1, "getoptionvalue() invoked with NULL name");
diff --git a/net-ftp/lukemftp/lukemftp-1.5-r3.ebuild b/net-ftp/lukemftp/lukemftp-1.5-r3.ebuild
deleted file mode 100644
index 808171d72046..000000000000
--- a/net-ftp/lukemftp/lukemftp-1.5-r3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2000-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Donny Davies <woodchip@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lukemftp/lukemftp-1.5-r3.ebuild,v 1.1 2001/11/15 12:55:05 achim Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="NetBSD FTP client with several advanced features"
-SRC_URI="ftp://ftp.netbsd.org/pub/NetBSD/misc/lukemftp/${P}.tar.gz"
-
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.1"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # Adds a command line option: -s, which produces clean, informative output.
- # Shows progess status, ETA, transfer speed, no server responses or login messages.
- # ~woodchip
- cp src/main.c src/main.orig
- sed -e "s/Aadefgino:pP:r:RtT:u:vV/Aadefgino:pP:r:RstT:u:vV/" \
- -e "s/case 't'/case 's':\n\t\t\tverbose = 0;\n\t\t\tprogress = 1;\n\t\t\tbreak;\n\n\t\t&/" \
- src/main.orig > src/main.c
-
- # And now we need to patch some stuff (achim)
- patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
-}
-
-src_compile() {
- local myconf
- use ipv6 || myconf="${myconf} --disable-ipv6"
-
- ./configure --host=${CHOST} --prefix=/usr --enable-editcomplete ${myconf}
- assert ; make ; assert "compile problem :("
-}
-
-src_install() {
- dodoc COPYING ChangeLog README* THANKS NEWS
- newbin src/ftp lukemftp
- newman src/ftp.1 lukemftp.1
-
- if [ ! -e /usr/bin/ftp ]; then
- cd ${D}/usr/bin
- ln -s lukemftp ftp
- fi
-}