summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2008-05-11 19:10:29 +0000
committerNed Ludd <solar@gentoo.org>2008-05-11 19:10:29 +0000
commit47b7af2243e06de7afb9ccf3a4007f7de957a6ce (patch)
tree10b736603ec5d03c8ae08e7582aa37a5fcf152b3 /net-ftp/netkit-ftpd
parentfix runtime errors with XCB, patches provided by Ed Catmur <ed AT catmur DOT ... (diff)
downloadgentoo-2-47b7af2243e06de7afb9ccf3a4007f7de957a6ce.tar.gz
gentoo-2-47b7af2243e06de7afb9ccf3a4007f7de957a6ce.tar.bz2
gentoo-2-47b7af2243e06de7afb9ccf3a4007f7de957a6ce.zip
- make netkit-ftpd cross compile aware
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-ftp/netkit-ftpd')
-rw-r--r--net-ftp/netkit-ftpd/ChangeLog6
-rw-r--r--net-ftp/netkit-ftpd/files/netkit-ftpd-0.17-cross.patch45
-rw-r--r--net-ftp/netkit-ftpd/netkit-ftpd-0.17-r7.ebuild6
3 files changed, 54 insertions, 3 deletions
diff --git a/net-ftp/netkit-ftpd/ChangeLog b/net-ftp/netkit-ftpd/ChangeLog
index 0fe1ea3edc9c..6133131be3e6 100644
--- a/net-ftp/netkit-ftpd/ChangeLog
+++ b/net-ftp/netkit-ftpd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/netkit-ftpd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-ftpd/ChangeLog,v 1.17 2008/01/14 21:13:31 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-ftpd/ChangeLog,v 1.18 2008/05/11 19:10:29 solar Exp $
+
+ 11 May 2008; <solar@gentoo.org> +files/netkit-ftpd-0.17-cross.patch,
+ netkit-ftpd-0.17-r7.ebuild:
+ - make netkit-ftpd cross compile aware
14 Jan 2008; Ulrich Mueller <ulm@gentoo.org> -netkit-ftpd-0.17-r4.ebuild,
-netkit-ftpd-0.17-r5.ebuild:
diff --git a/net-ftp/netkit-ftpd/files/netkit-ftpd-0.17-cross.patch b/net-ftp/netkit-ftpd/files/netkit-ftpd-0.17-cross.patch
new file mode 100644
index 000000000000..cb6ad986a914
--- /dev/null
+++ b/net-ftp/netkit-ftpd/files/netkit-ftpd-0.17-cross.patch
@@ -0,0 +1,45 @@
+--- configure.orig 2008-05-11 12:02:50.000000000 -0700
++++ configure 2008-05-11 12:04:14.000000000 -0700
+@@ -93,7 +93,7 @@
+ echo -n 'Checking if C compiler works... '
+ if (
+ $CC __conftest.c -o __conftest || exit 1
+- ./__conftest || exit 1
++ [ -e __conftest ] || exit 1
+ ) >/dev/null 2>&1; then
+ echo 'yes'
+ else
+@@ -169,13 +169,13 @@
+ EOF
+ if (
+ $CC $CFLAGS __conftest.c -o __conftest || exit 1
+- ./__conftest || exit 1
++ [ -e __conftest ] || exit 1
+ ) >/dev/null 2>&1; then
+ echo 'yes'
+ else
+ if (
+ $CC $CFLAGS -D__USE_BSD_SIGNAL __conftest.c -o __conftest || exit 1
+- ./__conftest || exit 1
++ [ -e ./__conftest ] || exit 1
+ ) >/dev/null 2>&1; then
+ echo '-D__USE_BSD_SIGNAL'
+ CFLAGS="$CFLAGS -D__USE_BSD_SIGNAL"
+@@ -311,7 +311,7 @@
+ else
+ if (
+ $CC $CFLAGS -D_GNU_SOURCE __conftest.c -o __conftest || exit 1
+- ./__conftest || exit 1
++ [ -e ./__conftest ] || exit 1
+ ) >/dev/null 2>&1; then
+ echo '-D_GNU_SOURCE'
+ CFLAGS="$CFLAGS -D_GNU_SOURCE"
+@@ -342,7 +342,7 @@
+ EOF
+ if (
+ $CC $CFLAGS __conftest.c $LIBBSD -o __conftest || exit 1
+- ./__conftest || exit 1
++ [ -e ./__conftest ] || exit 1
+ ) >/dev/null 2>&1; then
+ echo 'ok'
+ else
diff --git a/net-ftp/netkit-ftpd/netkit-ftpd-0.17-r7.ebuild b/net-ftp/netkit-ftpd/netkit-ftpd-0.17-r7.ebuild
index 86f898741899..e4071e3932ba 100644
--- a/net-ftp/netkit-ftpd/netkit-ftpd-0.17-r7.ebuild
+++ b/net-ftp/netkit-ftpd/netkit-ftpd-0.17-r7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-ftpd/netkit-ftpd-0.17-r7.ebuild,v 1.9 2008/01/14 19:40:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-ftpd/netkit-ftpd-0.17-r7.ebuild,v 1.10 2008/05/11 19:10:29 solar Exp $
-inherit eutils ssl-cert
+inherit eutils ssl-cert toolchain-funcs
MY_P="linux-ftpd-${PV}"
DESCRIPTION="The netkit FTP server with optional SSL support"
@@ -30,10 +30,12 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-shadowfix.patch
epatch "${FILESDIR}"/${P}-gcc41.patch
epatch "${FILESDIR}"/${P}-setguid.patch
+ epatch "${FILESDIR}"/${P}-cross.patch
use ssl && epatch "${FILESDIR}"/${P}-fclose-CVE-2007-6263.patch #199206
}
src_compile() {
+ tc-export CC
./configure --prefix=/usr || die "configure failed"
emake || die "parallel make failed"
}