summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-02 08:31:54 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-02 08:31:54 +0000
commit2198a2cf845c9511fe0052b4a230169733bf689f (patch)
tree61cb7cc59c11b86079854be338ca711bdf538032 /net-ftp/proftpd
parentAdded building of shared libs. (diff)
downloadgentoo-2-2198a2cf845c9511fe0052b4a230169733bf689f.tar.gz
gentoo-2-2198a2cf845c9511fe0052b4a230169733bf689f.tar.bz2
gentoo-2-2198a2cf845c9511fe0052b4a230169733bf689f.zip
Added dependencies
Diffstat (limited to 'net-ftp/proftpd')
-rw-r--r--net-ftp/proftpd/proftpd-1.2.0_rc2-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-ftp/proftpd/proftpd-1.2.0_rc2-r1.ebuild b/net-ftp/proftpd/proftpd-1.2.0_rc2-r1.ebuild
index 64942c9e93de..b1d5df912b75 100644
--- a/net-ftp/proftpd/proftpd-1.2.0_rc2-r1.ebuild
+++ b/net-ftp/proftpd/proftpd-1.2.0_rc2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.0_rc2-r1.ebuild,v 1.3 2000/09/20 20:04:53 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.0_rc2-r1.ebuild,v 1.4 2000/11/02 08:31:52 achim Exp $
P=proftpd-1.2.0rc2
A="${P}.tar.gz"
@@ -10,13 +10,18 @@ DESCRIPTION="proftpd."
SRC_URI="ftp://ftp.nl.uu.net/pub/unix/ftp/proftpd/${P}.tar.gz"
HOMEPAGE="http://www.proftpd.net/"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.72
+ >=dev-db/mysql-3.23.26
+ >=net-nds/openldap-1.2.11"
+
src_unpack() {
unpack ${A}
}
src_compile() {
LDFLAGS="-Lssl" CFLAGS="$CFLAGS -I/usr/include/mysql" try ./configure --host=${CHOST} --prefix=/usr --sbindir=/usr/sbin \
- --sysconfdir=/etc --localstatedir=/var/run --mandir=/usr/man \
+ --sysconfdir=/etc/proftp --localstatedir=/var/run --mandir=/usr/man \
--with-modules=mod_ldap:mod_ratio:mod_readme:mod_linuxprivs:mod_mysql:mod_sqlpw:mod_pam \
--disable-sendfile --enable-shadow --enable-autoshadow
try make clean