summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-13 07:32:12 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-13 07:32:12 +0000
commit41050a640c665afcac11256ac4a3b650401a6fd9 (patch)
treeaffadb4784fb4b5aed4c8dc04146bb1753bc0137 /net-ftp/swiftfxp
parentRemoving condition for patch, so gcc4 can compile this too (diff)
downloadgentoo-2-41050a640c665afcac11256ac4a3b650401a6fd9.tar.gz
gentoo-2-41050a640c665afcac11256ac4a3b650401a6fd9.tar.bz2
gentoo-2-41050a640c665afcac11256ac4a3b650401a6fd9.zip
initial import
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'net-ftp/swiftfxp')
-rw-r--r--net-ftp/swiftfxp/ChangeLog8
-rw-r--r--net-ftp/swiftfxp/Manifest2
-rw-r--r--net-ftp/swiftfxp/files/digest-swiftfxp-0.4.41
-rw-r--r--net-ftp/swiftfxp/files/swiftfxp-0.4.4-build.patch17
-rw-r--r--net-ftp/swiftfxp/swiftfxp-0.4.4.ebuild29
5 files changed, 57 insertions, 0 deletions
diff --git a/net-ftp/swiftfxp/ChangeLog b/net-ftp/swiftfxp/ChangeLog
new file mode 100644
index 000000000000..073c122af846
--- /dev/null
+++ b/net-ftp/swiftfxp/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-ftp/swiftfxp
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/swiftfxp/ChangeLog,v 1.1 2005/11/13 07:32:12 vapier Exp $
+
+*swiftfxp-0.4.4 (13 Nov 2005)
+
+ 13 Nov 2005; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/net-ftp/swiftfxp/Manifest b/net-ftp/swiftfxp/Manifest
new file mode 100644
index 000000000000..0f9b0cccf6bd
--- /dev/null
+++ b/net-ftp/swiftfxp/Manifest
@@ -0,0 +1,2 @@
+MD5 e27f8098d95ef36dd7bde34b75ce56b5 files/digest-swiftfxp-0.4.4 62
+MD5 ba167765d96ad3d982182e4ea1881c7b swiftfxp-0.4.4.ebuild 458
diff --git a/net-ftp/swiftfxp/files/digest-swiftfxp-0.4.4 b/net-ftp/swiftfxp/files/digest-swiftfxp-0.4.4
new file mode 100644
index 000000000000..a167ed82d9a0
--- /dev/null
+++ b/net-ftp/swiftfxp/files/digest-swiftfxp-0.4.4
@@ -0,0 +1 @@
+MD5 afe830bdad153aed34550b2886af2990 SwiftFXP-0.4.4.zip 57728
diff --git a/net-ftp/swiftfxp/files/swiftfxp-0.4.4-build.patch b/net-ftp/swiftfxp/files/swiftfxp-0.4.4-build.patch
new file mode 100644
index 000000000000..394d297216b2
--- /dev/null
+++ b/net-ftp/swiftfxp/files/swiftfxp-0.4.4-build.patch
@@ -0,0 +1,17 @@
+--- Makefile
++++ Makefile
+@@ -1,5 +1,5 @@
+-CC = gcc
+-CFLAGS = -O2 -g `gtk-config --cflags`
++CC ?= gcc
++CFLAGS += `gtk-config --cflags`
+ LIBS = `gtk-config --libs gthread `
+ LIBPATH = -L/usr/X11R6/lib -lpthread
+ OBJECTS = ui.o net.o misc.o widgets.o configfile.o queue.o sort.o
+@@ -26,3 +26,6 @@
+ SwiftFXP: $(OBJECTS)
+ $(CC) $(CFLAGS) -o SwiftFXP $(OBJECTS) $(LIBS) $(LIBPATH)
+
++install:
++ install -m 0755 -d $(DESTDIR)/usr/bin
++ install -m 0755 SwiftFXP $(DESTDIR)/usr/bin
diff --git a/net-ftp/swiftfxp/swiftfxp-0.4.4.ebuild b/net-ftp/swiftfxp/swiftfxp-0.4.4.ebuild
new file mode 100644
index 000000000000..10b875ebdae7
--- /dev/null
+++ b/net-ftp/swiftfxp/swiftfxp-0.4.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/swiftfxp/swiftfxp-0.4.4.ebuild,v 1.1 2005/11/13 07:32:12 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="GTK based FXP Client clone of FlashFXP"
+HOMEPAGE="http://sourceforge.net/projects/swiftfxp/"
+SRC_URI="mirror://sourceforge/swiftfxp/SwiftFXP-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=x11-libs/gtk+-1*"
+
+S=${WORKDIR}/SwiftFXP-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc BUGS ChangeLog README TODO
+}