summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-10-20 22:10:51 +0000
committerJeroen Roovers <jer@gentoo.org>2009-10-20 22:10:51 +0000
commit111065cb218d2886071fb8144b74871d10a2e6b7 (patch)
tree4eb629e8103299af3b1468591a1de0bc57d048da /net-ftp
parentinitial commit (bug #284645) (diff)
downloadgentoo-2-111065cb218d2886071fb8144b74871d10a2e6b7.tar.gz
gentoo-2-111065cb218d2886071fb8144b74871d10a2e6b7.tar.bz2
gentoo-2-111065cb218d2886071fb8144b74871d10a2e6b7.zip
Version bump. Carry over lafiles patch.
(Portage version: 2.2_rc46/cvs/Linux i686)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-4.0.3.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 1c528ce0c797..8d440b7bb24f 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.238 2009/10/13 19:04:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.239 2009/10/20 22:10:51 jer Exp $
+
+*lftp-4.0.3 (20 Oct 2009)
+
+ 20 Oct 2009; Jeroen Roovers <jer@gentoo.org> +lftp-4.0.3.ebuild:
+ Version bump. Carry over lafiles patch.
13 Oct 2009; Jeroen Roovers <jer@gentoo.org> -lftp-3.7.14.ebuild:
Remove old.
diff --git a/net-ftp/lftp/lftp-4.0.3.ebuild b/net-ftp/lftp/lftp-4.0.3.ebuild
new file mode 100644
index 000000000000..8dfcd2dc9ba7
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.0.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.0.3.ebuild,v 1.1 2009/10/20 22:10:51 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ >=sys-libs/readline-5.1
+"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl
+ =sys-devel/libtool-2*
+"
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.0.2.91-lafile.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}