summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-07-10 13:07:59 +0000
committerRoy Marples <uberlord@gentoo.org>2007-07-10 13:07:59 +0000
commitbd6449585d0ba055337a0ef26d12efbfd0dd1887 (patch)
tree2284885549d490e199ee01bfbd0285a2bb6a592f /net-ftp
parentx86 stable and remove old (diff)
downloadgentoo-2-bd6449585d0ba055337a0ef26d12efbfd0dd1887.tar.gz
gentoo-2-bd6449585d0ba055337a0ef26d12efbfd0dd1887.tar.bz2
gentoo-2-bd6449585d0ba055337a0ef26d12efbfd0dd1887.zip
Bumped for bug #184666 and keyworded ~x86-fbsd.
(Portage version: 2.1.3_rc7)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ftpbase/ChangeLog7
-rw-r--r--net-ftp/ftpbase/files/digest-ftpbase-0.010
-rw-r--r--net-ftp/ftpbase/ftpbase-0.01.ebuild87
3 files changed, 93 insertions, 1 deletions
diff --git a/net-ftp/ftpbase/ChangeLog b/net-ftp/ftpbase/ChangeLog
index 83524dbf8cd9..6f5d00a03239 100644
--- a/net-ftp/ftpbase/ChangeLog
+++ b/net-ftp/ftpbase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/ftpbase
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ChangeLog,v 1.14 2007/05/15 14:03:32 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ChangeLog,v 1.15 2007/07/10 13:07:59 uberlord Exp $
+
+*ftpbase-0.01 (09 Jul 2007)
+
+ 09 Jul 2007; Roy Marples <uberlord@gentoo.org> +ftpbase-0.01.ebuild:
+ Bumped for bug #184666 and keyworded ~x86-fbsd.
15 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/net-ftp/ftpbase/files/digest-ftpbase-0.01 b/net-ftp/ftpbase/files/digest-ftpbase-0.01
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net-ftp/ftpbase/files/digest-ftpbase-0.01
diff --git a/net-ftp/ftpbase/ftpbase-0.01.ebuild b/net-ftp/ftpbase/ftpbase-0.01.ebuild
new file mode 100644
index 000000000000..bfd7f3a3e38e
--- /dev/null
+++ b/net-ftp/ftpbase/ftpbase-0.01.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ftpbase-0.01.ebuild,v 1.1 2007/07/10 13:07:59 uberlord Exp $
+
+inherit eutils pam
+
+DESCRIPTION="FTP layout package"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="pam"
+
+DEPEND="pam? ( || ( virtual/pam sys-libs/pam ) )
+ !<net-ftp/proftpd-1.2.10-r6
+ !<net-ftp/pure-ftpd-1.0.20-r2
+ !<net-ftp/vsftpd-2.0.3-r1"
+
+S=${WORKDIR}
+
+check_collision() {
+ [[ ! -e $1 ]] && return 0
+
+ [[ $(head -n 1 "$1") == $(head -n 1 "$2") ]] && return 0
+
+ eerror " $1 exists and was not provided by ${P}"
+ return 1
+}
+
+pkg_setup() {
+ ebegin "Checking for possible file collisions..."
+
+ local collide=false
+ check_collision "${ROOT}etc/ftpusers" "${FILESDIR}/ftpusers" || collide=true
+
+ if use pam ; then
+ check_collision "${ROOT}etc/pam.d/ftp" "${FILESDIR}/ftp-pamd" || collide=true
+ fi
+
+ if ${collide} ; then
+ eerror
+ eerror "Those files listed above have to be removed in order to"
+ eerror "install this version of ftpbase."
+ eerror
+ eerror "If you edited them, remember to backup and when restoring make"
+ eerror " sure the first line in each file is:"
+ eerror "$(head -n 1 "${FILESDIR}/ftpusers")"
+ eend 1
+ die "Can't be installed, files will collide"
+ fi
+
+ eend 0
+
+ # Check if home exists
+ local exists=false
+ [[ -d "${ROOT}home/ftp" ]] && exists=true
+
+ # Add our default ftp user
+ enewgroup ftp 21
+ enewuser ftp 21 -1 /home/ftp ftp
+
+ # If home did not exist and does now then we created it in the enewuser
+ # command. Now we have to change it's permissions to something sane.
+ if [[ ${exists} == "false" && -d "${ROOT}home/ftp" ]] ; then
+ chown root:ftp "${ROOT}"home/ftp
+ fi
+}
+
+src_install() {
+ # The ftpusers file is a list of people who are NOT allowed
+ # to use the ftp service.
+ insinto /etc
+ doins "${FILESDIR}/ftpusers" || die
+
+ # Ideally we would create the home directory here with a dodir.
+ # But we cannot until bug #9849 is solved - so we kludge in pkg_postinst()
+
+ if use pam ; then
+ if has_version "<sys-libs/pam-0.78" ; then
+ newpamd "${FILESDIR}/ftp-pamd" ftp
+ else
+ newpamd "${FILESDIR}/ftp-pamd-include" ftp
+ fi
+ fi
+}