summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-12-14 17:31:26 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-12-14 17:31:26 +0000
commitf09703d06f0120d7e3540f72c789e57a532c9abf (patch)
treecdf26145632e18c0dd0692c6bda87da9aba1806d /net-ftp
parentRepacked in a tar ball to avoid conflicts with jsmath-extra-dark (diff)
downloadgentoo-2-f09703d06f0120d7e3540f72c789e57a532c9abf.tar.gz
gentoo-2-f09703d06f0120d7e3540f72c789e57a532c9abf.tar.bz2
gentoo-2-f09703d06f0120d7e3540f72c789e57a532c9abf.zip
Version bump, use pid variables in init script by Polynomial-C in bug #296864
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/pure-ftpd/ChangeLog9
-rw-r--r--net-ftp/pure-ftpd/files/pure-ftpd.rc713
-rw-r--r--net-ftp/pure-ftpd/pure-ftpd-1.0.27.ebuild119
3 files changed, 135 insertions, 6 deletions
diff --git a/net-ftp/pure-ftpd/ChangeLog b/net-ftp/pure-ftpd/ChangeLog
index 91f69a6e6b5e..3738447ee704 100644
--- a/net-ftp/pure-ftpd/ChangeLog
+++ b/net-ftp/pure-ftpd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/pure-ftpd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.82 2009/11/23 12:59:07 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.83 2009/12/14 17:31:26 voyageur Exp $
+
+*pure-ftpd-1.0.27 (14 Dec 2009)
+
+ 14 Dec 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +pure-ftpd-1.0.27.ebuild, files/pure-ftpd.rc7:
+ Version bump, use pid variables in init script by Polynomial-C in bug
+ #296864
*pure-ftpd-1.0.26 (23 Nov 2009)
diff --git a/net-ftp/pure-ftpd/files/pure-ftpd.rc7 b/net-ftp/pure-ftpd/files/pure-ftpd.rc7
index 84bcf21e0ebf..34918951f5f1 100644
--- a/net-ftp/pure-ftpd/files/pure-ftpd.rc7
+++ b/net-ftp/pure-ftpd/files/pure-ftpd.rc7
@@ -1,7 +1,10 @@
#!/sbin/runscript
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/files/pure-ftpd.rc7,v 1.1 2009/11/23 12:59:07 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/files/pure-ftpd.rc7,v 1.2 2009/12/14 17:31:26 voyageur Exp $
+
+ftpd_pidifle="/var/run/pure-ftpd.pid"
+script_pidfile="/var/run/pure-uploadscript.pid"
depend() {
need net
@@ -23,7 +26,7 @@ start() {
OKNODO="--oknodo"
fi
ebegin "Starting Pure-FTPd"
- start-stop-daemon --start --quiet --pidfile /var/run/pure-ftpd.pid $OKNODO --exec /usr/sbin/pure-ftpd -- --pidfile /var/run/pure-ftpd.pid $SERVER $MAX_CONN $MAX_CONN_IP $DAEMON $DISK_FULL $USE_NAT $AUTH $LOG $TIMEOUT $CHARCONV $MISC_OTHER $UPSCRIPT
+ start-stop-daemon --start --quiet --pidfile ${ftpd_pidfile} $OKNODO --exec /usr/sbin/pure-ftpd -- --pidfile ${ftpd_pidfile} $SERVER $MAX_CONN $MAX_CONN_IP $DAEMON $DISK_FULL $USE_NAT $AUTH $LOG $TIMEOUT $CHARCONV $MISC_OTHER $UPSCRIPT
result=$?
if [ $result -ne 0 ] ; then
eend 1 "Could not launch Pure-FTPd"
@@ -31,7 +34,7 @@ start() {
eend $result
if [ -n "$UPLOADSCRIPT" ] ; then
ebegin "Starting Pure-FTPd upload script"
- start-stop-daemon --start --quiet --make-pidfile --pidfile /var/run/pure-uploadscript.pid --exec /usr/sbin/pure-uploadscript -- -B -r $UPLOADSCRIPT
+ start-stop-daemon --start --quiet --make-pidfile --pidfile ${script_pidfile} --exec /usr/sbin/pure-uploadscript -- -B -r $UPLOADSCRIPT
eend $?
fi
fi
@@ -39,11 +42,11 @@ start() {
stop() {
ebegin "Stopping Pure-FTPd"
- start-stop-daemon --stop --retry 20 --quiet --pidfile /var/run/pure-ftpd.pid
+ start-stop-daemon --stop --retry 20 --quiet --pidfile ${ftpd_pidfile}
eend $?
if [ -n "$UPLOADSCRIPT" ] ; then
ebegin "Stopping Pure-FTPd upload script"
- start-stop-daemon --stop --retry 20 --quiet --pidfile /var/run/pure-uploadscript.pid
+ start-stop-daemon --stop --retry 20 --quiet --pidfile ${script_pidfile}
eend $?
fi
}
diff --git a/net-ftp/pure-ftpd/pure-ftpd-1.0.27.ebuild b/net-ftp/pure-ftpd/pure-ftpd-1.0.27.ebuild
new file mode 100644
index 000000000000..57bab6ec3d6f
--- /dev/null
+++ b/net-ftp/pure-ftpd/pure-ftpd-1.0.27.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/pure-ftpd-1.0.27.ebuild,v 1.1 2009/12/14 17:31:26 voyageur Exp $
+
+EAPI=2
+inherit eutils confutils flag-o-matic
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="Fast, production-quality, standard-conformant FTP server."
+HOMEPAGE="http://www.pureftpd.org/"
+SRC_URI="ftp://ftp.pureftpd.org/pub/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+
+IUSE="anondel anonperm anonren anonres caps charconv ldap mysql noiplog pam paranoidmsg postgres selinux ssl vchroot xinetd"
+
+DEPEND="caps? ( sys-libs/libcap )
+ charconv? ( virtual/libiconv )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ mysql? ( virtual/mysql )
+ pam? ( virtual/pam )
+ postgres? ( virtual/postgresql-base )
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ xinetd? ( virtual/inetd )"
+
+RDEPEND="${DEPEND}
+ net-ftp/ftpbase
+ selinux? ( sec-policy/selinux-ftpd )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.22-pam.patch
+}
+
+src_configure() {
+ # adjust max user length to something more appropriate
+ # for virtual hosts. See bug #62472 for details.
+ sed -e "s:# define MAX_USER_LENGTH 32U:# define MAX_USER_LENGTH 127U:" -i "${S}/src/ftpd.h" || die "sed failed"
+
+ local my_conf=""
+
+ # Let's configure the USE-enabled stuff
+ enable_extension_without "capabilities" "caps"
+ enable_extension_with "rfc2640" "charconv" 0
+ enable_extension_with "ldap" "ldap" 0
+ enable_extension_with "mysql" "mysql" 0
+ enable_extension_with "pam" "pam" 0
+ enable_extension_with "paranoidmsg" "paranoidmsg" 0
+ enable_extension_with "pgsql" "postgres" 0
+ enable_extension_with "tls" "ssl" 0
+ enable_extension_with "virtualchroot" "vchroot" 0
+ enable_extension_without "inetd" "xinetd"
+
+ # noiplog is a negative flag, we don't want that enabled by default,
+ # so we handle it manually, as confutils can't do that
+ use noiplog && my_conf="${my_conf} --without-iplogging"
+
+ # Those features are only configurable like this, see bug #179375.
+ use anondel && append-cppflags -DANON_CAN_DELETE
+ use anonperm && append-cppflags -DANON_CAN_CHANGE_PERMS
+ use anonren && append-cppflags -DANON_CAN_RENAME
+ use anonres && append-cppflags -DANON_CAN_RESUME
+
+ econf \
+ --with-altlog \
+ --with-cookie \
+ --with-diraliases \
+ --with-extauth \
+ --with-ftpwho \
+ --with-language=${PUREFTPD_LANG:=english} \
+ --with-peruserlimits \
+ --with-privsep \
+ --with-puredb \
+ --with-quotas \
+ --with-ratios \
+ --with-throttling \
+ --with-uploadscript \
+ --with-virtualhosts \
+ --enable-largefile \
+ ${my_conf} || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS CONTACT ChangeLog FAQ HISTORY INSTALL README* NEWS
+
+ newconfd "${FILESDIR}/pure-ftpd.conf_d" pure-ftpd
+
+ newinitd "${FILESDIR}/pure-ftpd.rc7" pure-ftpd
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}/pure-ftpd.xinetd" pure-ftpd
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ doins pureftpd.schema
+ insinto /etc/openldap
+ insopts -m 0600
+ doins pureftpd-ldap.conf
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "Before starting Pure-FTPd, you have to edit the /etc/conf.d/pure-ftpd file!"
+ elog
+ ewarn "It's *really* important to read the README provided with Pure-FTPd!"
+ ewarn "Check out http://download.pureftpd.org/pub/pure-ftpd/doc/README for general info"
+ ewarn "and http://download.pureftpd.org/pub/pure-ftpd/doc/README.TLS for SSL/TLS info."
+ ewarn
+ if use charconv ; then
+ ewarn "Charset conversion is an *experimental* feature!"
+ ewarn "Remember to set a valid charset for your filesystem in the configuration!"
+ fi
+}