summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-28 01:49:47 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-28 01:49:47 +0000
commit059e63952e845b8080653dc61bdb93699d115336 (patch)
tree265859111c4f5d3469e549b86e1edb30fa261903 /net-im/gnomeicu
parentman page/LFH fixes. (diff)
downloadgentoo-2-059e63952e845b8080653dc61bdb93699d115336.tar.gz
gentoo-2-059e63952e845b8080653dc61bdb93699d115336.tar.bz2
gentoo-2-059e63952e845b8080653dc61bdb93699d115336.zip
Version bump and nls checks
Diffstat (limited to 'net-im/gnomeicu')
-rw-r--r--net-im/gnomeicu/ChangeLog8
-rw-r--r--net-im/gnomeicu/files/digest-gnomeicu-0.98.21
-rw-r--r--net-im/gnomeicu/gnomeicu-0.98.2.ebuild56
3 files changed, 64 insertions, 1 deletions
diff --git a/net-im/gnomeicu/ChangeLog b/net-im/gnomeicu/ChangeLog
index 8d3aa78b2515..10a0040dff4c 100644
--- a/net-im/gnomeicu/ChangeLog
+++ b/net-im/gnomeicu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gnomeicu
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnomeicu/ChangeLog,v 1.1 2002/02/01 21:53:32 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnomeicu/ChangeLog,v 1.2 2002/03/28 01:49:47 seemant Exp $
+
+*gnomeicu-0.98.2 (27 Mar 2002)
+
+ 27 Mar 2002; Seemant Kulleen <seemant@gentoo.org> gnomeicu-0.98.2.ebuild :
+
+ Version bump submitted by lkthomas. I added USE dependent nls compilation.
*gnomeicu-0.98 (1 Feb 2002)
diff --git a/net-im/gnomeicu/files/digest-gnomeicu-0.98.2 b/net-im/gnomeicu/files/digest-gnomeicu-0.98.2
new file mode 100644
index 000000000000..379a2569a466
--- /dev/null
+++ b/net-im/gnomeicu/files/digest-gnomeicu-0.98.2
@@ -0,0 +1 @@
+MD5 b0e015d060e3656c51b9dc962ed2a791 gnomeicu-0.98.2.tar.gz 1348190
diff --git a/net-im/gnomeicu/gnomeicu-0.98.2.ebuild b/net-im/gnomeicu/gnomeicu-0.98.2.ebuild
new file mode 100644
index 000000000000..93c7d8d94104
--- /dev/null
+++ b/net-im/gnomeicu/gnomeicu-0.98.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Joshua Pierre <joshua@swool.com>, Maintainer Bart Verwilst <verwilst@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/net-im/gnomeicu/gnomeicu-0.98.ebuild,v 1.2 2002/02/09 11:47:57 verwilst Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome ICQ Client"
+SRC_URI="http://download.sourceforge.net/gnomeicu/${P}.tar.gz"
+HOMEPAGE="http://gnomeicu.sourceforge.net/"
+SLOT="0"
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r2
+ >=sys-libs/gdbm-1.8.0
+ >=gnome-base/libglade-0.16
+ >=media-libs/gdk-pixbuf-0.9.0
+ >=net-libs/gnet-1.1.0
+ esd? ( >=media-sound/esound-0.2.23 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext ) "
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use esd`" ]
+ then
+ myconf="--disable-esd-test"
+ fi
+ if [ "`use socks5`" ];
+ then
+ myconf="${myconf} --enable-socks5"
+ fi
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ mkdir ./intl
+ touch ./intl/libgettext.h
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/log \
+ install || die
+
+ dodoc AUTHORS COPYING CREDITS ChangeLog NEWS README TODO ABOUT-NLS
+}